Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the App-pmuninstall CPAN distribution.

Report information
The Basics
Id: 69737
Status: resolved
Priority: 0/
Queue: App-pmuninstall

People
Owner: XAICRON [...] cpan.org
Requestors: Ben Bullock (no email address)
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 0.18
Fixed in: (no value)



Download (untitled) / with headers
text/plain 540b
App::pmuninstall cannot find things which are in @INC. I installed Chart::Clicker under Perl 5.10.0 and it's in the following directory: /usr/home/ben/software/install/lib/perl5/site_perl/5.10.0/Chart/Clicker. pm After that I installed Perl 5.12.3, and it is using the old Chart::Clicker distribution which is still in the above directory. However, pm-uninstall cannot find it: $ pm-uninstall Chart::Clicker Chart::Clicker is not installed. I have been able to use pm-uninstall for things which are in the 5.12.3 directory though.
Download (untitled) / with headers
text/plain 715b
Hi, I'm sorry slow response. Thank you for report. I tried it, but worked in my environment. please try it: 1. upgrade of App::pmuninstall 0.19 or later. 2. I want results of the following command: $ pm-uninstall -v Chart::Clicker Finding Chart::Clicker in your @INC -> Finding .packlist /home/xaicron/perl5/perlbrew/perls/perl- 5.14.1/lib/site_perl/5.14.1/x86_64-linux/auto/Chart/Clicker/.packlist ... Looking up Chart::Clicker on cpanmetadb -> Finding .packlist /home/xaicron/perl5/perlbrew/perls/perl- 5.14.1/lib/site_perl/5.14.1/x86_64-linux/auto/Chart/Clicker/.packlist ... Chart::Clicker is not installed. 3. and, I want the detailed version information for perl. $ perl -V ... Thank you. -- xaicron
Subject: Re: [rt.cpan.org #69737]
Date: Tue, 23 Aug 2011 05:51:06 +0900
To: bug-App-pmuninstall [...] rt.cpan.org
From: Ben Bullock <benkasminbullock [...] gmail.com>
Download (untitled) / with headers
text/plain 1.6k
Please find the requested data as an attachment. [ben@mikan] {05:47 52} ~ 507 $ perl -MChart::Clicker -e "print $Chart::Clicker::VERSION" Can't locate Moose.pm in @INC (@INC contains: /home/ben/software/install/lib/perl5/site_perl/5.12.3/i386-freebsd /home/ben/software/install/lib/perl5/site_perl/5.12.3 /home/ben/software/install/lib/perl5/5.12.3/i386-freebsd /home/ben/software/install/lib/perl5/5.12.3 /home/ben/software/install/lib/perl5/site_perl/5.10.0 /home/ben/software/install/lib/perl5/site_perl .) at /home/ben/software/install/lib/perl5/site_perl/5.10.0/Chart/Clicker.pm line 2. BEGIN failed--compilation aborted at /home/ben/software/install/lib/perl5/site_perl/5.10.0/Chart/Clicker.pm line 2. Compilation failed in require. BEGIN failed--compilation aborted. On 23 August 2011 03:10, Yuji Shimada via RT <bug-App-pmuninstall@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=69737 > > > Hi, > > I'm sorry slow response. > > Thank you for report. > I tried it, but worked in my environment. > > please try it: > > 1. upgrade of App::pmuninstall 0.19 or later. > > 2. I want results of the following command: > $ pm-uninstall -v Chart::Clicker > Finding Chart::Clicker in your @INC > -> Finding .packlist /home/xaicron/perl5/perlbrew/perls/perl- > 5.14.1/lib/site_perl/5.14.1/x86_64-linux/auto/Chart/Clicker/.packlist > ... > Looking up Chart::Clicker on cpanmetadb > -> Finding .packlist /home/xaicron/perl5/perlbrew/perls/perl- > 5.14.1/lib/site_perl/5.14.1/x86_64-linux/auto/Chart/Clicker/.packlist > ... > Chart::Clicker is not installed. > > 3. and, I want the detailed version information for perl. > $ perl -V > ... > > > > Thank you. > > -- > xaicron >
Download shimada-data
application/octet-stream 4.2k

Message body not shown because it is not plain text.

Download (untitled) / with headers
text/plain 750b
hmmm..., it seems strange to me that your environment. You are using Perl i5.12.1, but why which contains 5.10.0 path? exists `.packlist` to following location? /home/ben/software/install/lib/perl5/site_perl/5.12.3/i386- freebsd/auto/Chart/Clicker/.packlist /home/ben/software/install/lib/perl5/site_perl/5.12.3/auto/Chart/Clicker /.packlist /home/ben/software/install/lib/perl5/5.12.3/i386- freebsd/auto/Chart/Clicker/.packlist /home/ben/software/install/lib/perl5/5.12.3/auto/Chart/Clicker/.packlist /home/ben/software/install/lib/perl5/site_perl/5.10.0/auto/Chart/Clicker /.packlist /home/ben/software/install/lib/perl5/site_perl/auto/Chart/Clicker/.packl ist If you not have it, please tell me where find the .packlsit. Thanks, -- xaicron
Subject: Re: [rt.cpan.org #69737]
Date: Wed, 24 Aug 2011 04:10:48 +0900
To: bug-App-pmuninstall [...] rt.cpan.org
From: Ben Bullock <benkasminbullock [...] gmail.com>
Download (untitled) / with headers
text/plain 1.1k
On 24 August 2011 02:14, Yuji Shimada via RT <bug-App-pmuninstall@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=69737 > > > hmmm..., it seems strange to me that your environment. > You are using Perl i5.12.1, but  why which contains 5.10.0 path?
Because I had 5.10.0 installed before. This was set up by Configure, the script which installs Perl from source code. Show quoted text
> > exists `.packlist` to following location? > > /home/ben/software/install/lib/perl5/site_perl/5.12.3/i386- > freebsd/auto/Chart/Clicker/.packlist > /home/ben/software/install/lib/perl5/site_perl/5.12.3/auto/Chart/Clicker > /.packlist > /home/ben/software/install/lib/perl5/5.12.3/i386- > freebsd/auto/Chart/Clicker/.packlist > /home/ben/software/install/lib/perl5/5.12.3/auto/Chart/Clicker/.packlist > /home/ben/software/install/lib/perl5/site_perl/5.10.0/auto/Chart/Clicker > /.packlist > /home/ben/software/install/lib/perl5/site_perl/auto/Chart/Clicker/.packl > ist > > If you not have it, please tell me where find the .packlsit.
/usr/home/ben/software/install/lib/perl5/site_perl/5.10.0/i386-freebsd/auto/Chart/Clicker/.packlist Show quoted text
> Thanks, > > -- > xaicron > >
Download (untitled) / with headers
text/plain 468b
Show quoted text
> Because I had 5.10.0 installed before. This was set up by Configure, > the script which installs Perl from source code.
I see. However, You should probably add `/usr/home/ben/software/install/lib/perl5/site_perl/5.10.0/i386-freebsd` into @INC. Thereafter, following command: $ pm-uninstall Chart::Clicker OR $ env PERL5LIB=/usr/home/ben/software/install/lib/perl5/site_perl/5.10.0/i386- freebsd pm-uninstall Chart::Clicker Please try it. Thanks. -- xaicron
Subject: Re: [rt.cpan.org #69737]
Date: Thu, 25 Aug 2011 07:36:09 +0900
To: bug-App-pmuninstall [...] rt.cpan.org
From: Ben Bullock <benkasminbullock [...] gmail.com>
Download (untitled) / with headers
text/plain 777b
On 25 August 2011 00:33, Yuji Shimada via RT <bug-App-pmuninstall@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=69737 > >
>> Because I had 5.10.0 installed before. This was set up by Configure, >> the script which installs Perl from source code.
> > I see. > However, You should probably add > `/usr/home/ben/software/install/lib/perl5/site_perl/5.10.0/i386-freebsd` > into @INC. > Thereafter, following command: > $ pm-uninstall Chart::Clicker > > OR > > $ env > PERL5LIB=/usr/home/ben/software/install/lib/perl5/site_perl/5.10.0/i386- > freebsd pm-uninstall Chart::Clicker
Show quoted text
> > Please try it.
This works, but note that as I showed you Perl can find Chart::Clicker with the current @INC, so it's a bug in your module. Show quoted text
> Thanks. > -- > xaicron > >
Maybe fixed this problem at version 0.21. Please retry it. Thanks -- xaicron
Subject: Re: [rt.cpan.org #69737]
Date: Thu, 8 Sep 2011 10:15:42 +0900
To: bug-App-pmuninstall [...] rt.cpan.org
From: Ben Bullock <benkasminbullock [...] gmail.com>
Download (untitled) / with headers
text/plain 541b
Hi again, I have downloaded 0.21 and tried deleting many different things. As far as I can see there is no problem now with deleting from the 5.10.0 directory. Thank you for fixing this bug and thank you for the module which I appreciate. Please consider this bug closed. Best wishes, Ben Bullock On 28 August 2011 03:09, Yuji Shimada via RT <bug-App-pmuninstall@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=69737 > > > Maybe fixed this problem at version 0.21. > Please retry it. > > Thanks > -- > xaicron >
Download (untitled) / with headers
text/plain 688b
It's great! Thanks for your report :) -- xaicron On 2011-9月-07 水 21:15:53, BKB wrote: Show quoted text
> Hi again, > > I have downloaded 0.21 and tried deleting many different things. As > far as I can see there is no problem now with deleting from the 5.10.0 > directory. > > Thank you for fixing this bug and thank you for the module which I > appreciate. > > Please consider this bug closed. > > Best wishes, > > Ben Bullock > > On 28 August 2011 03:09, Yuji Shimada via RT > <bug-App-pmuninstall@rt.cpan.org> wrote:
> > <URL: https://rt.cpan.org/Ticket/Display.html?id=69737 > > > > > Maybe fixed this problem at version 0.21. > > Please retry it. > > > > Thanks > > -- > > xaicron > >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.