Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Perl-Critic CPAN distribution.

Report information
The Basics
Id: 69670
Status: open
Priority: 0/
Queue: Perl-Critic

People
Owner: Nobody in particular
Requestors: dillman [...] ria.buffalo.edu
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Perl::Critic::Policy::Documentation::RequirePodSections and core module Pod::Usage don't play well together out of the box.
Date: Thu, 21 Jul 2011 14:35:07 -0400
To: bug-Perl-Critic [...] rt.cpan.org
From: dillman [...] ria.buffalo.edu
Download (untitled) / with headers
text/plain 649b
This is a minor issue/feature request. Perl::Critic::Policy::Documentation::RequirePodSections wants programs to have a section named "REQUIRED ARGUMENTS". The core module Pod::Usage wants programs to have a section named "ARGUMENTS". While both modules can be reconfigured to use the other's preference, it seems desirable for both modules to play well with each other out of the box. Perhaps Perl::Critic::Policy::Documentation::RequirePodSections could detect when Pod::Usage is loaded, either directly or via Getopt::Long and modify it's defaults? Thomas J. Dillman Research Institute on Addictions 1021 Main Street, Buffalo, NY 14203
Subject: Re: [rt.cpan.org #69670] Perl::Critic::Policy::Documentation::RequirePodSections and core module Pod::Usage don't play well together out of the box.
Date: Thu, 21 Jul 2011 19:25:16 -0500
To: bug-Perl-Critic [...] rt.cpan.org
From: Elliot Shank <perl [...] galumph.com>
Download (untitled) / with headers
text/plain 752b
At this point, I don't think we can change this. From the documentation: "The language option has a default, unnamed value but also accepts values of en_AU and en_US. The reason the unnamed value exists is because the default values for programs don't actually match the book, even taking spelling into account, i.e. CONFIGURATION instead of CONFIGURATION AND ENVIRONMENT, the removal of VERSION, and the addition of EXIT STATUS." When I changed all this stuff, I made an effort to not change anything in order to not produce new violations upon upgrades. There already was an issue with the setup of this policy years ago, which is why it isn't possible to specify a configuration that results in the default behavior. I'd vote against a change.
Subject: Re: [rt.cpan.org #69670] Perl::Critic::Policy::Documentation::RequirePodSections and core module Pod::Usage don't play well together out of the box.
Date: Fri, 22 Jul 2011 09:17:04 -0400
To: bug-Perl-Critic [...] rt.cpan.org
From: dillman [...] ria.buffalo.edu
Fair enough.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.