Skip Menu |
 

This queue is for tickets about the HTTP-Proxy CPAN distribution.

Report information
The Basics
Id: 69559
Status: resolved
Priority: 0/
Queue: HTTP-Proxy

People
Owner: Nobody in particular
Requestors: gilles.quenot [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 0.25
Fixed in: 0.26



Subject: HTTP::Proxy 0.25 make test failed
Download (untitled) / with headers
text/plain 5.9k
Hi, (bonjour) cpan -i refuse to compile both via make or cpan (nor the PKGBUILD of the package for archlinux, I'm the maintener of your module in AUR) $ perl Makefile.PL $ make $ make test PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/00basic.t ......... ok t/01pod.t ........... ok # Failed test 'Pod coverage on HTTP::Proxy' # at /usr/share/perl5/vendor_perl/Test/Pod/Coverage.pm line 126. # Coverage for HTTP::Proxy is 97.2%, with 1 naked subroutine: # ERROR # Failed test 'Pod coverage on HTTP::Proxy::Engine::Threaded' # at /usr/share/perl5/vendor_perl/Test/Pod/Coverage.pm line 126. # Coverage for HTTP::Proxy::Engine::Threaded is 75.0%, with 1 naked subroutine: # worker # Looks like you failed 2 tests of 18. t/02pod-coverage.t .. Dubious, test returned 2 (wstat 512, 0x200) Failed 2/18 subtests t/05new.t ........... ok t/10init.t .......... ok t/11log.t ........... ok maxconn is deprecated, please use max_connections at t/15accessors.t line 42 maxserve is deprecated, please use max_keep_alive_requests at t/15accessors.t line 42 t/15accessors.t ..... ok t/15deprecated.t .... ok t/16stash.t ......... ok t/17fstack.t ........ ok t/18engine.t ........ ok t/20dummy.t ......... ok t/20keepalive.t ..... ok t/22http.t .......... ok t/22transparent.t ... ok t/23connect.t ....... skipped: Unable to make this test work correctly t/23https.t ......... skipped: Can't make this work with Crypt::SSLeay t/40push_filters.t .. ok t/41filters.t ....... ok t/42will_modify.t ... ok t/50hopbyhop.t ...... ok t/50standard.t ...... ok t/50via.t ........... ok t/51simple.t ........ ok t/51simple2.t ....... ok t/61simple.t ........ ok t/61simple2.t ....... ok Use of "goto" to jump into a construct is deprecated at /tmp/HTTP-Proxy- 0.25/blib/lib/HTTP/Proxy/BodyFilter/htmltext.pm line 32. t/64htmltext.t ...... ok t/64lines.t ......... ok t/64tags.t .......... ok t/66htmlparser.t .... ok t/67complete.t ...... ok t/67save.t .......... ok Use of "goto" to jump into a construct is deprecated at /tmp/HTTP-Proxy- 0.25/blib/lib/HTTP/Proxy/BodyFilter/htmltext.pm line 32. t/71rot13.t ......... ok t/90diveintomark.t .. skipped: http://diveintomark.org/tests/client/http seems to have stopped working Test Summary Report ------------------- t/02pod-coverage.t (Wstat: 512 Tests: 18 Failed: 2) Failed tests: 1, 17 Non-zero exit status: 2 Files=35, Tests=450, 12 wallclock secs ( 0.11 usr 0.04 sys + 3.30 cusr 0.67 csys = 4.12 CPU) Result: FAIL Failed 1/35 test programs. 2/450 subtests failed. make: *** [test_dynamic] Error 255 I use archlinux x86_64 and a fresh "cpan -u" upgrade (success) This is my perl -V : Summary of my perl5 (revision 5 version 14 subversion 1) configuration: Platform: osname=linux, osvers=2.6.39-arch, archname=x86_64-linux-thread-multi uname='linux foutbox 2.6.39-arch #1 smp preempt mon jun 27 21:26:22 cest 2011 x86_64 amd phenom(tm) ii x6 1090t processor authenticamd gnulinux ' config_args='-des -Dusethreads -Duseshrplib -Doptimize=-march=x86-64 -mtune=generic -O2 -pipe -Dprefix=/usr -Dinstallprefix=/usr - Dvendorprefix=/usr -Dprivlib=/usr/share/perl5/core_perl - Darchlib=/usr/lib/perl5/core_perl -Dsitelib=/usr/share/perl5/site_perl - Dsitearch=/usr/lib/perl5/site_perl - Dvendorlib=/usr/share/perl5/vendor_perl - Dvendorarch=/usr/lib/perl5/vendor_perl -Dscriptdir=/usr/bin/core_perl - Dsitescript=/usr/bin/site_perl -Dvendorscript=/usr/bin/vendor_perl - Dinc_version_list=none -Dman1ext=1perl -Dman3ext=3perl -Dcccdlflags='- fPIC' -Dlddlflags=-shared -Wl,--hash-style=gnu -Wl,--as-needed - Dldflags=-Wl,--hash-style=gnu -Wl,--as-needed' hint=recommended, useposix=true, d_sigaction=define useithreads=define, usemultiplicity=define useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef use64bitint=define, use64bitall=define, uselongdouble=undef usemymalloc=n, bincompat5005=undef Compiler: cc='cc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing - pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE - D_FILE_OFFSET_BITS=64', optimize='-march=x86-64 -mtune=generic -O2 -pipe', cppflags='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe - fstack-protector -I/usr/local/include' ccversion='', gccversion='4.6.1', gccosandvers='' intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678 d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16 ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8 alignbytes=8, prototype=define Linker and Libraries: ld='cc', ldflags ='-Wl,--hash-style=gnu -Wl,--as-needed -fstack- protector -L/usr/local/lib' libpth=/usr/local/lib /lib/../lib /usr/lib/../lib /lib /usr/lib libs=-lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lpthread -lc - lgdbm_compat perllibs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc libc=/lib/libc-2.14.so, so=so, useshrplib=true, libperl=libperl.so gnulibc_version='2.14' Dynamic Linking: dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E - Wl,-rpath,/usr/lib/perl5/core_perl/CORE' cccdlflags='-fPIC', lddlflags='-shared -Wl,--hash-style=gnu -Wl,-- as-needed -L/usr/local/lib -fstack-protector' Characteristics of this binary (from libperl): Compile-time options: MULTIPLICITY PERL_DONT_CREATE_GVSV PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP PERL_PRESERVE_IVUV USE_64_BIT_ALL USE_64_BIT_INT USE_ITHREADS USE_LARGE_FILES USE_PERLIO USE_PERL_ATOF USE_REENTRANT_API Built under linux Compiled at Jun 29 2011 17:17:44 @INC: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl . $ uname -a Linux FreAkyLab 2.6.38-ARCH #1 SMP PREEMPT Fri Apr 22 20:29:33 CEST 2011 x86_64 Intel(R) Core(TM)2 Quad CPU Q9650 @ 3.00GHz GenuineIntel GNU/Linux Salut, sputnick aka Gilles Quenot.
From: gilles.quenot [...] gmail.com
Download (untitled) / with headers
text/plain 562b
Last but not least, the dependencies are up to date : root@FreAkyLab:# cpan -i Test::More Going to read '/root/.cpan/Metadata' Database was generated on Sun, 17 Jul 2011 21:28:36 GMT Test::More is up to date (0.98). root@FreAkyLab:# cpan -i HTTP::Daemon Going to read '/root/.cpan/Metadata' Database was generated on Sun, 17 Jul 2011 21:28:36 GMT HTTP::Daemon is up to date (6.00). root@FreAkyLab:# cpan -i LWP::UserAgent Going to read '/root/.cpan/Metadata' Database was generated on Sun, 17 Jul 2011 21:28:36 GMT LWP::UserAgent is up to date (6.02).


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.