Skip Menu |
 

This queue is for tickets about the CPANPLUS CPAN distribution.

Report information
The Basics
Id: 69384
Status: resolved
Worked: 30 min
Priority: 0/
Queue: CPANPLUS

People
Owner: BINGOS [...] cpan.org
Requestors: tour [...] jeroen.la
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: CPANPLUS does not parse v-strings (v1.2.3) in dependencies
Download (untitled) / with headers
text/plain 921b
I was testing File-Pairtree-v0.302.0 a few weeks back, and got the following output: Warning: prerequisite File::Namaste v0.260.0 not found. Warning: prerequisite File::OM 0.21 not found. Warning: prerequisite File::Value v0.250.0 not found. Writing Makefile for File::Pairtree [MSG] Module 'File::Pairtree' requires 'File::Namaste' version '0.0' to be installed [MSG] Module 'File::Pairtree' requires 'File::OM' version '0.21' to be installed [MSG] Module 'File::Pairtree' requires 'File::Value' version '0.0' to be installed CPANPLUS is not parsing the versions for File::Namaste and File::Value. The result is that CPANPLUS will not upgrade these prerequisites, if an older version exists. I've changed the version code to use the version module in these cases. My changes are visible at: https://github.com/jeroenl/cpanplus- devel/commit/4ecd894cb31f6efe1260451b7afade6e45ae6f9a I'll submit a pull request.
From: tour [...] jeroen.la
Download (untitled) / with headers
text/plain 199b
By the way, before I patched this, there was a discussion on cpan-testers- discuss whether this was simply something the module author needed to change: http://markmail.org/message/ub262pt6qnvqbpnh
Thanks. This should be resolved with the latest release (0.9107)


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.