Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Devel-Cover CPAN distribution.

Report information
The Basics
Id: 68991
Status: resolved
Priority: 0/
Queue: Devel-Cover

People
Owner: Nobody in particular
Requestors: HMBRAND [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: (no value)
Fixed in: (no value)



Subject: t/e2e epic fail when prefix for perl is not the physical location
Download (untitled) / with headers
text/plain 1.1k
When perl has been configured for prefix /opt/perl64 (or whatever) and that actually is a symbolic link to /opt2/perl64 (or whatever), Devel::Cover will fail: t/e2e/at1.t ................. ok # Test 7 got: "/opt2/perl64/lib/5.14.1/B/Debug.pm 0.0 0.0 0.0 0.0 0.0\n" (/opt2/perl64/.cpan/build/Devel-Cover-0.78- vNv3al/blib/lib/Devel/Cover/Test.pm at line 303 fail #7) <Tux> # Expected: "tests/t2 93.8 50.0 n/a 100.0 84.0\n" <Tux> # /opt2/perl64/.cpan/build/Devel-Cover-0.78-vNv3al/blib/lib/ Devel/Cover/Test.pm line 303 is: $ENV {DEVEL_COVER_NO_COVERAGE} ? ok 1 : ok $t, $c; <Tux> # Test 8 got: "/opt2/perl64/lib/5.14.1/B/Deparse.pm 0.0 0.0 0.0 0.0 0.0\n" (/opt2/perl64/.cpan/build/Devel- Cover-0.78-vNv3al/blib/lib/Devel/Cover/Test.pm at line 303 fail #8) The reason for this symbolic link is that the perl built should be known at /opt/perl64 so it can be in a worldwide available binary distribution that expect /opt as base (and not /opt2). The system I am building on however does not have enough space, so it symlinks to another disk. So far Devel::Cover is the only packages that suffers from this construct
Download (untitled) / with headers
text/plain 269b
I think this is fixed with f650a35. If you have a chance to test it from git (https://github.com/pjcj/Devel--Cover) I'd be very grateful. I'm going to close this ticket, but if there are still problems in this area, please fell free to reopen it. Thanks very much.
Download (untitled) / with headers
text/plain 1.7k
On Fri Jul 13 21:00:32 2012, PJCJ wrote: Show quoted text
> I think this is fixed with f650a35. If you have a chance to test it
from Show quoted text
> git (https://github.com/pjcj/Devel--Cover) I'd be very grateful.
Could not get that with git version 1.7.0.2 from the machine in question so I cloned it elsewhere and rsynced $ ux HP-UX 11.00/64 U A500-7X/64 PA8700/750(2) pa-2.0 2048 Mb $ which gperl64 /u/usr/merijn/bin/gperl64 $ ll /u/usr/merijn/bin/gperl64 4429 lrwxrwxrwx 1 merijn softwr 31 Apr 22 2004 /u/usr/merijn/bin/ gperl64 -> ../../../../opt/perl64/bin/perl $ ll /opt/perl64 9739 lrwxrwxrwx 1 root sys 14 Jan 9 2007 /opt/perl64 -> ../opt2/perl64 $ gperl64 -v|grep v5 This is perl 5, version 16, subversion 0 (v5.16.0) built for PA-RISC2.0- LP64 $ gperl64 Makefile.PL : checking for Storable .... 2.34 /opt/ perl64/lib/5.16.0/PA-RISC2.0-LP64/Storable.pm checking for JSON .... 2.53 /opt/ perl64/lib/site_perl/5.16.0/JSON.pm checking for JSON::PP .... 2.27200 /opt/ perl64/lib/5.16.0/JSON/PP.pm checking for Digest::MD5 .... 2.51 /opt/ perl64/lib/5.16.0/PA-RISC2.0-LP64/Digest/MD5.pm checking for Test::More .... 0.98 /opt/ perl64/lib/5.16.0/Test/More.pm checking for Test::Warn .... 0.24 /opt/ perl64/lib/site_perl/5.16.0/Test/Warn.pm checking for Template version 2.00 .... not found : checking for PPI::HTML version 1.07 .... not found : checking for Browser::Open .... not found : $ make : $ make test : All tests successful. Files=54, Tests=4371, 191 wallclock secs ( 2.62 usr 0.47 sys + 150.51 cusr 15.92 csys = 169.52 CPU) Result: PASS pjcj++


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.