Skip Menu |
 

This queue is for tickets about the Archive-Zip CPAN distribution.

Report information
The Basics
Id: 6897
Status: resolved
Priority: 0/
Queue: Archive-Zip

People
Owner: Nobody in particular
Requestors: jean.marie.gouarne [...] online.fr
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 1_11
Fixed in: (no value)



Subject: Version numbering
Download (untitled) / with headers
text/plain 860b
Hi, The version number of the last Archive::Zip distro (took from the Zip.pm version number) is written "1_11", while it was written "1.10" in the preceding one. It should be "1.11" and not "1_11", because (in Perl speaking), "1_11" is less than "1.10" (more precisely, "1_11" is less than "1.01"). So, any Perl application that requires Archive::Zip 1.0x with x >= 1 fails if Archive::Zip "1_11" is installed. In order to run such an application, the version control must be removed form any "use Archive::Zip" statement. For example, I've recently released to the CPAN a module (OpenOffice-OODoc) that uses Archive::Zip >= 1.05; it works with any Archive::Zip from 1.05 to 1.10 but fails on any platform where "1_11" is installed. So, I got a lot of "FAIL" install reports with messages such as "prerequisite Archive::Zip 1.05 not found. We have 1_11" :-\
Download (untitled) / with headers
text/plain 602b
[guest - Thu Jul 8 12:28:43 2004]: Show quoted text
> For example, I've recently released to the CPAN a module (OpenOffice- > OODoc) that uses Archive::Zip >= 1.05; it works with any > Archive::Zip from 1.05 to 1.10 but fails on any platform where > "1_11" is installed. So, I got a lot of "FAIL" install reports with > messages such as "prerequisite Archive::Zip 1.05 not found. We have > 1_11" :-\
Sorry about that. The convention on CPAN is to regard any module with an underscore in its name as "not a release", but I forgot about version comparisons. I will release a new version of 1.11 soon.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.