Skip Menu |
 

This queue is for tickets about the Test-WWW-Selenium CPAN distribution.

Report information
The Basics
Id: 68874
Status: open
Priority: 0/
Queue: Test-WWW-Selenium

People
Owner: Nobody in particular
Requestors: vid [...] svaksha.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Harness test for Test::WWW::Selenium fails
Date: Thu, 16 Jun 2011 17:43:55 +0000
To: bug-Test-WWW-Selenium [...] rt.cpan.org
From: ॥ स्वक्ष ॥ <vid [...] svaksha.com>
Download (untitled) / with headers
text/plain 6.7k
http://paste.pocoo.org/show/406962/ $cpanm Test::WWW::Selenium cpanm (App::cpanminus) 1.4007 on perl 5.010001 built for i486-linux-gnu-thread-multi Work directory is /home/mom/.cpanm/work/1307991813.8654 You have make /usr/bin/make You have LWP 6.02 You have /bin/tar: tar (GNU tar) 1.22 Copyright (C) 2009 Free Software Foundation, Inc. License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>. This is free software: you are free to change and redistribute it. There is NO WARRANTY, to the extent permitted by law. Written by John Gilmore and Jay Fenlason. You have /usr/bin/unzip Searching Test::WWW::Selenium on cpanmetadb ... Checking if you have ExtUtils::MakeMaker 6.31 ... Yes (6.55_02) Checking if you have ExtUtils::Install 1.46 ... Yes (1.54) Checking if you have Module::Build 0.36 ... Yes (0.3800) --> Working on Test::WWW::Selenium Fetching http://search.cpan.org/CPAN/authors/id/M/MA/MATTP/Test-WWW-Selenium-1.25.tar.gz -> OK Unpacking Test-WWW-Selenium-1.25.tar.gz Entering Test-WWW-Selenium-1.25 Checking configure dependencies from META.yml Checking if you have ExtUtils::MakeMaker 6.31 ... Yes (6.55_02) Configuring Test-WWW-Selenium-1.25 Running Makefile.PL Checking if your kit is complete... Looks good Writing Makefile for Test::WWW::Selenium -> OK Finding PREREQ from Makefile ... Checking if you have Test::Exception 0 ... Yes (0.31) Checking if you have Test::Mock::LWP 0 ... Yes (0.05) Checking if you have FindBin 0 ... Yes (1.50) Checking if you have URI::Escape 0 ... Yes (3.29) Checking if you have File::Spec 0 ... Yes (3.30) Checking if you have Time::HiRes 0 ... Yes (1.9719) Checking if you have Exporter 0 ... Yes (5.63) Checking if you have Test::Builder::Tester 0 ... Yes (1.22) Checking if you have Carp 0 ... Yes (1.11) Checking if you have Test::More 0 ... Yes (0.98) Checking if you have LWP::UserAgent 0 ... Yes (6.02) Checking if you have IO::Socket 0 ... Yes (1.31) Checking if you have Test::Builder 0 ... Yes (0.98) Checking if you have HTTP::Headers 0 ... Yes (6.00) Checking if you have File::Find 0 ... Yes (1.14) Checking if you have File::Temp 0 ... Yes (0.22) Checking if you have HTTP::Request 0 ... Yes (6.00) Building and testing Test-WWW-Selenium-1.25 cp lib/WWW/Selenium.pm blib/lib/WWW/Selenium.pm cp mypod2html.pl blib/lib/Test/WWW/mypod2html.pl cp lib/Test/WWW/Selenium.pm blib/lib/Test/WWW/Selenium.pm cp lib/WWW/Selenium/Util.pm blib/lib/WWW/Selenium/Util.pm Manifying blib/man3/WWW::Selenium.3pm Manifying blib/man3/Test::WWW::Selenium.3pm Manifying blib/man3/WWW::Selenium::Util.3pm PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/00-compile.t ........... ok t/01_load.t .............. ok t/interweb.t ............. skipped: not running live interweb tests # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Looks like you failed 1 test of 27. t/selenium-compat.t ...... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/27 subtests # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Looks like you failed 1 test of 151. t/selenium-core.t ........ Dubious, test returned 1 (wstat 256, 0x100) Failed 1/151 subtests # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Looks like you failed 7 tests of 30. t/selenium-dwim.t ........ Dubious, test returned 7 (wstat 1792, 0x700) Failed 7/30 subtests # Failed test at t/selenium-rc.t line 151. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Ffoo.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Ffoo.com' # Looks like you failed 1 test of 50. t/selenium-rc.t .......... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/50 subtests t/test-selenium.t ........ ok t/test_default_server.t .. skipped: No selenium server found! t/test_google.t .......... skipped: No selenium server found! t/test_i18n.t ............ skipped: No selenium server found! # Failed test at t/WWW/Selenium.pm line 40. # got: 'cmd=getNewBrowserSession&1=*firefox&2=http%3A%2F%2Fexample.com' # expected: 'cmd=getNewBrowserSession&1=%2Afirefox&2=http%3A%2F%2Fexample.com' # Looks like you failed 1 test of 5. t/timeouts.t ............. Dubious, test returned 1 (wstat 256, 0x100) Failed 1/5 subtests Test Summary Report ------------------- t/selenium-compat.t (Wstat: 256 Tests: 27 Failed: 1) Failed test: 4 Non-zero exit status: 1 t/selenium-core.t (Wstat: 256 Tests: 151 Failed: 1) Failed test: 5 Non-zero exit status: 1 t/selenium-dwim.t (Wstat: 1792 Tests: 30 Failed: 7) Failed tests: 4, 8, 13, 17, 21, 25, 29 Non-zero exit status: 7 t/selenium-rc.t (Wstat: 256 Tests: 50 Failed: 1) Failed test: 13 Non-zero exit status: 1 t/timeouts.t (Wstat: 256 Tests: 5 Failed: 1) Failed test: 4 Non-zero exit status: 1 Files=12, Tests=332, 2 wallclock secs ( 0.10 usr 0.03 sys + 1.60 cusr 0.16 csys = 1.89 CPU) Result: FAIL Failed 5/12 test programs. 11/332 subtests failed. make: *** [test_dynamic] Error 1 -> FAIL Installing Test::WWW::Selenium failed. See /home/mom/.cpanm/build.log for details. -- vid ॥ http://svaksha.com
Download (untitled) / with headers
text/plain 232b
I'm not fully sure what's happening here, but I suspect it is safe to ignore. It looks like * is being translated somewhere along the line, and the hardcoded expected return isn't matching. Has this affected your usage of selenium?


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.