Skip Menu |
 

This queue is for tickets about the minismokebox CPAN distribution.

Report information
The Basics
Id: 68608
Status: open
Priority: 0/
Queue: minismokebox

People
Owner: Nobody in particular
Requestors: njh [...] bandsman.co.uk
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 0.50
Fixed in: (no value)



Subject: Requires broken pre-requisite POE::XS::Loop::Poll
Download (untitled) / with headers
text/plain 3.2k
Trying to upgrade to 0.50 fails because of a dependency POE::XS::Loop::Poll, which is a broken module on MacOS. I realise that the problem is with POE::XS::Loop::Poll, not with minismokebox, unfortunately the author of that hasn't released a fix even though it's been logged at http://www.cpantesters.org/cpan/report/4f700f9c-8b9a-11e0-b49a-291920b1acdd so perhaps you could avoid its use? Here is the problem: ... CPAN.pm: Going to build B/BI/BINGOS/minismokebox-0.50.tar.gz CPAN: CPAN::Reporter loaded ok (v1.1902) Checking if your kit is complete... Looks good Warning: prerequisite POE::XS::Loop::Poll 1 not found. Writing Makefile for minismokebox (/usr/bin/perl Makefile.PL PREFIX=~/perl DESTDIR=~/perl exited with 0) CPAN::Reporter: Makefile.PL result is 'pass', No errors. Could not read metadata file. Falling back to other methods to determine prerequisites Show quoted text
---- Unsatisfied dependencies detected during ---- ---- BINGOS/minismokebox-0.50.tar.gz ---- POE::XS::Loop::Poll [requires] Running make test Delayed until after prerequisites Running make install Delayed until after prerequisites Running install for module 'POE::XS::Loop::Poll' Running make for T/TO/TONYC/POE-XS-Loop-Poll-1.000.tar.gz Has already been unwrapped into directory /Users/nigel/.cpan/build/POE-XS-Loop-Poll-1.000-JDYNNo Has already been made Running make test PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/poe_xs_loop_poll/*.t # Testing POE 1.311, POE::Test::Loops 1.311, Using Loop(POE::XS::Loop::Poll), Perl 5.010000, /usr/bin/perl on darwin t/poe_xs_loop_poll/00_info.t ....................... ok t/poe_xs_loop_poll/all_errors.t .................... skipped: most of these should move into other test files t/poe_xs_loop_poll/comp_tcp.t ...................... ok # You might see a 'disconnect' error during this test. # It may be ignored. t/poe_xs_loop_poll/comp_tcp_concurrent.t ........... ok t/poe_xs_loop_poll/connect_errors.t ................ ok t/poe_xs_loop_poll/k_alarms.t ...................... ok t/poe_xs_loop_poll/k_aliases.t ..................... ok t/poe_xs_loop_poll/k_detach.t ...................... ok t/poe_xs_loop_poll/k_run_returns.t ................. ok t/poe_xs_loop_poll/k_selects.t ..................... ok # Waiting 2 seconds for child processes to settle. t/poe_xs_loop_poll/k_sig_child.t ................... ok # Waiting 2 seconds for child processes to settle. t/poe_xs_loop_poll/k_signals.t ..................... ok t/poe_xs_loop_poll/k_signals_rerun.t ............... ok t/poe_xs_loop_poll/sbk_signal_init.t ............... ok t/poe_xs_loop_poll/ses_nfa.t ....................... ok # This test generates some STDERR during trace testing. === 35467 === 23 -> _start (from /Users/nigel/perl/lib/perl5/site_perl/POE/Kernel.pm at 1413) === 35467 === 23 -> woot (from /Users/nigel/perl/lib/perl5/site_perl/POE/Test/Loops/ses_session.pm at 706) === 35467 === 23 -> narf (from /Users/nigel/perl/lib/perl5/site_perl/POE/Kernel.pm at 1816) === 35467 === 23 -> _stop (from /Users/nigel/perl/lib/perl5/site_perl/POE/Resource/Sessions.pm at 571) t/poe_xs_loop_poll/ses_session.t ................... ok t/poe_xs_loop_poll/wheel_accept.t .................. ok t/poe_xs_loop_poll/wheel_curses.t .................. skipped: Curses not available At which point the testing *hangs*.
Subject: Re: [rt.cpan.org #68608] Requires broken pre-requisite POE::XS::Loop::Poll
Date: Fri, 3 Jun 2011 13:16:31 +0100
To: "njh [...] bandsman.co.uk via RT" <bug-minismokebox [...] rt.cpan.org>
From: "Chris 'BinGOs' Williams" <chris [...] bingosnet.co.uk>
Download (untitled) / with headers
text/plain 1.1k
On Thu, Jun 02, 2011 at 10:11:04AM -0400, njh@bandsman.co.uk via RT wrote: Show quoted text
> Thu Jun 02 10:11:03 2011: Request 68608 was acted upon. > Transaction: Ticket created by njh@bandsman.co.uk > Queue: minismokebox > Subject: Requires broken pre-requisite POE::XS::Loop::Poll > Broken in: 0.50 > Severity: Critical > Owner: Nobody > Requestors: njh@bandsman.co.uk > Status: new > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=68608 > > > > Trying to upgrade to 0.50 fails because of a dependency > POE::XS::Loop::Poll, which is a broken module on MacOS. > > I realise that the problem is with POE::XS::Loop::Poll, not with > minismokebox, unfortunately the author of that hasn't released a fix > even though it's been logged at > http://www.cpantesters.org/cpan/report/4f700f9c-8b9a-11e0-b49a-291920b1acdd > so perhaps you could avoid its use? >
This wasn't something I realised, thanks for spotting it. 0.54 should be on CPAN now and will use POE::Loop::Event on MacOSX. ( ignore 0.52, I messed up ). Cheers, -- Chris Williams aka BinGOs PGP ID 0x4658671F http://www.gumbynet.org.uk ==========================
Download (untitled)
application/pgp-signature 189b

Message body not shown because it is not plain text.

From: njh [...] bandsman.co.uk
Looks good - thanks.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.