Skip Menu |
 

This queue is for tickets about the Geo-Coder-Googlev3 CPAN distribution.

Report information
The Basics
Id: 68343
Status: rejected
Priority: 0/
Queue: Geo-Coder-Googlev3

People
Owner: Nobody in particular
Requestors: bart [...] procolix.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: missing dependancy dommon::sense
Date: Fri, 20 May 2011 17:45:03 +0200
To: bug-Geo-Coder-Googlev3 [...] rt.cpan.org
From: Bart Jol <bart [...] procolix.com>
Download (untitled) / with headers
text/plain 5.1k
Hi, I had a problem with installing Geo::Coder::Googlev3 on debian (lenny) perl This is perl, v5.10.1 (*) built for i686-linux My problem was fixed by installing common::sense (http://search.cpan.org/~mlehmann/common-sense-3.4/sense.pm.PL ) This was the build/test output (cpan is called by a script that checks dependancies for WebGUI, a CMS) Attempting to install Geo::Coder::Googlev3... Going to read '/root/.cpan/Metadata' Database was generated on Fri, 15 Apr 2011 10:31:00 GMT Warning: no success downloading '/root/.cpan/sources/authors/01mailrc.txt.gz.tmp16205'. Giving up on it. at /data/wre/prereqs/lib/perl5/5.10.1/CPAN/Index.pm line 225 Fetching with LWP: http://www.perl.org/CPAN/authors/01mailrc.txt.gz CPAN: YAML loaded ok (v0.68) Going to read '/root/.cpan/sources/authors/01mailrc.txt.gz' ............................................................................DONE Fetching with LWP: http://www.perl.org/CPAN/modules/02packages.details.txt.gz Going to read '/root/.cpan/sources/modules/02packages.details.txt.gz' Database was generated on Fri, 20 May 2011 15:29:52 GMT ............... New CPAN.pm version (v1.9600) available. [Currently running version is v1.9402] You might want to try install CPAN reload cpan to both upgrade CPAN.pm and run the new version without leaving the current session. .............................................................DONE Fetching with LWP: http://www.perl.org/CPAN/modules/03modlist.data.gz Going to read '/root/.cpan/sources/modules/03modlist.data.gz' ............................................................................DONE Going to write /root/.cpan/Metadata Running install for module 'Geo::Coder::Googlev3' Running make for S/SR/SREZIC/Geo-Coder-Googlev3-0.07.tar.gz Fetching with LWP: http://www.perl.org/CPAN/authors/id/S/SR/SREZIC/Geo-Coder-Googlev3-0.07.tar.gz Fetching with LWP: http://www.perl.org/CPAN/authors/id/S/SR/SREZIC/CHECKSUMS Checksum for /root/.cpan/sources/authors/id/S/SR/SREZIC/Geo-Coder-Googlev3-0.07.tar.gz ok Will not use Archive::Tar, need 1.00 Geo-Coder-Googlev3-0.07/ Geo-Coder-Googlev3-0.07/MANIFEST Geo-Coder-Googlev3-0.07/.gitignore Geo-Coder-Googlev3-0.07/t/ Geo-Coder-Googlev3-0.07/lib/ Geo-Coder-Googlev3-0.07/Changes Geo-Coder-Googlev3-0.07/README Geo-Coder-Googlev3-0.07/Makefile.PL Geo-Coder-Googlev3-0.07/META.yml Geo-Coder-Googlev3-0.07/lib/Geo/ Geo-Coder-Googlev3-0.07/lib/Geo/Coder/ Geo-Coder-Googlev3-0.07/lib/Geo/Coder/Googlev3.pm Geo-Coder-Googlev3-0.07/t/geocode.t CPAN.pm: Going to build S/SR/SREZIC/Geo-Coder-Googlev3-0.07.tar.gz Checking if your kit is complete... Looks good Warning: prerequisite JSON::XS 0 not found. Writing Makefile for Geo::Coder::Googlev3 cp lib/Geo/Coder/Googlev3.pm blib/lib/Geo/Coder/Googlev3.pm Manifying blib/man3/Geo::Coder::Googlev3.3 SREZIC/Geo-Coder-Googlev3-0.07.tar.gz /usr/bin/make -- OK Running make test PERL_DL_NONLAZY=1 /data/wre/prereqs/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/geocode.t .. 1/30 # Failed test 'use Geo::Coder::Googlev3;' # at t/geocode.t line 10. # Tried to use 'Geo::Coder::Googlev3'. # Error: Can't locate common/sense.pm in @INC (@INC contains: /root/.cpan/build/Geo-Coder-Googlev3-0.07-_TQjRk/blib/lib /root/.cpan/build/Geo-Coder-Googlev3-0.07-_TQjRk/blib/arch /data/WebGUI/lib /data/WebGUI/lib /data/wre/prereqs/lib/perl5/5.10.1/i686-linux /data/wre/prereqs/lib/perl5/5.10.1 /data/wre/prereqs/lib/perl5/site_perl/5.10.1/i686-linux /data/wre/prereqs/lib/perl5/site_perl/5.10.1 .) at /data/wre/prereqs/lib/perl5/site_perl/5.10.1/i686-linux/JSON/XS.pm line 104. # BEGIN failed--compilation aborted at /data/wre/prereqs/lib/perl5/site_perl/5.10.1/i686-linux/JSON/XS.pm line 104. # Compilation failed in require at /root/.cpan/build/Geo-Coder-Googlev3-0.07-_TQjRk/blib/lib/Geo/Coder/Googlev3.pm line 19. # BEGIN failed--compilation aborted at /root/.cpan/build/Geo-Coder-Googlev3-0.07-_TQjRk/blib/lib/Geo/Coder/Googlev3.pm line 19. # Compilation failed in require at (eval 4) line 2. # BEGIN failed--compilation aborted at (eval 4) line 2. Can't locate object method "new" via package "Geo::Coder::Googlev3" at t/geocode.t line 12. # Looks like you planned 30 tests but ran 1. # Looks like you failed 1 test of 1 run. # Looks like your test exited with 255 just after 1. t/geocode.t .. Dubious, test returned 255 (wstat 65280, 0xff00) Failed 30/30 subtests Test Summary Report ------------------- t/geocode.t (Wstat: 65280 Tests: 1 Failed: 1) Failed test: 1 Non-zero exit status: 255 Parse errors: Bad plan. You planned 30 tests but ran 1. Files=1, Tests=1, 0 wallclock secs ( 0.02 usr 0.00 sys + 0.03 cusr 0.02 csys = 0.07 CPU) Result: FAIL Failed 1/1 test programs. 1/1 subtests failed. make: *** [test_dynamic] Error 255 SREZIC/Geo-Coder-Googlev3-0.07.tar.gz /usr/bin/make test -- NOT OK //hint// to see the cpan-testers results for installing this module, try: reports SREZIC/Geo-Coder-Googlev3-0.07.tar.gz Running make install make test had returned bad status, won't install without force Checking for module Geo::Coder::Googlev3: Install of Geo::Coder::Googlev3 failed! Kind regards Bart
Subject: Re: [rt.cpan.org #68343] AutoReply: missing dependancy dommon::sense
Date: Fri, 20 May 2011 17:48:59 +0200
To: bug-Geo-Coder-Googlev3 [...] rt.cpan.org
From: Bart Jol <bart [...] procolix.com>
Download (untitled) / with headers
text/plain 123b
Sorry, forgot the uname -a output Linux myhostname 2.6.29-xs5.5.0.17 #1 SMP Mon Aug 3 17:37:37 UTC 2009 i686 GNU/Linux
Download (untitled) / with headers
text/plain 524b
On 2011-05-20 11:42:17, bart@procolix.com wrote: Show quoted text
> Hi, > > I had a problem with installing Geo::Coder::Googlev3 on debian (lenny) > perl This is perl, v5.10.1 (*) built for i686-linux > > My problem was fixed by installing common::sense > (http://search.cpan.org/~mlehmann/common-sense-3.4/sense.pm.PL ) >
Geo::Coder::Googlev3 does not use common::sense directly. But it does use JSON::XS, which in turn probably uses common::sense. So I suspect that the problem happened while installing JSON::XS. Regards, Slaven


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.