Skip Menu |
 

This queue is for tickets about the CPANPLUS CPAN distribution.

Report information
The Basics
Id: 68004
Status: open
Priority: 0/
Queue: CPANPLUS

People
Owner: Nobody in particular
Requestors: dolmen [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.9105
Fixed in: (no value)



Subject: "make install" after "Build test" with URI-FromHash-0.03
Download (untitled) / with headers
text/plain 9.6k
I have prefer_makefile => '' (which means I prefer Build.PL). When installing the distibution URI-FromHash-0.03 that has both Makefile.PL and Build.PL it looks like CPANPLUS starts with Build.PL but tries to do "install" using make. This is CPANPLUS 0.9105 on MSWin32 with Strawberry Perl 5.12.1.0 ---------------------------------------------------------------- CPAN Terminal> s conf allow_build_interactivity '1' base 'PRIVACY\.cpanplus' buildflags '' cpantest '1' cpantest_mx '' cpantest_reporter_args {'transport_args' => ['uri','https://metabase.cpantesters.org/api/v1','id_file','PRIVACY\\.cpanreporter\\metabase_id.json'],'transport' => 'Metabase'} debug '' dist_type '' email 'cpanplus@example.com' enable_custom_sources '1' extractdir '' fetchdir '' flush '1' force '' lib [] makeflags '' makemakerflags '' md5 '1' no_update '' passive '' prefer_bin '' prefer_makefile '' prereqs '3' shell 'CPANPLUS::Shell::Default' show_startup_tip '1' signature '1' skiptest '' source_engine 'CPANPLUS::Internals::Source::SQLite' storable '1' timeout '300' verbose '1' write_install_logs '1' CPAN Terminal> i Dist::Zilla::Plugin::GithubMeta Installing Dist::Zilla::Plugin::GithubMeta (0.12) [MSG] Using cached file 'PRIVACY\.cpanplus\authors\id\B\ BI\BINGOS\CHECKSUMS' on disk; ttl (3600s) is not exceeded [MSG] Checksum matches for 'Dist-Zilla-Plugin-GithubMeta-0.12.tar.gz' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/README' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/LICENSE' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/Changes' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/dist.ini' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/META.yml' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/MANIFEST' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/t' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/t/basic.t' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/META.json' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/Makefile.PL' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/t/00-compile.t' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/HEAD' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/config' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/description' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/refs' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/refs/ignore' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/t/release-pod-syntax.t' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/info' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/info/exclude' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/GHM-Sample' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/GHM-Sample/ignore' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/t/release-pod-coverage.t' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/objects' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/objects/ignore' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/branches' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/branches/ignore' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/hooks' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/hooks/update.sampl e' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/hooks/commit-msg.s ample' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/hooks/pre-commit.s ample' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/hooks/pre-rebase.s ample' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/lib/Dist/Zilla/Plugin' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/lib/Dist/Zilla/Plugin/GithubM eta.pm' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/hooks/post-commit. sample' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/hooks/post-update. sample' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/hooks/post-receive .sample' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/hooks/applypatch-m sg.sample' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/hooks/pre-applypat ch.sample' [MSG] Extracted 'Dist-Zilla-Plugin-GithubMeta-0.12/corpus/git/hooks/prepare-comm it-msg.sample' [MSG] Extracted 'Dist::Zilla::Plugin::GithubMeta' to 'PRIVACY\.cpanplus\5.12.1\build\Dist-Zilla-Plugin-GithubMeta-0.12' ==> MISSING Signature file! <== Running [C:\strawberry\perl\bin\perl.exe C:\strawberry\perl\bin\cpanp-run-perl PRIVACY\.cpanplus\5.12.1\build\Dist-Zilla-Plugin-GithubMe ta-0.12\Makefile.PL]... Warning: prerequisite MooseX::Types::URI 0.02 not found. Writing Makefile for Dist::Zilla::Plugin::GithubMeta [MSG] Module 'Dist::Zilla::Plugin::GithubMeta' requires 'MooseX::Types::URI' ver sion '0.02' to be installed [MSG] Using cached file 'PRIVACY\.cpanplus\authors\id\F\ FL\FLORA\CHECKSUMS' on disk; ttl (3600s) is not exceeded [MSG] Checksum matches for 'MooseX-Types-URI-0.02.tar.gz' [MSG] Extracted 'MooseX-Types-URI-0.02/' [MSG] Extracted 'MooseX-Types-URI-0.02/MANIFEST.SKIP' [MSG] Extracted 'MooseX-Types-URI-0.02/Changes' [MSG] Extracted 'MooseX-Types-URI-0.02/t/' [MSG] Extracted 'MooseX-Types-URI-0.02/t/basic.t' [MSG] Extracted 'MooseX-Types-URI-0.02/Makefile.PL' [MSG] Extracted 'MooseX-Types-URI-0.02/META.yml' [MSG] Extracted 'MooseX-Types-URI-0.02/SIGNATURE' [MSG] Extracted 'MooseX-Types-URI-0.02/MANIFEST' [MSG] Extracted 'MooseX-Types-URI-0.02/lib/' [MSG] Extracted 'MooseX-Types-URI-0.02/lib/MooseX/' [MSG] Extracted 'MooseX-Types-URI-0.02/lib/MooseX/Types/' [MSG] Extracted 'MooseX-Types-URI-0.02/lib/MooseX/Types/URI.pm' [MSG] Extracted 'MooseX::Types::URI' to 'PRIVACY\.cpanplus\5.12.1\build\MooseX-Types-URI-0.02' 'gpg' n’est pas reconnu en tant que commande interne ou externe, un programme exécutable ou un fichier de commandes. Running [C:\strawberry\perl\bin\perl.exe C:\strawberry\perl\bin\cpanp-run-perl PRIVACY\.cpanplus\5.12.1\build\MooseX-Types-URI-0.02\Make file.PL]... Warning: prerequisite URI::FromHash 0 not found. Writing Makefile for MooseX::Types::URI [MSG] Module 'MooseX::Types::URI' requires 'URI::FromHash' version '0' to be ins talled [MSG] Using cached file 'PRIVACY\.cpanplus\authors\id\D\ DR\DROLSKY\CHECKSUMS' on disk; ttl (3600s) is not exceeded [MSG] Checksum matches for 'URI-FromHash-0.03.tar.gz' [MSG] Extracted 'URI-FromHash-0.03/' [MSG] Extracted 'URI-FromHash-0.03/t/' [MSG] Extracted 'URI-FromHash-0.03/t/pod.t' [MSG] Extracted 'URI-FromHash-0.03/t/pod-coverage.t' [MSG] Extracted 'URI-FromHash-0.03/t/uri.t' [MSG] Extracted 'URI-FromHash-0.03/META.yml' [MSG] Extracted 'URI-FromHash-0.03/Changes' [MSG] Extracted 'URI-FromHash-0.03/README' [MSG] Extracted 'URI-FromHash-0.03/MANIFEST' [MSG] Extracted 'URI-FromHash-0.03/Makefile.PL' [MSG] Extracted 'URI-FromHash-0.03/lib/' [MSG] Extracted 'URI-FromHash-0.03/lib/URI/' [MSG] Extracted 'URI-FromHash-0.03/lib/URI/FromHash.pm' [MSG] Extracted 'URI-FromHash-0.03/SIGNATURE' [MSG] Extracted 'URI-FromHash-0.03/LICENSE' [MSG] Extracted 'URI-FromHash-0.03/Build.PL' [MSG] Extracted 'URI::FromHash' to 'PRIVACY\.cpanplus\5. 12.1\build\URI-FromHash-0.03' 'gpg' n’est pas reconnu en tant que commande interne ou externe, un programme exécutable ou un fichier de commandes. Running [C:\strawberry\perl\bin\perl.exe C:\strawberry\perl\bin\cpanp-run-perl PRIVACY\.cpanplus\5.12.1\build\URI-FromHash-0.03\Build.PL ]... Created MYMETA.yml and MYMETA.json Creating new 'Build' script for 'URI-FromHash' version '0.03' Running [C:\strawberry\perl\bin\perl.exe C:\strawberry\perl\bin\cpanp-run-perl PRIVACY\.cpanplus\5.12.1\build\URI-FromHash-0.03\Build].. . Building URI-FromHash Running [C:\strawberry\perl\bin\perl.exe C:\strawberry\perl\bin\cpanp-run-perl PRIVACY\.cpanplus\5.12.1\build\URI-FromHash-0.03\Build te st]... t\pod-coverage.t .. skipped: This test is only run for the module author t\pod.t ........... skipped: This test is only run for the module author t\uri.t ........... ok All tests successful. Files=3, Tests=22, 0 wallclock secs ( 0.08 usr + 0.03 sys = 0.11 CPU) Result: PASS [MSG] Sending test report for 'URI-FromHash-0.03' [MSG] Successfully sent 'pass' report for 'URI-FromHash-0.03' Running [C:\STRAWB~1\c\bin\dmake.EXE]... [ERROR] MAKE failed: [MSG] Sending test report for 'MooseX-Types-URI-0.02' Test report prepared for module 'MooseX::Types::URI'. Would you like to send it? (You can edit it if you like) Would you like to send the test report? [y/N]: n [MSG] Ok, not sending test report [ERROR] Unable to create a new distribution object for 'MooseX::Types::URI' -- c annot continue [ERROR] Failed to install 'MooseX::Types::URI' as prerequisite for 'Dist::Zilla: :Plugin::GithubMeta' [ERROR] Unable to satisfy prerequisites for 'Dist::Zilla::Plugin::GithubMeta' -- aborting install [ERROR] Unable to create a new distribution object for 'Dist::Zilla::Plugin::Git hubMeta' -- cannot continue *** Install log written to: PRIVACY\.cpanplus\install-logs\Dist-Zilla-Plugin-Githu bMeta-0.12-1304768923.log Error installing 'Dist::Zilla::Plugin::GithubMeta' Problem installing one or more modules
Subject: Re: [rt.cpan.org #68004] "make install" after "Build test" with URI-FromHash-0.03
Date: Tue, 10 May 2011 06:19:49 -0700
To: bug-CPANPLUS [...] rt.cpan.org
From: Jos Boumans <jos [...] dwim.org>
Download (untitled) / with headers
text/plain 3.2k
Hi, On 7 May 2011, at 05:09, Olivier 'dolmen' Mengué via RT wrote: Show quoted text
> I have prefer_makefile => '' (which means I prefer Build.PL). > > When installing the distibution URI-FromHash-0.03 that has both > Makefile.PL and Build.PL it looks like CPANPLUS starts with Build.PL > but > tries to do "install" using make. > > This is CPANPLUS 0.9105 on MSWin32 with Strawberry Perl 5.12.1.0 > > ---------------------------------------------------------------- > > CPAN Terminal> s conf
[...] Show quoted text
> prereqs '3'
You have prereqs set to 3, which means 'build only'; this is the setting you want if you're testing/smoking modules. If you want to install them on disk you want 1 (yes) or 2 (ask). Typing 's conf reconfigure' can help you with this. This also means that the 'make' you are seeing is not for URI::FromHash, but for the module that depended on URI::FromHash; the build of U::FH succeeds, a test report is sent for it and then 'make' is ran for MooseX-Types-URI-0.02. You can verify this by running 't URI::FromHash'. Cheers, Show quoted text
> CPAN Terminal> i Dist::Zilla::Plugin::GithubMeta >
Show quoted text
> [MSG] Extracted 'URI::FromHash' to 'PRIVACY\.cpanplus\5. > 12.1\build\URI-FromHash-0.03' > 'gpg' n’est pas reconnu en tant que commande interne > ou externe, un programme exécutable ou un fichier de commandes. > Running [C:\strawberry\perl\bin\perl.exe > C:\strawberry\perl\bin\cpanp-run-perl > PRIVACY\.cpanplus\5.12.1\build\URI-FromHash-0.03\Build.PL > ]... > Created MYMETA.yml and MYMETA.json > Creating new 'Build' script for 'URI-FromHash' version '0.03' > Running [C:\strawberry\perl\bin\perl.exe > C:\strawberry\perl\bin\cpanp-run-perl > PRIVACY\.cpanplus\5.12.1\build\URI-FromHash-0.03\Build].. > . > Building URI-FromHash > Running [C:\strawberry\perl\bin\perl.exe > C:\strawberry\perl\bin\cpanp-run-perl > PRIVACY\.cpanplus\5.12.1\build\URI-FromHash-0.03\Build te > st]... > t\pod-coverage.t .. skipped: This test is only run for the module > author > t\pod.t ........... skipped: This test is only run for the module > author > t\uri.t ........... ok > All tests successful. > Files=3, Tests=22, 0 wallclock secs ( 0.08 usr + 0.03 sys = 0.11 > CPU) > Result: PASS > [MSG] Sending test report for 'URI-FromHash-0.03' > [MSG] Successfully sent 'pass' report for 'URI-FromHash-0.03' > Running [C:\STRAWB~1\c\bin\dmake.EXE]... > [ERROR] MAKE failed: > > [MSG] Sending test report for 'MooseX-Types-URI-0.02' > > Test report prepared for module 'MooseX::Types::URI'. > Would you like to send it? (You can edit it if you like) > > Would you like to send the test report? [y/N]: n > [MSG] Ok, not sending test report > [ERROR] Unable to create a new distribution object for > 'MooseX::Types::URI' -- c > annot continue > > [ERROR] Failed to install 'MooseX::Types::URI' as prerequisite for > 'Dist::Zilla: > :Plugin::GithubMeta' > > [ERROR] Unable to satisfy prerequisites for > 'Dist::Zilla::Plugin::GithubMeta' -- > aborting install > > [ERROR] Unable to create a new distribution object for > 'Dist::Zilla::Plugin::Git > hubMeta' -- cannot continue > > *** Install log written to: > PRIVACY\.cpanplus\install-logs\Dist-Zilla-Plugin-Githu > bMeta-0.12-1304768923.log > > Error installing 'Dist::Zilla::Plugin::GithubMeta' > Problem installing one or more modules >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.