Skip Menu |
 

This queue is for tickets about the CGI-Application-Plugin-Authentication CPAN distribution.

Report information
The Basics
Id: 67840
Status: resolved
Priority: 0/
Queue: CGI-Application-Plugin-Authentication

People
Owner: Nobody in particular
Requestors: CARNIL [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 0.20



Subject: Use Digest::SHA instead of Digest::SHA1
Date: Fri, 29 Apr 2011 19:41:13 +0200
To: bug-CGI-Application-Plugin-Authentication [...] rt.cpan.org
From: Salvatore Bonaccorso <carnil [...] cpan.org>
Download (untitled) / with headers
text/plain 446b
Hi CGI-Application-Plugin-Authentication uses Digest::SHA1. In Debian we would like to drop the package providing libdigest-sha1-perl [1]. Digest::SHA is part of the standard perl distribution since perl v5.9.3 so changing use of Digest::SHA1 to use Digest::SHA reduces the number of external dependencies by one. [1] http://deb.li/digestsha Would it be possible to change this too for CGI-Application-Plugin-Authentication? Bests Salvatore
Download signature.asc
application/pgp-signature 836b

Message body not shown because it is not plain text.



This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.