Skip Menu |
 

This queue is for tickets about the Moose CPAN distribution.

Report information
The Basics
Id: 67721
Status: rejected
Priority: 0/
Queue: Moose

People
Owner: Nobody in particular
Requestors: Lawrence.Hixson [...] noaa.gov
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Moose 2.0000 install error from ActivePerl 5.12.2
Date: Sat, 23 Apr 2011 23:10:50 -0400
To: bug-Moose [...] rt.cpan.org
From: Lawrence.Hixson [...] noaa.gov
Download (untitled) / with headers
text/plain 1.3k
Thanks! --------------- OS: Microsoft Windows XP [Version 5.1.2600] --------------- c:\myperl>perl -v This is perl 5, version 12, subversion 2 (v5.12.2) built for MSWin32-x86-multi-thread (with 8 registered patches, see perl -V for more detail) Copyright 1987-2010, Larry Wall Binary build 1202 [293621] provided by ActiveState http://www.ActiveState.com Built Sep 6 2010 23:36:03 Perl may be copied only under the terms of either the Artistic License or the GNU General Public License, which may be found in the Perl 5 source kit. Complete documentation for Perl, including FAQ lists, should be found on this system using "man perl" or "perldoc perl". If you have access to the Internet, point your browser at http://www.perl.org/, the Perl Home Page. --------------- ActiveState PPM Moose 2.0000 install error: Moose depends on Eval-Closure Installing 2 packages ... Downloading Moose-2.0000 ... done Downloading Eval-Closure-0.04 ... done Unpacking Moose-2.0000 ... done Unpacking Eval-Closure-0.04 ... done Generating HTML for Moose-2.0000 ... done Generating HTML for Eval-Closure-0.04 ... done Updating files in site area ... failed Installing 2 packages failed ERROR: File conflict for 'C:/Perl/html/site/lib/Class/MOP/Attribute.html'. The package Class-MOP has already installed a file that package Moose wants to install. ---------------
Subject: Re: [rt.cpan.org #67721] Moose 2.0000 install error from ActivePerl 5.12.2
Date: Sat, 23 Apr 2011 22:25:47 -0500 (CDT)
To: Lawrence Hixson via RT <bug-Moose [...] rt.cpan.org>
From: Dave Rolsky <autarch [...] urth.org>
On Sat, 23 Apr 2011, Lawrence Hixson via RT wrote: Show quoted text
> ActiveState PPM Moose 2.0000 install error: > > Moose depends on Eval-Closure > Installing 2 packages ... > Downloading Moose-2.0000 ... done > Downloading Eval-Closure-0.04 ... done > Unpacking Moose-2.0000 ... done > Unpacking Eval-Closure-0.04 ... done > Generating HTML for Moose-2.0000 ... done > Generating HTML for Eval-Closure-0.04 ... done > Updating files in site area ... failed > Installing 2 packages failed > > ERROR: File conflict for 'C:/Perl/html/site/lib/Class/MOP/Attribute.html'. > The package Class-MOP has already installed a file that package Moose > wants to install.
I have no idea how PPMs work, but maybe you can uninstall the old Class-MOP PPM first? I'm not sure there's much we as the Moose devs can do to help. -dave /*============================================================ http://VegGuide.org http://blog.urth.org Your guide to all that's veg House Absolute(ly Pointless) ============================================================*/
This was stalled over a year ago, if this is still an issue please re-open. -Chris


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.