Skip Menu |
 

This queue is for tickets about the Test-WWW-Selenium CPAN distribution.

Report information
The Basics
Id: 67636
Status: resolved
Priority: 0/
Queue: Test-WWW-Selenium

People
Owner: Nobody in particular
Requestors: sundial.services [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.24
Fixed in: (no value)



Subject: 'make test' errors with selenium 2.0b3
Download (untitled) / with headers
text/plain 1.3k
using selenium-server-standalone-2.0b3.jar on OS/X running against port 4444 (standard). These tests fail: t/test_default_server.t .. # Test::WWW::Selenium running open (/selenium-server/tests/html/test_click_page1.html) t/test_default_server.t .. 1/7 # Test::WWW::Selenium running get_text (link (?-xism:Click here for next page) link contains expected text) Error requesting http://localhost:4444/selenium-server/driver/: ERROR: Element link not found # Looks like you planned 7 tests but ran 1. # Looks like your test exited with 255 just after 1. t/test_default_server.t .. Dubious, test returned 255 (wstat 65280, 0xff00) Failed 6/7 subtests t/test_google.t .......... Error requesting http://localhost:4444/selenium-server/driver/: Timed out after 5000ms # Looks like your test exited with 255 before it could output anything. t/test_google.t .......... Dubious, test returned 255 (wstat 65280, 0xff00) Failed 1/1 subtests Various things about Selenium might have changed recently because with the browser we get responses like: 404 Not found RequestURI=/selenium-server/tests/html/test_click_page1.html Powered by Jetty:// In all likelihood these tests are failing because they're requesting things that don't exist (anymore). Or, if that is not the case, pointers on how to set up Selenium correctly are cordially requested and should be added to the test sequence.
Subject: Re: [rt.cpan.org #67636] 'make test' errors with selenium 2.0b3
Date: Wed, 20 Apr 2011 14:31:05 -0700
To: bug-Test-WWW-Selenium [...] rt.cpan.org
From: Luke Closs <lukecloss [...] gmail.com>
I believe this is because you'reyu running Selenium 2 which is not yet supported. It may be the case that it still works but this part of the unit tests is not supported. Patches are welcome. On Wed, Apr 20, 2011 at 1:53 PM, Sundial Services via RT <bug-Test-WWW-Selenium@rt.cpan.org> wrote: Show quoted text
> Wed Apr 20 16:53:34 2011: Request 67636 was acted upon. > Transaction: Ticket created by sundialservices >       Queue: Test-WWW-Selenium >     Subject: 'make test' errors with selenium 2.0b3 >   Broken in: 1.24 >    Severity: (no value) >       Owner: Nobody >  Requestors: sundial.services@gmail.com >      Status: new >  Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=67636 > > > > using selenium-server-standalone-2.0b3.jar on OS/X > running against port 4444 (standard). > > These tests fail: > t/test_default_server.t .. # Test::WWW::Selenium running open > (/selenium-server/tests/html/test_click_page1.html) > t/test_default_server.t .. 1/7 # Test::WWW::Selenium running get_text > (link (?-xism:Click here for next page) link contains expected text) > Error requesting http://localhost:4444/selenium-server/driver/: > ERROR: Element link not found > # Looks like you planned 7 tests but ran 1. > # Looks like your test exited with 255 just after 1. > t/test_default_server.t .. Dubious, test returned 255 (wstat 65280, 0xff00) > Failed 6/7 subtests > t/test_google.t .......... Error requesting > http://localhost:4444/selenium-server/driver/: > Timed out after 5000ms > # Looks like your test exited with 255 before it could output anything. > t/test_google.t .......... Dubious, test returned 255 (wstat 65280, 0xff00) > Failed 1/1 subtests > > > Various things about Selenium might have changed recently because with > the browser we get responses like: > > 404 Not found > RequestURI=/selenium-server/tests/html/test_click_page1.html > Powered by Jetty:// > > In all likelihood these tests are failing because they're requesting > things that don't exist (anymore).  Or, if that is not the case, > pointers on how to set up Selenium correctly are cordially requested and > should be added to the test sequence. >
From: sundial.services [...] gmail.com
Download (untitled) / with headers
text/plain 598b
It appears to definitely be the case that this is so, and I have confirmed that many other Selenium test-suites have the same issue. As far as I can determine, Selenium 2.x simply doesn't provide this "test page" functionality any more. It seems appropriate to close this bug ... to just let it document the fact that "Selenium itself has changed." Thanks. On Wed Apr 20 17:31:14 2011, lukecloss@gmail.com wrote: Show quoted text
> I believe this is because you're running Selenium 2 which is not yet > supported. > > It may be the case that it still works but this part of the unit tests > is not supported.
Download (untitled) / with headers
text/plain 102b
This issue has been fixed in the git repo, and will be resolved in the upcoming 1.25 release. Thanks!


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.