Skip Menu |
 

This queue is for tickets about the PAR-Packer CPAN distribution.

Report information
The Basics
Id: 67380
Status: resolved
Priority: 0/
Queue: PAR-Packer

People
Owner: RSCHUPP [...] cpan.org
Requestors: nijdama56 [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



CC: Abel Nijdam <nijdama56 [...] gmail.com>
Subject: Problems with install PAR::Packer 1.009 on Strawberry Perl 5.12.2 on WinXP.
Date: Mon, 11 Apr 2011 15:47:02 +0200
To: bug-PAR-Packer [...] rt.cpan.org
From: Abel Nijdam <nijdama56 [...] gmail.com>
Download (untitled) / with headers
text/plain 23.4k

Message body is not shown because it is too large.

Download (untitled) / with headers
text/html 30.3k

Message body is not shown because it is too large.

Download (untitled) / with headers
text/plain 336b
On 2011-04-11 09:47:21, nijdama56@gmail.com wrote: Show quoted text
> I've collected as much info as I could (see below), I hope, you can > help me > fixing this problem.
Strange. Can you check whether you have a file called pp.bat somewhere below your build directory. If yes, please post its contents (should be just a few lines). Cheers, Roderich
CC: Abel Nijdam <nijdama56 [...] gmail.com>
Subject: Re: [rt.cpan.org #67380] Problems with install PAR::Packer 1.009 on Strawberry Perl 5.12.2 on WinXP.
Date: Mon, 11 Apr 2011 22:13:59 +0200
To: bug-PAR-Packer [...] rt.cpan.org
From: Abel Nijdam <nijdama56 [...] gmail.com>
Download (untitled) / with headers
text/plain 1.2k
Builders of PAR::Packer 1.009, You requested, that if there is a pp.bat file somewhere below in my build directory, I give you the contents. Well, there is a pp.bat file in D:\Scratch\Perl\CPAN\PAR-Packer-1.009\blib\script with the following content: @rem = '--*-Perl-*-- @echo off if "%OS%" == "Windows_NT" goto WinNT "%~dp0perl.exe" -x -S "%0" %1 %2 %3 %4 %5 %6 %7 %8 %9 goto endofperl :WinNT "%~dp0perl.exe" -x -S %0 %* if NOT "%COMSPEC%" == "%SystemRoot%\system32\cmd.exe" goto endofperl if %errorlevel% == 9009 echo You do not have Perl in your PATH. if errorlevel 1 goto script_failed_so_exit_with_non_zero_val 2>nul goto endofperl @rem '; #!/usr/bin/perl #line 15 use strict; use warnings; use pp; pp->go(); __END__ :endofperl Hope, this helps! Regards, Abel. 2011/4/11 Roderich Schupp via RT <bug-PAR-Packer@rt.cpan.org> Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=67380 > > > On 2011-04-11 09:47:21, nijdama56@gmail.com wrote:
> > I've collected as much info as I could (see below), I hope, you can > > help me > > fixing this problem.
> > Strange. Can you check whether you have a file called pp.bat > somewhere below your build directory. > If yes, please post its contents (should be just a few lines). > > Cheers, Roderich > >
Download (untitled) / with headers
text/plain 494b
On 2011-04-11 16:14:08, nijdama56@gmail.com wrote: Show quoted text
> "%~dp0perl.exe" -x -S %0 %*
This is the culprit. It means: "call perl.exe on the same drive in the same directory as this batch file" which is totally bogus. pp.bat is generated by pl2bat.bat which usually comes with your Perl distribution. I checked with ActiveState Perl 5.10.1 and Strawberry Perl 5.12.0 and their pl2bat.bat doesn't generate such a line, so I suggest you look for some rogue pl2bat.bat in your PATH. Cheers, Roderich
CC: Abel Nijdam <nijdama56 [...] gmail.com>
Subject: Re: [rt.cpan.org #67380] Problems with install PAR::Packer 1.009 on Strawberry Perl 5.12.2 on WinXP.
Date: Tue, 12 Apr 2011 14:45:37 +0200
To: bug-PAR-Packer [...] rt.cpan.org
From: Abel Nijdam <nijdama56 [...] gmail.com>
Download (untitled) / with headers
text/plain 1.8k
That's it: You've checked with Strawberry Perl 5.12.0, with that version, the first lines of pl2bat.bat are: @rem = '--*-Perl-*-- @echo off if "%OS%" == "Windows_NT" goto WinNT perl -x -S "%0" %1 %2 %3 %4 %5 %6 %7 %8 %9 goto endofperl :WinNT perl -x -S %0 %* if NOT "%COMSPEC%" == "%SystemRoot%\system32\cmd.exe" goto endofperl if %errorlevel% == 9009 echo You do not have Perl in your PATH. if errorlevel 1 goto script_failed_so_exit_with_non_zero_val 2>nul goto endofperl But I am running Strawberry Perl 5.12.2.0, and with this (latest) version, the first lines of pl2bat.bat are: @rem = '--*-Perl-*-- @echo off if "%OS%" == "Windows_NT" goto WinNT "%~dp0perl.exe" -x -S "%0" %1 %2 %3 %4 %5 %6 %7 %8 %9 goto endofperl :WinNT "%~dp0perl.exe" -x -S %0 %* if NOT "%COMSPEC%" == "%SystemRoot%\system32\cmd.exe" goto endofperl if %errorlevel% == 9009 echo You do not have Perl in your PATH. if errorlevel 1 goto script_failed_so_exit_with_non_zero_val 2>nul goto endofperl Now is my scratch-drive drive D: (install-files are there, as well as build-dir etc...), and I've build Strawberry Perl 5.12.2.0 on drive E:, so there is my perl (pointed to this location in my PATH). So this latest version of Strawberry Perl (5.12.2.0) isn't ready for PAR::Packer 1.009 install? Regards, Abel. 2011/4/12 Roderich Schupp via RT <bug-PAR-Packer@rt.cpan.org> Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=67380 > > > On 2011-04-11 16:14:08, nijdama56@gmail.com wrote:
> > "%~dp0perl.exe" -x -S %0 %*
> > This is the culprit. It means: "call perl.exe on the same drive > in the same directory as this batch file" which is totally bogus. > > pp.bat is generated by pl2bat.bat which usually comes with your > Perl distribution. I checked with ActiveState Perl 5.10.1 and > Strawberry Perl 5.12.0 and their pl2bat.bat doesn't generate > such a line, so I suggest you look for some rogue pl2bat.bat > in your PATH. > > Cheers, Roderich >
Download (untitled) / with headers
text/plain 1.8k
On 2011-04-12 08:45:52, nijdama56@gmail.com wrote: Show quoted text
> But I am running Strawberry Perl 5.12.2.0, and with this (latest) version, > the first lines of pl2bat.bat are: > > @rem = '--*-Perl-*-- > @echo off > if "%OS%" == "Windows_NT" goto WinNT > "%~dp0perl.exe" -x -S "%0" %1 %2 %3 %4 %5 %6 %7 %8 %9
Err, I just did a clean install of Strawberry 5.12.2.0 (downloaded the MSI from strawberryperl.com) and this is NOT what I'm seeing - mine's the same as in 5.12.0. Anyway, "%~dp0perl.exe" is horribly wrong, just replace it with simply perl.exe everywhere in pl2bat.bat and then re-build PAR::Packer. Cheers, Roderich Show quoted text
> goto endofperl > :WinNT > "%~dp0perl.exe" -x -S %0 %* > if NOT "%COMSPEC%" == "%SystemRoot%\system32\cmd.exe" goto endofperl > if %errorlevel% == 9009 echo You do not have Perl in your PATH. > if errorlevel 1 goto script_failed_so_exit_with_non_zero_val 2>nul > goto endofperl > Now is my scratch-drive drive D: (install-files are there, as well as > build-dir etc...), and I've build Strawberry Perl 5.12.2.0 on > drive E:, so there is my perl (pointed to this location in my PATH). > > So this latest version of Strawberry Perl (5.12.2.0) isn't ready for > PAR::Packer 1.009 install? > > Regards, Abel. > > 2011/4/12 Roderich Schupp via RT <bug-PAR-Packer@rt.cpan.org> >
> > <URL: https://rt.cpan.org/Ticket/Display.html?id=67380 > > > > > On 2011-04-11 16:14:08, nijdama56@gmail.com wrote:
> > > "%~dp0perl.exe" -x -S %0 %*
> > > > This is the culprit. It means: "call perl.exe on the same drive > > in the same directory as this batch file" which is totally bogus. > > > > pp.bat is generated by pl2bat.bat which usually comes with your > > Perl distribution. I checked with ActiveState Perl 5.10.1 and > > Strawberry Perl 5.12.0 and their pl2bat.bat doesn't generate > > such a line, so I suggest you look for some rogue pl2bat.bat > > in your PATH. > > > > Cheers, Roderich > >
Subject: Re: [rt.cpan.org #67380] Problems with install PAR::Packer 1.009 on Strawberry Perl 5.12.2 on WinXP.
Date: Tue, 12 Apr 2011 16:08:06 +0200
To: bug-PAR-Packer [...] rt.cpan.org
From: Abel Nijdam <nijdama56 [...] gmail.com>
Download (untitled) / with headers
text/plain 2.4k
Changed pl2bat.bat (took it from strawberry-perl-5.12.0.1.zip) and tried to install PAR::Packer 1.009 again, but this made things only worse... My build was from strawberry-perl-5.12.2.0-portable.zip I will clean this install, then take the install from strawberry-perl-5.12.2.0.msi, add the required modules and PAR::Packer 1.009 again (as you did), and will see, what happens... Will keep you posted! Regards, Abel. 2011/4/12 Roderich Schupp via RT <bug-PAR-Packer@rt.cpan.org> Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=67380 > > > On 2011-04-12 08:45:52, nijdama56@gmail.com wrote:
> > But I am running Strawberry Perl 5.12.2.0, and with this (latest)
> version,
> > the first lines of pl2bat.bat are: > > > > @rem = '--*-Perl-*-- > > @echo off > > if "%OS%" == "Windows_NT" goto WinNT > > "%~dp0perl.exe" -x -S "%0" %1 %2 %3 %4 %5 %6 %7 %8 %9
> > Err, I just did a clean install of Strawberry 5.12.2.0 > (downloaded the MSI from strawberryperl.com) > and this is NOT what I'm seeing - mine's the same as in 5.12.0. > Anyway, "%~dp0perl.exe" is horribly wrong, just > replace it with simply perl.exe everywhere in pl2bat.bat > and then re-build PAR::Packer. > > Cheers, Roderich >
> > goto endofperl > > :WinNT > > "%~dp0perl.exe" -x -S %0 %* > > if NOT "%COMSPEC%" == "%SystemRoot%\system32\cmd.exe" goto endofperl > > if %errorlevel% == 9009 echo You do not have Perl in your PATH. > > if errorlevel 1 goto script_failed_so_exit_with_non_zero_val 2>nul > > goto endofperl > > Now is my scratch-drive drive D: (install-files are there, as well as > > build-dir etc...), and I've build Strawberry Perl 5.12.2.0 on > > drive E:, so there is my perl (pointed to this location in my PATH). > > > > So this latest version of Strawberry Perl (5.12.2.0) isn't ready for > > PAR::Packer 1.009 install? > > > > Regards, Abel. > > > > 2011/4/12 Roderich Schupp via RT <bug-PAR-Packer@rt.cpan.org> > >
> > > <URL: https://rt.cpan.org/Ticket/Display.html?id=67380 > > > > > > > On 2011-04-11 16:14:08, nijdama56@gmail.com wrote:
> > > > "%~dp0perl.exe" -x -S %0 %*
> > > > > > This is the culprit. It means: "call perl.exe on the same drive > > > in the same directory as this batch file" which is totally bogus. > > > > > > pp.bat is generated by pl2bat.bat which usually comes with your > > > Perl distribution. I checked with ActiveState Perl 5.10.1 and > > > Strawberry Perl 5.12.0 and their pl2bat.bat doesn't generate > > > such a line, so I suggest you look for some rogue pl2bat.bat > > > in your PATH. > > > > > > Cheers, Roderich > > >
> > > >
Subject: Re: [rt.cpan.org #67380] Problems with install PAR::Packer 1.009 on Strawberry Perl 5.12.2 on WinXP.
Date: Wed, 13 Apr 2011 22:47:29 +0200
To: bug-PAR-Packer [...] rt.cpan.org
From: Abel Nijdam <nijdama56 [...] gmail.com>
Got it! Tried to install from (as I said) strawberry-perl-5.12.2.0.msi, on my scratch-drive D: to drive E:\strawberry, but also this is not a good idea! Install works fine, but every install of extra modules (as I need for instance Net::Telnet and Net::Telnet::Brcd, and last PAR::Packer) goes to C:\strawberry instead of E:\strawberry! So that's not a good idea also... Cleaned again my installs, took strawberry-perl-5.12.2.0.msi again, but now I installed it to the default, C:\strawberry and YES: all further installs of the modules I need, went to this very same structure, C:\strawberry... And finally, I was succesful in installing PAR::Packer 1.009 (all the tests were completed OK), and that's what it was all about. Now I have pp available and can start testing. Take my existing perl-scripts (running as executables on several servers), make the desired changes, make new executables of these new / changed scripts with pp and see, what happens! Thanks for all your support, after all it wasn't the PAR::Packer 1.009 at all, but all my problems were caused by the unability of several strawberry installs to deal with installing strawberry on anything else than drive C:.....!! The makers / builders / maintainers of strawberry distributions should make changes to their distributions, because the installer lets you choose where to install strawberry, but it only works (without any changes) on drive C: ! Regards, cheers, Abel. 2011/4/12 Abel Nijdam <nijdama56@gmail.com> Show quoted text
> Changed pl2bat.bat (took it from strawberry-perl-5.12.0.1.zip) and tried to > install PAR::Packer 1.009 again, but this made things only worse... > My build was from strawberry-perl-5.12.2.0-portable.zip > I will clean this install, then take the install from > strawberry-perl-5.12.2.0.msi, add the required modules and PAR::Packer 1.009 > again (as you did), and will see, what happens... > Will keep you posted! > > Regards, Abel. > > 2011/4/12 Roderich Schupp via RT <bug-PAR-Packer@rt.cpan.org> >
>> <URL: https://rt.cpan.org/Ticket/Display.html?id=67380 > >> >> On 2011-04-12 08:45:52, nijdama56@gmail.com wrote:
>> > But I am running Strawberry Perl 5.12.2.0, and with this (latest)
>> version,
>> > the first lines of pl2bat.bat are: >> > >> > @rem = '--*-Perl-*-- >> > @echo off >> > if "%OS%" == "Windows_NT" goto WinNT >> > "%~dp0perl.exe" -x -S "%0" %1 %2 %3 %4 %5 %6 %7 %8 %9
>> >> Err, I just did a clean install of Strawberry 5.12.2.0 >> (downloaded the MSI from strawberryperl.com) >> and this is NOT what I'm seeing - mine's the same as in 5.12.0. >> Anyway, "%~dp0perl.exe" is horribly wrong, just >> replace it with simply perl.exe everywhere in pl2bat.bat >> and then re-build PAR::Packer. >> >> Cheers, Roderich >>
>> > goto endofperl >> > :WinNT >> > "%~dp0perl.exe" -x -S %0 %* >> > if NOT "%COMSPEC%" == "%SystemRoot%\system32\cmd.exe" goto endofperl >> > if %errorlevel% == 9009 echo You do not have Perl in your PATH. >> > if errorlevel 1 goto script_failed_so_exit_with_non_zero_val 2>nul >> > goto endofperl >> > Now is my scratch-drive drive D: (install-files are there, as well as >> > build-dir etc...), and I've build Strawberry Perl 5.12.2.0 on >> > drive E:, so there is my perl (pointed to this location in my PATH). >> > >> > So this latest version of Strawberry Perl (5.12.2.0) isn't ready for >> > PAR::Packer 1.009 install? >> > >> > Regards, Abel. >> > >> > 2011/4/12 Roderich Schupp via RT <bug-PAR-Packer@rt.cpan.org> >> >
>> > > <URL: https://rt.cpan.org/Ticket/Display.html?id=67380 > >> > > >> > > On 2011-04-11 16:14:08, nijdama56@gmail.com wrote:
>> > > > "%~dp0perl.exe" -x -S %0 %*
>> > > >> > > This is the culprit. It means: "call perl.exe on the same drive >> > > in the same directory as this batch file" which is totally bogus. >> > > >> > > pp.bat is generated by pl2bat.bat which usually comes with your >> > > Perl distribution. I checked with ActiveState Perl 5.10.1 and >> > > Strawberry Perl 5.12.0 and their pl2bat.bat doesn't generate >> > > such a line, so I suggest you look for some rogue pl2bat.bat >> > > in your PATH. >> > > >> > > Cheers, Roderich >> > >
>> >> >> >>
>
Download (untitled) / with headers
text/plain 829b
On 2011-04-13 16:47:40, nijdama56@gmail.com wrote: Show quoted text
> Thanks for all your support, after all it wasn't the PAR::Packer 1.009 > at all
No problem, I have seen the error message in your original report a few times before, but was never able to get to the bottom of it. Now I can at least people into the right direction and others may find the "solution" when searching rt.cpan.org or the mailing list. Closing this bug now. Show quoted text
> The makers / builders / maintainers of strawberry > distributions > should make changes to their distributions, because the installer lets > you > choose where to install strawberry, but it only works (without any > changes) > on drive C: !
If you find the time you might want to file a bug with Strawberry. Bugs are tracked right here on rt.cpan.org in queue Perl-Dist-Strawberry. Cheers, Roderich
I just noticed this bug. Feel free to close if this re-opens it... A quick explanation of how the difference between Strawberry Perl *Portable* and normal Strawberry Perl is affecting the batch files. The %~dp0 in Strawberry Perl Portable's batch files are because Portable can't assume that the correct perl.exe is in the path for a portable edition meant for thumb drives, or is in the same place every time. It's not as if it can run perl code to find perl before we run it, either. So Portable is set up so that all the /bin directories go to one place, if I recall correctly, and the assumption is that the batch files and perl.exe are landing there. A false assumption in this case, unfortunately. We DON'T do it for the standard non-portable .msi and .zip builds, because we CAN assume that perl.exe is in the path (and give a script and directions in the README in the .zip for making that assumption true.) Any better solutions to the Portable batch-file problem, feel free to file a bug against Perl-Dist-Strawberry and they'll be considered.
Download (untitled) / with headers
text/plain 724b
On 2011-06-13 22:22:42, CSJEWELL wrote: Show quoted text
> A quick explanation of how the difference between Strawberry Perl > *Portable* and normal Strawberry Perl is affecting the batch files.
Curtis, thanks for the explanation. Show quoted text
> Any better solutions to the Portable batch-file problem, feel free to > file a bug against Perl-Dist-Strawberry and they'll be considered.
That won't be necessary. IMHO installing modules into _another_ location (as was the case with the intial reporter) when using the Portable version kinda defeats the purpose of this version. So when users want to install modules from CPAN they should - either use INSTALLDIRS=perl with the Portable version - or use the "normal" version instead. Cheers, Roderich


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.