Skip Menu |
 

This queue is for tickets about the Test-Pod-LinkCheck CPAN distribution.

Report information
The Basics
Id: 67126
Status: resolved
Priority: 0/
Queue: Test-Pod-LinkCheck

People
Owner: Nobody in particular
Requestors: geistteufel [...] yahoo.fr
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.005
Fixed in: (no value)



Subject: test still doesn't work
Download (untitled) / with headers
text/plain 2.8k
perl -v 5.12.3 perl Makefile.PL Checking if your kit is complete... Looks good Writing Makefile for Test::Pod::LinkCheck Mac-Pro-de-Vincent-Bachelier:Test-Pod-LinkCheck-0.005 geistteufel$ make test cp lib/Test/Pod/LinkCheck.pm blib/lib/Test/Pod/LinkCheck.pm PERL_DL_NONLAZY=1 /Brew/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/00-compile.t ................ ok t/000-report-versions-tiny.t .. # You should load Test::Tester before Test::Builder (or anything that loads Test::Builder) at /Brew/Cellar/perl/5.12.3/lib/5.12.3/Test/Tester.pm line 9. # # perl: v5.12.3 (wanted 5.008) on darwin from /Brew/bin/perl # # App::PodLinkCheck::ParseLinks => 7 (want 4) # App::PodLinkCheck::ParseSections => 7 (want any version) # Capture::Tiny => 0.10 (want any version) # Config => <undef> (want any version) # Exporter => 5.64_01 (want any version) # File::Find => 1.15 (want any version) # File::Spec => 3.3101 (want any version) # File::Temp => 0.22 (want any version) # Module::Build => 0.3603 (want 0.3601) # Moose => 1.24 (want 1.01) # Moose::Util::TypeConstraints => 1.24 (want 1.01) # Pod::Find => 1.35 (want any version) # Test::Builder => 0.98 (want 0.94) # Test::More => 0.98 (want 0.88) # Test::Pod => 1.45 (want 1.44) # Test::Tester => 0.107 (want any version) # # Thanks for using my code. I hope it works for you. # If not, please try and include this output in the bug report. # That will help me reproduce the issue and solve you problem. # t/000-report-versions-tiny.t .. ok t/cpan_backend.t .............. ok t/functions.t ................. ok t/simple.t .................... 51/95 # Failed test 'actual_ok for pass_cpan' # at t/simple.t line 144. # got: '0' # expected: '1' # Looks like you failed 1 test of 95. t/simple.t .................... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/95 subtests Test Summary Report ------------------- t/cpan_backend.t (Wstat: 0 Tests: 12 Failed: 0) TODO passed: 3-4 t/simple.t (Wstat: 256 Tests: 95 Failed: 1) Failed test: 94 Non-zero exit status: 1 Files=5, Tests=113, 7 wallclock secs ( 0.06 usr 0.02 sys + 2.64 cusr 0.45 csys = 3.17 CPU) Result: FAIL Failed 1/5 test programs. 1/113 subtests failed. make: *** [test_dynamic] Error 1
Download (untitled) / with headers
text/plain 903b
On Thu Mar 31 17:08:17 2011, Geistteufel wrote: Show quoted text
> ... > t/simple.t .................... 51/95 > # Failed test 'actual_ok for pass_cpan' > # at t/simple.t line 144. > # got: '0' > # expected: '1' > # Looks like you failed 1 test of 95. > t/simple.t .................... Dubious, test returned 1 (wstat 256,
0x100) Show quoted text
> Failed 1/95 subtests > > Test Summary Report > ------------------- > t/cpan_backend.t (Wstat: 0 Tests: 12 Failed: 0) > TODO passed: 3-4 > t/simple.t (Wstat: 256 Tests: 95 Failed: 1) > Failed test: 94 > Non-zero exit status: 1 > Files=5, Tests=113, 7 wallclock secs ( 0.06 usr 0.02 sys + 2.64
cusr Show quoted text
> 0.45 csys = 3.17 CPU) > Result: FAIL > Failed 1/5 test programs. 1/113 subtests failed. > make: *** [test_dynamic] Error 1
I've got the same test failure on my system perl (5.10.1) - in case you need info or debugging help.
Download (untitled) / with headers
text/plain 177b
Hello, Thanks again for reporting this! I've just uploaded v0.007 to CPAN which fixes this. Please re-open if it still FAILs for you and I'll kick some ass :) -- ~Apocalypse


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.