Skip Menu |
 

This queue is for tickets about the Encode-Locale CPAN distribution.

Report information
The Basics
Id: 67010
Status: resolved
Priority: 0/
Queue: Encode-Locale

People
Owner: Nobody in particular
Requestors: ytnobody [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 1.01
Fixed in: (no value)



Subject: On Linux(CentOS-5.4), some tests failed with "The locale codeset (GB18030)"
Download (untitled) / with headers
text/plain 8.2k
Hello. I encountered a failure in testing Encode-Locale-1.01. # locale LANG=zh_CN.GB18030 LC_CTYPE="zh_CN.GB18030" LC_NUMERIC="zh_CN.GB18030" LC_TIME="zh_CN.GB18030" LC_COLLATE="zh_CN.GB18030" LC_MONETARY="zh_CN.GB18030" LC_MESSAGES="zh_CN.GB18030" LC_PAPER="zh_CN.GB18030" LC_NAME="zh_CN.GB18030" LC_ADDRESS="zh_CN.GB18030" LC_TELEPHONE="zh_CN.GB18030" LC_MEASUREMENT="zh_CN.GB18030" LC_IDENTIFICATION="zh_CN.GB18030" LC_ALL= # uname -a Linux localhost 2.6.18-164.el5 #1 SMP Thu Sep 3 03:28:30 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux # perl -V Summary of my perl5 (revision 5 version 8 subversion 8) configuration: Platform: osname=linux, osvers=2.6.18-53.el5, archname=x86_64-linux-thread- multi uname='linux builder10.centos.org 2.6.18-53.el5 #1 smp mon nov 12 02:14:55 est 2007 x86_64 x86_64 x86_64 gnulinux ' config_args='-des -Doptimize=-O2 -g -pipe -Wall -Wp,- D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer- size=4 -m64 -mtune=generic -Dversion=5.8.8 -Dmyhostname=localhost - Dperladmin=root@localhost -Dcc=gcc -Dcf_by=Red Hat, Inc. - Dinstallprefix=/usr -Dprefix=/usr -Dlibpth=/usr/local/lib64 /lib64 /usr/lib64 -Dprivlib=/usr/lib/perl5/5.8.8 - Dsitelib=/usr/lib/perl5/site_perl/5.8.8 - Dvendorlib=/usr/lib/perl5/vendor_perl/5.8.8 - Darchlib=/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi - Dsitearch=/usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi - Dvendorarch=/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi -Darchname=x86_64-linux-thread-multi -Dvendorprefix=/usr - Dsiteprefix=/usr -Duseshrplib -Dusethreads -Duseithreads -Duselargefiles -Dd_dosuid -Dd_semctl_semun -Di_db -Ui_ndbm -Di_gdbm -Di_shadow - Di_syslog -Dman3ext=3pm -Duseperlio -Dinstallusrbinperl=n - Ubincompat5005 -Uversiononly -Dpager=/usr/bin/less -isr - Dd_gethostent_r_proto -Ud_endhostent_r_proto -Ud_sethostent_r_proto - Ud_endprotoent_r_proto -Ud_setprotoent_r_proto -Ud_endservent_r_proto - Ud_setservent_r_proto -Dinc_version_list=5.8.7 5.8.6 5.8.5 - Dscriptdir=/usr/bin' hint=recommended, useposix=true, d_sigaction=define usethreads=define use5005threads=undef useithreads=define usemultiplicity=define useperlio=define d_sfio=undef uselargefiles=define usesocks=undef use64bitint=define use64bitall=define uselongdouble=undef usemymalloc=n, bincompat5005=undef Compiler: cc='gcc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -Wdeclaration-after-statement -I/usr/local/include - D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm', optimize='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions - fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic', cppflags='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe - Wdeclaration-after-statement -I/usr/local/include -I/usr/include/gdbm' ccversion='', gccversion='4.1.2 20080704 (Red Hat 4.1.2-46)', gccosandvers='' intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678 d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16 ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8 alignbytes=8, prototype=define Linker and Libraries: ld='gcc', ldflags ='' libpth=/usr/local/lib64 /lib64 /usr/lib64 libs=-lresolv -lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lpthread - lc perllibs=-lresolv -lnsl -ldl -lm -lcrypt -lutil -lpthread -lc libc=, so=so, useshrplib=true, libperl=libperl.so gnulibc_version='2.5' Dynamic Linking: dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E - Wl,-rpath,/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE' cccdlflags='-fPIC', lddlflags='-shared -O2 -g -pipe -Wall -Wp,- D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer- size=4 -m64 -mtune=generic' Characteristics of this binary (from libperl): Compile-time options: MULTIPLICITY PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP USE_64_BIT_ALL USE_64_BIT_INT USE_ITHREADS USE_LARGE_FILES USE_PERLIO USE_REENTRANT_API Built under linux Compiled at Sep 3 2009 10:26:51 @INC: /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8 . # cpanm Encode::Locale --mirror http://cpan.wenzk.com/ --mirror-only -v You have make /usr/bin/make You have /usr/bin/wget You have /bin/tar: tar (GNU tar) 1.15.1 You have /usr/bin/unzip Searching Encode::Locale on mirror http://cpan.wenzk.com ... Downloading index file http://cpan.wenzk.com/modules/02packages.details.txt.gz ... --2011-03-28 12:00:05-- http://cpan.wenzk.com/modules/02packages.details.txt.gz cpan.wenzk.com... 124.95.37.69, 2001:470:85cf::1 Connecting to cpan.wenzk.com|124.95.37.69|:80... HTTP ?... 200 OK 995414 (972K) [application/x-gzip] Saving to: `/root/.cpanm/sources/http%cpan.wenzk.com/02packages.details.txt.gz' 100% [======================================================================= ============>] 995,414 3.60M/s in 0.3s 2011-03-28 12:00:05 (3.60 MB/s) - `/root/.cpanm/sources/http%cpan.wenzk.com/02packages.details.txt.gz' saved [995414/995414] --> Working on Encode::Locale Fetching http://cpan.wenzk.com/authors/id/G/GA/GAAS/Encode-Locale- 1.01.tar.gz ... --2011-03-28 12:00:05-- http://cpan.wenzk.com/authors/id/G/GA/GAAS/Encode-Locale-1.01.tar.gz cpan.wenzk.com... 124.95.37.69, 2001:470:85cf::1 Connecting to cpan.wenzk.com|124.95.37.69|:80... HTTP ?... 200 OK 6549 (6.4K) [application/x-gzip] Saving to: `Encode-Locale-1.01.tar.gz' 100% [======================================================================= ============>] 6,549 --.-K/s in 0.02s 2011-03-28 12:00:05 (325 KB/s) - `Encode-Locale-1.01.tar.gz' saved [6549/6549] OK Unpacking Encode-Locale-1.01.tar.gz Encode-Locale-1.01/ Encode-Locale-1.01/Changes Encode-Locale-1.01/lib/ Encode-Locale-1.01/Makefile.PL Encode-Locale-1.01/MANIFEST Encode-Locale-1.01/META.yml Encode-Locale-1.01/README Encode-Locale-1.01/t/ Encode-Locale-1.01/t/arg.t Encode-Locale-1.01/t/env.t Encode-Locale-1.01/lib/Encode/ Encode-Locale-1.01/lib/Encode/Locale.pm Entering Encode-Locale-1.01 Checking configure dependencies from META.yml Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.56) Configuring Encode-Locale-1.01 ... Running Makefile.PL Checking if your kit is complete... Looks good Writing Makefile for Encode::Locale OK Finding PREREQ from Makefile ... Checking if you have Test 0 ... Yes (1.25) Checking if you have Encode::Alias 0 ... Yes (2.13) Checking if you have Encode 2 ... Yes (2.42) Building and testing Encode-Locale-1.01 ... cp lib/Encode/Locale.pm blib/lib/Encode/Locale.pm Manifying blib/man3/Encode::Locale.3pm PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/arg.t .. The locale codeset (GB18030) isn't one that perl can decode, stopped at /root/.cpanm/work/1301284805.29436/Encode-Locale- 1.01/blib/lib/Encode/Locale.pm line 74. Compilation failed in require at t/arg.t line 7. BEGIN failed--compilation aborted at t/arg.t line 7. t/arg.t .. Dubious, test returned 2 (wstat 512, 0x200) No subtests run t/env.t .. The locale codeset (GB18030) isn't one that perl can decode, stopped at /root/.cpanm/work/1301284805.29436/Encode-Locale- 1.01/blib/lib/Encode/Locale.pm line 74. Compilation failed in require at t/env.t line 7. BEGIN failed--compilation aborted at t/env.t line 7. t/env.t .. Dubious, test returned 2 (wstat 512, 0x200) No subtests run Test Summary Report ------------------- t/arg.t (Wstat: 512 Tests: 0 Failed: 0) Non-zero exit status: 2 Parse errors: No plan found in TAP output t/env.t (Wstat: 512 Tests: 0 Failed: 0) Non-zero exit status: 2 Parse errors: No plan found in TAP output Files=2, Tests=0, 0 wallclock secs ( 0.02 usr 0.00 sys + 0.04 cusr 0.01 csys = 0.07 CPU) Result: FAIL Failed 2/2 test programs. 0/0 subtests failed. make: *** [test_dynamic] 2 FAIL ! Installing Encode::Locale failed. See /root/.cpanm/build.log for details. -- yturtle(ytnobody) <ytnobody@gmail.com> My Blog (LANG:JA-jp) http://yellowstore.blogspot.com/
Download (untitled) / with headers
text/plain 100b
Does it work if you just install http://search.cpan.org/dist/Encode-HanExtra/ with your perl first?
From: ytnobody [...] gmail.com
Download (untitled) / with headers
text/plain 3.7k
Thank you. I tried to install Encode-Locale after installing Encode-HanExtra. * cpanm says some errors since I installed Encode-Locale and libwww-perl forced... # cpanm ./Encode-HanExtra-0.23.tar.gz --> Working on ./Encode-HanExtra-0.23.tar.gz Fetching file:///root/Encode-HanExtra-0.23.tar.gz ... FAIL ! Download file:///root/Encode-HanExtra-0.23.tar.gz failed. Retrying ... Configuring Encode-HanExtra-0.23 ... OK Building and testing Encode-HanExtra-0.23 ... OK Successfully installed Encode-HanExtra-0.23 1 distribution installed # cpanm ./Encode-Locale-1.01.tar.gz --> Working on ./Encode-Locale-1.01.tar.gz Fetching file:///root/Encode-Locale-1.01.tar.gz ... FAIL ! Download file:///root/Encode-Locale-1.01.tar.gz failed. Retrying ... Configuring Encode-Locale-1.01 ... OK Building and testing Encode-Locale-1.01 ... FAIL ! Installing ./Encode-Locale-1.01.tar.gz failed. See /root/.cpanm/build.log for details. # cat .cpanm/build.log cpanm (App::cpanminus) 1.4004 on perl 5.008008 built for x86_64-linux- thread-multi Work directory is /root/.cpanm/work/1301295603.5454 You have make /usr/bin/make You have LWP 6.02 You have /bin/tar: tar (GNU tar) 1.15.1 You have /usr/bin/unzip --> Working on ./Encode-Locale-1.01.tar.gz Fetching file:///root/Encode-Locale-1.01.tar.gz The locale codeset (GB18030) isn't one that perl can decode, stopped at /usr/lib/perl5/site_perl/5.8.8/Encode/Locale.pm line 74. Compilation failed in require at /usr/lib/perl5/site_perl/5.8.8/LWP/UserAgent.pm line 976. -> FAIL Download file:///root/Encode-Locale-1.01.tar.gz failed. Retrying ... -> OK Unpacking Encode-Locale-1.01.tar.gz Entering Encode-Locale-1.01 Checking configure dependencies from META.yml Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.56) Configuring Encode-Locale-1.01 Running Makefile.PL Checking if your kit is complete... Looks good Writing Makefile for Encode::Locale -> OK Finding PREREQ from Makefile ... Checking if you have Test 0 ... Yes (1.25) Checking if you have Encode::Alias 0 ... Yes (2.13) Checking if you have Encode 2 ... Yes (2.42) Building and testing Encode-Locale-1.01 cp lib/Encode/Locale.pm blib/lib/Encode/Locale.pm Manifying blib/man3/Encode::Locale.3pm PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t The locale codeset (GB18030) isn't one that perl can decode, stopped at /root/.cpanm/work/1301295603.5454/Encode-Locale- 1.01/blib/lib/Encode/Locale.pm line 74. Compilation failed in require at t/arg.t line 7. BEGIN failed--compilation aborted at t/arg.t line 7. t/arg.t .. Dubious, test returned 2 (wstat 512, 0x200) No subtests run The locale codeset (GB18030) isn't one that perl can decode, stopped at /root/.cpanm/work/1301295603.5454/Encode-Locale- 1.01/blib/lib/Encode/Locale.pm line 74. Compilation failed in require at t/env.t line 7. BEGIN failed--compilation aborted at t/env.t line 7. t/env.t .. Dubious, test returned 2 (wstat 512, 0x200) No subtests run Test Summary Report ------------------- t/arg.t (Wstat: 512 Tests: 0 Failed: 0) Non-zero exit status: 2 Parse errors: No plan found in TAP output t/env.t (Wstat: 512 Tests: 0 Failed: 0) Non-zero exit status: 2 Parse errors: No plan found in TAP output Files=2, Tests=0, 0 wallclock secs ( 0.02 usr 0.01 sys + 0.05 cusr 0.00 csys = 0.08 CPU) Result: FAIL Failed 2/2 test programs. 0/0 subtests failed. make: *** [test_dynamic] 2 -> FAIL Installing ./Encode-Locale-1.01.tar.gz failed. See /root/.cpanm/build.log for details. On 2011-3꜈-28 ꜈ 02:36:11, GAAS wrote: Show quoted text
> Does it work if you just install http://search.cpan.org/dist/Encode- > HanExtra/ with your perl > first?
-- yturtle(ytnobody) <ytnobody@gmail.com> My Blog (LANG:JA-jp) http://yellowstore.blogspot.com/
Download (untitled) / with headers
text/plain 193b
It looks like Encode::HanExtra needs to explictly loaded to take effect. I've patched it in like this: <https://github.com/gisle/encode-locale/commit/2053c6ed3acb9a702fdfc8a32280b5b7fe542940>
From: ytnobody [...] gmail.com
Download (untitled) / with headers
text/plain 135b
Install was succeeded. Thank you. -- yturtle(ytnobody) <ytnobody@gmail.com> My Blog (LANG:JA-jp) http://yellowstore.blogspot.com/


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.