Skip Menu |
 

This queue is for tickets about the Memoize-Expire-ByInstance CPAN distribution.

Report information
The Basics
Id: 66988
Status: open
Priority: 0/
Queue: Memoize-Expire-ByInstance

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.500001
Fixed in: (no value)



Subject: Tests fail since perl 5.13.1
Download (untitled) / with headers
text/plain 233b
Download (untitled) / with headers
text/plain 108b
http://rt.perl.org/rt3/Ticket/Display.html?id=87650 git bisect on bleadperl points to v5.12.0-110-g7ce0928
CC: perl5-porters [...] perl.org, bug-Memoize-Expire-ByInstance [...] rt.cpan.org
Subject: [perl #87650] [rt.cpan.org #66988] Bleadperl v5.12.0-110-g7ce0928 breaks JBEVERLY/Memoize-Expire-ByInstance-0.500001.tar.gz
Date: Sun, 10 Apr 2011 18:34:55 -0700
To: "OtherRecipients of perl Ticket #87650":;
From: "Father Chrysostomos via RT" <perlbug-followup [...] perl.org>
Download (untitled) / with headers
text/plain 1.1k
On Sat Apr 02 01:09:10 2011, andreas.koenig.7os6VVqR@franz.ak.mind.de wrote: Show quoted text
> rt.cpan ticket: > --------------- > > https://rt.cpan.org/Ticket/Display.html?id=66988 > > git bisect: > ----------- > > v5.12.0-110-g7ce0928 was written for 5.12 and then merged into > blead. > It is between v5.13.0-158-g99782e3 and v5.13.0-154-g4e2ac26. > > commit 7ce092845b50544ac127e66e60d73a2f7b707464 > Author: Zefram <zefram@fysh.org> > Date: Fri Apr 23 02:22:54 2010 +0100 > > bring G_KEEPERR back to the realm of sanity > > Makes the G_KEEPERR logic more consistent, and in particular make > it > sensibly handle non-string exceptions. An exception in a > destructor > is now always emitted as a warning, and never copied or merged > into > $@ of the surrounding context. No more clobbering exceptions > being > handled elsewhere, and no more double reporting. This fixes the > rest of > [perl #74538].
This module’s tests are expecting $@ to contain something immediately after a successful eval{}. I think the module’s tests need to adjust to using a $SIG{__WARN__} handler. Hence, I do not think this needs to be a 5.14 blocker.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.