Skip Menu |
 

This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id: 66777
Status: open
Priority: 0/
Queue: CPAN

People
Owner: Nobody in particular
Requestors: chad.a.davis [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in:
  • 1.94_56
  • 1.9600
Fixed in: (no value)



Subject: t/41distribution.t fails on stock Fedora 14
Download (untitled) / with headers
text/plain 894b
In the CPAN shell, a 'test CPAN' fails with : t/41distribution.t ..... 1/19 # Failed test (t/41distribution.t at line 151) # got: '' # expected: 'HASH' # Failed test (t/41distribution.t at line 161) # Failed test (t/41distribution.t at line 151) # got: '' # expected: 'HASH' # Failed test (t/41distribution.t at line 161) # Looks like you failed 4 tests of 19. Installing, or even just 'test'ing Parse::CPAN::Meta allows the test to pass. PS This may be the result of some core modules being provided in separate RPMs on Fedora 14. It seems that CPAN may want to depend on Parse::CPAN::Meta explicitly, or an alternative parser, if there is one. This is perl 5, version 12, subversion 3 (v5.12.3) built for i386-linux-thread-multi ... with YAML 0.72 I tested this in a clean bash environment with no local::lib or perlbrew or any other voodoo.
From: batailic [...] gmail.com
On Tue Mar 22 11:15:46 2011, chad.a.davis@gmail.com wrote: Show quoted text
> In the CPAN shell, a 'test CPAN' fails with : > > t/41distribution.t ..... 1/19 # Failed test (t/41distribution.t at > line 151) > # got: '' > # expected: 'HASH' > # Failed test (t/41distribution.t at line 161) > # Failed test (t/41distribution.t at line 151) > # got: '' > # expected: 'HASH' > # Failed test (t/41distribution.t at line 161) > # Looks like you failed 4 tests of 19. > > Installing, or even just 'test'ing Parse::CPAN::Meta allows the test to > pass. > > PS This may be the result of some core modules being provided in > separate RPMs on Fedora 14. It seems that CPAN may want to depend on > Parse::CPAN::Meta explicitly, or an alternative parser, if there is one. > > This is perl 5, version 12, subversion 3 (v5.12.3) built for > i386-linux-thread-multi > ... with YAML 0.72 > I tested this in a clean bash environment with no local::lib or perlbrew > or any other voodoo. > >
This is correct on any distribution without Parse::CPAN::Meta.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.