Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 66758
Status: resolved
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors: dolmen [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.3800
Fixed in: (no value)



Subject: [meta] meta_merge => resources => license does not accept an ARRAY
Download (untitled) / with headers
text/plain 831b
The CPAN::Meta::Spec says: http://search.cpan.org/dist/CPAN-Meta/lib/CPAN/Meta/Spec.pm#resources resources => { license => [ 'http://dev.perl.org/licenses/' ], ... } But Module::Build 0.3800 refuses an ARRAY as a value for license. For example: meta_merge => { resources => { license => [ 'http://www.gnu.org/licenses/gpl-3.0.html' ], }, }, Here is the error: Could not get valid metadata. Error is: Invalid metadata structure. Errors: 'ARRAY(0x13714fc)' for 'license' does not have a URL scheme (resources -> license) [Validation: 1.4] at C:/strawberry/perl/lib/Module/Build/Base.pm line 4559 The only accepted license value seems to be a SCALAR value. Module::Build 0.3800 CPAN::Meta 2.110580 -- Olivier Mengué - http://search.cpan.org/~dolmen/ http://github.com/dolmen/
Subject: Re: [rt.cpan.org #66758] [meta] meta_merge => resources => license does not accept an ARRAY
Date: Mon, 21 Mar 2011 14:39:44 -0400
To: bug-Module-Build [...] rt.cpan.org
From: David Golden <dagolden [...] cpan.org>
Download (untitled) / with headers
text/plain 390b
2011/3/21 Olivier 'dolmen' Mengué via RT <bug-Module-Build@rt.cpan.org>: Show quoted text
> But Module::Build 0.3800 refuses an ARRAY as a value for license. For > example:
This is a known issue. Module::Build only accepts version 1.4 metadata inputs, though it outputs both v1.4 and v2 files. Eventually, the M::B API needs to be revised to do something smarter without breaking old Build.PL's. David
Download (untitled) / with headers
text/plain 937b
On Mon Mar 21 13:27:43 2011, DOLMEN wrote: Show quoted text
> The CPAN::Meta::Spec says: > http://search.cpan.org/dist/CPAN-Meta/lib/CPAN/Meta/Spec.pm#resources > > resources => { > license => [ 'http://dev.perl.org/licenses/' ], > ... > } > > But Module::Build 0.3800 refuses an ARRAY as a value for license. For > example: > > meta_merge => { > resources => { > license => [ 'http://www.gnu.org/licenses/gpl-3.0.html' ], > }, > }, > > Here is the error: > > Could not get valid metadata. Error is: Invalid metadata structure. > Errors: 'ARRAY(0x13714fc)' for 'license' does not have a URL scheme > (resources -> license) [Validation: 1.4] > at C:/strawberry/perl/lib/Module/Build/Base.pm line 4559 > > > The only accepted license value seems to be a SCALAR value. > > Module::Build 0.3800 > CPAN::Meta 2.110580
This should now work, if you include a meta-spec => { version => 2.0 } in the merge.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.