Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Constant CPAN distribution.

Report information
The Basics
Id: 66727
Status: resolved
Priority: 0/
Queue: Constant

People
Owner: Nobody in particular
Requestors: dagolden [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: (no value)
Fixed in: 1.20



Subject: Add explicit configure_requires to Build.PL
Download (untitled) / with headers
text/plain 401b
The default with recent Module::Build is to require the latest stable Module::Build to configure_requires in META.yml. Because you don't need any recent features, you should add an explicit Module:Build configure_requires so upgrading constant doesn't force an upgrade of the whole Module::Build toolchain. Targeting 0.2808 should be sufficient, as that's more or less equivalent to 5.10. -- David
Subject: Re: [rt.cpan.org #66727] Add explicit configure_requires to Build.PL
Date: Sat, 16 Apr 2011 16:33:26 +0200
To: bug-Constant [...] rt.cpan.org
From: Sébastien Aperghis-Tramoni <saper [...] cpan.org>
Download (untitled) / with headers
text/plain 620b
David Golden wrote via RT: Show quoted text
> The default with recent Module::Build is to require the latest stable > Module::Build to configure_requires in META.yml. > > Because you don't need any recent features, you should add an explicit > Module:Build configure_requires so upgrading constant doesn't force an > upgrade of the whole Module::Build toolchain. > > Targeting 0.2808 should be sufficient, as that's more or less > equivalent > to 5.10.
Thanks. Added in the latest release of constant, version 0.20, sponsored by Perl QA Hackathon 2011 in Amsterdam -- Sébastien Aperghis-Tramoni Close the world, txEn eht nepO.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.