Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 66300
Status: new
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: schwigon [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.00
Fixed in: (no value)



Subject: can_use() does not work with Module::Install::Catalyst
Download (untitled) / with headers
text/plain 851b
Hi! I'm not sure it's a problem in M::I or M::I::Catalyst. Try this Makefile.PL: ------------------------------------------------------ use inc::Module::Install; print "can_use M::I::Catalyst: ".can_use('Module::Install::Catalyst')."\n"; print "can_use Data::Dumper: ".can_use('Data::Dumper')."\n"; ------------------------------------------------------ This prints: ------------------------------------------------------ can_use M::I::Catalyst: can_use Data::Dumper: 1 ------------------------------------------------------ It should print a "1" also on M::I::Catalyst as I have it installed and perldoc and perl -M both find it. In the end I wanted to utilize all that indirectly via M::I::AuthorRequires which uses M::I::can_use(). Thanks. Steffen -- Steffen Schwigon <ss5@renormalist.net> Dresden Perl Mongers <http://dresden-pm.org/>


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.