Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Test-WWW-Mechanize CPAN distribution.

Report information
The Basics
Id: 66272
Status: resolved
Priority: 0/
Queue: Test-WWW-Mechanize

People
Owner: Nobody in particular
Requestors: TJC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 1.30
Fixed in: (no value)



Subject: t/content_lacks.t fails to pass
Download (untitled) / with headers
text/plain 827b
On Debian Squeeze, with a freshly-compiled Perl 5.12.2 and a fresh (as of March 1 2011) set of CPAN modules installed, Test::WWW::Mechanize fails one unit test, content_lacks.t t/content_lacks.t ....... 2/5 # Failed test 'Handles not finding it' # at t/content_lacks.t line 40. # STDERR is: # # Failed test 'Shouldn't say it's a test page' # # at t/content_lacks.t line 39. # # searched: "<html>\x{0a} <head>\x{0a} <title>Test Page</title>"... # # and found: "Test Page" # # at position: 33 (line 3 column 16) # # not: # /#\s+Failed\ test.*?\n?.*?at\ t\/content_lacks\.t line 39.*\n?/ # # # searched: "<html>\x{0a} <head>\x{0a} <title>Test Page</title>"... # # # and found: "Test Page" # # # at position: 33 # # as expected t/content_lacks.t ....... Failed 1/5 subtests
Download (untitled) / with headers
text/plain 113b
Note that downgrading Test::Builder::Tester to 1.20 causes the test to pass; upgrading back to 1.22 causes fail.
This is resolved in 1.31_01.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.