Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Dist-Zilla CPAN distribution.

Report information
The Basics
Id: 66095
Status: resolved
Priority: 0/
Queue: Dist-Zilla

People
Owner: Nobody in particular
Requestors: xdaveg [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Compare requirements in different phases with Version::Requirements
Date: Wed, 23 Feb 2011 15:18:14 -0500
To: bug-Dist-Zilla [...] rt.cpan.org
From: David Golden <xdaveg [...] gmail.com>
Download (untitled) / with headers
text/plain 252b
When test/requires had "1.4400" and runtime/requires had "1.44", both were included in the META file, whereas the test/requires should have been dropped out. Using Version::Requirments and satisfies() might be the right way to compare them. -- David
Download (untitled) / with headers
text/plain 578b
15:13 >xdg< rjbs, followup on prereqs in both runtime/requires and test/requires -- issue in CPAN::Meta was that one of the PCM prereqs was "1.44" and the other "1.4400". When they are equal, dzil correctly drops PCM out the test/requires 15:13 <@rjbs> Wow, that dzil guy really knows his stuff. 15:13 <xdg> maybe use Version::Requirements and satisfies()? 15:14 <@rjbs> Maybe! can you drop that in RT? 15:14 <@rjbs> I'm just getting back into a hairy work system. 15:15 <xdg> I'll try. 15:15 <xdg> Things are a bit crazy for me now, too 15:15 * rjbs will quick do it -- rjbs
I can no longer reproduce this bug. I believe it was likely fixed since it was filed. -- rjbs


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.