Skip Menu |
 

This queue is for tickets about the Bryar CPAN distribution.

Report information
The Basics
Id: 6588
Status: resolved
Worked: 1 min
Priority: 0/
Queue: Bryar

People
Owner: Nobody in particular
Requestors: mstevens [...] etla.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 2.6
Fixed in: (no value)



Subject: bryar-newblog assumes /usr/bin/perl
Download (untitled) / with headers
text/plain 262b
Perl-5.8.4, fresh bryar 2.6 install from CPAN on Fedora Core 2. The bryar-newblog script generates a bryar.cgi that assumes a perl with Bryar installed is /usr/bin/perl, rather than using the perl which is actually running bryar-newblog and has Bryar installed.
From: PLURAL
Download (untitled) / with headers
text/plain 711b
[MSTEVENS - Thu Jun 10 16:57:42 2004]: Show quoted text
> Perl-5.8.4, fresh bryar 2.6 install from CPAN on Fedora Core 2. > > The bryar-newblog script generates a bryar.cgi that assumes a perl > with Bryar installed is /usr/bin/perl, rather than using the perl > which is actually running bryar-newblog and has Bryar installed.
With the new developer releases (and conceivably with the old releases), ExtUtils::MakeMaker should have rewritten the shebang line to deal with this. The #!/usr/bin/perl should have been the changed to the location of the perl running the build/install process. I will try to replicate and with the 2.6 release and update if needed, however, the new development is all in the 2.8 branch now.
Download (untitled) / with headers
text/plain 103b
Thanks, this is fixed in CVS (see the 'drhyde' project on Sourceforge) and will be in the next release.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.