Skip Menu |
 

This queue is for tickets about the Perl-Dist-Strawberry CPAN distribution.

Report information
The Basics
Id: 65439
Status: resolved
Priority: 0/
Queue: Perl-Dist-Strawberry

People
Owner: Nobody in particular
Requestors: matthew.pettis [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Bug report: CPAN program not working correctly when installing strawberry perl to drive other than c:
Date: Thu, 3 Feb 2011 21:28:46 -0600
To: bug-Perl-Dist-Strawberry [...] rt.cpan.org
From: Matthew Pettis <matthew.pettis [...] gmail.com>
Download (untitled) / with headers
text/plain 608b
Installer: strawberry-perl-5.12.2.0.msi OS: Windows Vista Home Premium Service Pack 2 HW: Acer Aspire 9410Z Problem: Using the Installer, I asked for the install to be located at d:\strawberry. This installed fine, and perl itself worked. When I used d:\strawberry\perl\bin\cpan to install the module 'Modern::Perl', it installed it to c:\strawberry\.... , not d:\strawberry. When I ran 'o conf' in cpan, I saw that all of the paths for cpan were pointing to c:\strawberry\... I went on irc.perl.org/win32, and it was recommended that I file a bug report. Thank you for your work on this project, Matt
Hi Matt,

the bug you are talking about seems to be a regression bug in 5.12.2.0 (MSI only) version.

To say it in short:

The relocation dome by MSI installer does not work at all. The installer works fine just in case you install in default location c:\strawberry. Other locations like d:\strawberry or c:\strawberry512 or whatever else breaks the installation exactly as you have described.

Workaround:

After installation to non-default directory - e.g. d:\strawberry - run manually the script d:\strawberry\relocation.pl.bat

Side note for Curtis: this is something that we need to fix veeeery quickly.

--
kmx
Subject: Re: [rt.cpan.org #65439] Bug report: CPAN program not working correctly when installing strawberry perl to drive other than c:
Date: Sun, 6 Mar 2011 10:19:52 -0600
To: bug-Perl-Dist-Strawberry [...] rt.cpan.org
From: Matthew Pettis <matthew.pettis [...] gmail.com>
thank you very much! On Sun, Mar 6, 2011 at 6:55 AM, kmx via RT < bug-Perl-Dist-Strawberry@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=65439 > > > Hi Matt, > > the bug you are talking about seems to be a regression bug in 5.12.2.0 (MSI > only) version. > > To say it in short: > > The relocation dome by MSI installer does not work at all. The installer > works > fine just in case you install in default location c:\strawberry. Other > locations like d:\strawberry or c:\strawberry512 or whatever else breaks > the > installation exactly as you have described. > > Workaround: > > After installation to non-default directory - e.g. d:\strawberry - run > manually > the script d:\strawberry\relocation.pl.bat > > Side note for Curtis: this is something that we need to fix veeeery > quickly. > > -- > kmx > >
-- Seven Deadly Sins (Gandhi): - Wealth without work - Politics without principle - Pleasure without conscience - Commerce without morality - Science without humanity - Worship without sacrifice - Knowledge without character
should be fixed in strawberry perl 5.14.2.1
Subject: Re: [rt.cpan.org #65439] Bug report: CPAN program not working correctly when installing strawberry perl to drive other than c:
Date: Sun, 26 Feb 2012 14:41:29 -0600
To: bug-Perl-Dist-Strawberry [...] rt.cpan.org
From: Matthew Pettis <matthew.pettis [...] gmail.com>
Download (untitled) / with headers
text/plain 354b
Thank You! Sincerely, Matt On Sun, Feb 26, 2012 at 2:21 PM, kmx via RT <bug-Perl-Dist-Strawberry@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=65439 > > > should be fixed in strawberry perl 5.14.2.1 >
-- Do not seek to follow in the footsteps of the wise men of old. Seek what they sought. - Matsuo Munefusa (”Basho”)
Download (untitled) / with headers
text/plain 105b
Sending the previous mail has failed. Please contact your admin, they can find more details in the logs.
Subject: Re: [rt.cpan.org #65439] Resolved: Bug report: CPAN program not working correctly when installing strawberry perl to drive other than c:
Date: Sun, 26 Feb 2012 16:07:04 -0600
To: bug-Perl-Dist-Strawberry [...] rt.cpan.org
From: Matthew Pettis <matthew.pettis [...] gmail.com>
Download (untitled) / with headers
text/plain 443b
Just a Thank You! Matt On Sun, Feb 26, 2012 at 2:21 PM, kmx via RT <bug-Perl-Dist-Strawberry@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=65439 > > > According to our records, your request has been resolved. If you have any > further questions or concerns, please respond to this message.
-- Do not seek to follow in the footsteps of the wise men of old. Seek what they sought. - Matsuo Munefusa (”Basho”)


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.