Skip Menu |
 

This queue is for tickets about the App-perlbrew CPAN distribution.

Report information
The Basics
Id: 65350
Status: open
Priority: 0/
Queue: App-perlbrew

People
Owner: Nobody in particular
Requestors: chad.a.davis [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 0.15
Fixed in: (no value)



Subject: perlbrew install requires -Dusethreads
Download (untitled) / with headers
text/plain 794b
Compiling perl-5.12.3 without any options resulted in undefined symbol errors (e.g. in Raw::Zlib when running cpan), until I compiled it with perlbew install perl-5.12.3 -Dusethreads It seems that perlbrew assumes threads in some places, but not in others, leading to an inconsistency which breaks Perl (maybe just 5.12?). Maybe perlbrew needs to -Dusethreads by default in some cases? Error: perl: symbol lookup error: /usr/local/perl/Ubuntu-10.10- x86_64/lib/perl5/x86_64-linux-gnu-thread- multi/auto/Compress/Raw/Zlib/Zlib.so: undefined symbol: Perl_Gthr_key_ptr zlib-dev is installed (1:1.2.3.4.dfsg-3ubuntu1) pmvers App::perlbrew 0.15 perl -v This is perl, v5.10.1 (*) built for x86_64-linux-gnu-thread-multi uname -a Linux 2.6.35-25-generic #44-Ubuntu SMP x86_64 GNU/Linux
Download (untitled) / with headers
text/plain 233b
That's not an issue with perlbrew itself but the module assumes to install on a threaded perl. You can pass any parameters to configure using the -D,-U,-A switches, in your case -Dusethreads which will build a threading enabled Perl.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.