This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id:
65102
Status:
open
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
rkitover [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Normal
Broken in:
1.94_56
Fixed in:
(no value)



Subject: pretty CPAN colors broken after writing CPAN config
Show quoted text
cpan> o conf test_report 1
test_report [1] Please use 'o conf commit' to make the config permanent!
Show quoted text
cpan> o conf commit
commit: wrote 'C:\Perl\lib/CPAN/Config.pm'
Show quoted text
cpan> quit
Lockfile removed. rkitover@EEEBOX ~ $ cpan ā†[32m cpan shell -- CPAN exploration and modules installation (v1.9456) Enter 'h' for help.ā†[0m As you can see, the ANSI colore codes are now broken :( Maybe this has something to do with the test_report option.
Please try o conf init /color/ and report whether you could repair your colors in that dialog.
Subject: Re: [rt.cpan.org #65102] pretty CPAN colors broken after writing CPAN config
Date: Tue, 25 Jan 2011 16:51:01 -0500
To: bug-CPAN@rt.cpan.org
From: Rafael Kitover <rkitover@cpan.org>
On 1/25/2011 4:29 PM, Andreas Koenig via RT wrote:
Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=65102> > > Please try > > o conf init /color/ > > and report whether you could repair your colors in that dialog.
Nope, does not help.
Probably not the correct "solution", but I'm now using ANSICON, and that gives me back the colors. http://adoxa.110mb.com/ansicon/index.html


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.