Skip Menu |
 

This queue is for tickets about the ExtUtils-Constant CPAN distribution.

Report information
The Basics
Id: 64965
Status: open
Priority: 0/
Queue: ExtUtils-Constant

People
Owner: Nobody in particular
Requestors: leonerd-cpan [...] leonerd.org.uk
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.23
Fixed in: (no value)



Subject: Builds unusable code for perl 5.10.1
Download (untitled) / with headers
text/plain 558b
The following line gets created by ExtUtils::Constant: croak_sv(sv_2mortal(sv)); This fails on Perl 5.10.1 (and likely others), because croak_sv doesn't exist. By noticing that the sv is in fact a plain SvPV, I managed to get the code to compile and run against 5.10.1 by just changing this to croak(SvPV_nolen(sv_2mortal(sv))); Quite likely a total hack, but it gets my code working. :) Perhaps EU::C could generate some code for older perls that would actually work - I'm not sure if this form is best, or something else. -- Paul Evans
Download (untitled) / with headers
text/plain 749b
+1 I find failures of Crypt::SMIME on Perl <=5.12 http://matrix.cpantesters.org/?dist=Crypt-SMIME+0.19 are caused by this issue. On Thu Jan 20 13:55:12 2011, PEVANS wrote: Show quoted text
> The following line gets created by ExtUtils::Constant: > > croak_sv(sv_2mortal(sv)); > > This fails on Perl 5.10.1 (and likely others), because croak_sv doesn't > exist. By noticing that the sv is in fact a plain SvPV, I managed to get > the code to compile and run against 5.10.1 by just changing this to > > croak(SvPV_nolen(sv_2mortal(sv))); > > Quite likely a total hack, but it gets my code working. :) > > Perhaps EU::C could generate some code for older perls that would > actually work - I'm not sure if this form is best, or something else.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.