Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the CGI-Application-Plugin-Authentication CPAN distribution.

Report information
The Basics
Id:
64919
Status:
open
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
ASB [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
0.19
Fixed in:
(no value)



Subject: test fails on Windows 7 x64 with strawberry perl 5.12.2 x64
Hi! Please find attached to output from the cpan console, where the failed tests are listed. CAP::Authentication v. 0.17 installs fine. I tried 0.17_8 and 0.18, too, they both failed. More information: * OS: Windows 7 x64 * Perl: strawberry perl 5.12.2 built for MSWin32-x64-multi-thread hth, Alex
Subject: capauth.log.txt
Running install for module 'CGI::Application::Plugin::Authentication' Running make for S/SI/SILASMONK/CGI-Application-Plugin-Authentication-0.19.tar.gz Checksum for C:\strawberry\cpan\sources\authors\id\S\SI\SILASMONK\CGI-Application-Plugin-Authentication-0.19.tar.gz ok Scanning cache C:\strawberry\cpan\build for sizes ........................................................--------------------DONE DEL(1/19): C:\strawberry\cpan\build\CGI-Application-Plugin-Authentication-0.19-fhQqyT DEL(2/19): C:\strawberry\cpan\build\CGI-Application-Plugin-Authentication-0.19-fhQqyT.yml DEL(3/19): C:\strawberry\cpan\build\Crypt-PasswdMD5-1.3-pincWO DEL(4/19): C:\strawberry\cpan\build\Crypt-PasswdMD5-1.3-pincWO.yml DEL(5/19): C:\strawberry\cpan\build\Apache-Htpasswd-1.8-EDSCxp.yml DEL(6/19): C:\strawberry\cpan\build\Apache-Htpasswd-1.8-EDSCxp DEL(7/19): C:\strawberry\cpan\build\Graphics-ColorNames-2.11-fYmJvb DEL(8/19): C:\strawberry\cpan\build\Graphics-ColorNames-2.11-fYmJvb.yml DEL(9/19): C:\strawberry\cpan\build\Graphics-ColorNames-WWW-1.13-9KCuCb DEL(10/19): C:\strawberry\cpan\build\Graphics-ColorNames-WWW-1.13-9KCuCb.yml DEL(11/19): C:\strawberry\cpan\build\Color-Calc-1.070-HqfzX0 DEL(12/19): C:\strawberry\cpan\build\Color-Calc-1.070-HqfzX0.yml DEL(13/19): C:\strawberry\cpan\build\Authen-Simple-0.4-RUF59E DEL(14/19): C:\strawberry\cpan\build\Authen-Simple-0.4-RUF59E.yml DEL(15/19): C:\strawberry\cpan\build\CGI-Application-Plugin-Authentication-Driver-DBIC-0.02-jcR88f DEL(16/19): C:\strawberry\cpan\build\CGI-Application-Plugin-Authentication-Driver-DBIC-0.02-jcR88f.yml DEL(17/19): C:\strawberry\cpan\build\Crypt-DSA-1.16-i8UUtm DEL(18/19): C:\strawberry\cpan\build\Crypt-DSA-1.16-i8UUtm.yml DEL(19/19): C:\strawberry\cpan\build\CGI-Application-Plugin-ValidateRM-2.3-KTOsK_ CPAN.pm: Going to build S/SI/SILASMONK/CGI-Application-Plugin-Authentication-0.19.tar.gz Creating new 'MYMETA.yml' with configuration results Creating new 'Build' script for 'CGI-Application-Plugin-Authentication' version '0.19' Building CGI-Application-Plugin-Authentication SILASMONK/CGI-Application-Plugin-Authentication-0.19.tar.gz C:\strawberry\perl\bin\perl.exe ./Build -- OK Running Build test t\01_basic.t ........................ ok t\02_config.t ....................... ok t\03_authenticate.t ................. ok t\03_destination.t .................. skipped: Not running these tests on windows yet t\03_login_box.t .................... skipped: Not running these tests on windows yet t\03_login_box_basic.t .............. skipped: Not running these tests on windows yet t\03_login_box_other.t .............. skipped: Not running these tests on windows yet t\03_missing_color.t ................ skipped: Not running these tests on windows yet t\04_attributes.t ................... ok t\05_autorunmode.t .................. skipped: CGI::Application::Plugin::AutoRunmode required for this test t\06_timeout.t ...................... ok t\07_protected_runmodes.t ........... ok t\40_encoder_crypt.t ................ ok t\40_encoder_lc.t ................... ok t\40_encoder_md5.t .................. ok t\40_encoder_sha1.t ................. ok t\40_encoder_strip.t ................ ok t\40_encoder_uc.t ................... ok t\50_driver_missing_modules.t ....... skipped: Not running these tests on windows yet t\50_driver_undefined.t ............. skipped: Not running these tests on windows yet t\51_driver_dummy.t ................. ok t\52_driver_generic.t ............... ok t\53_driver_dbi.t ................... ok t\53_driver_dbi_bad.t ............... ok t\53_driver_dbi_die.t ............... ok t\53_driver_dbi_syntax.t ............ ok t\54_driver_htpasswd.t .............. ok t\55_driver_authensimple.t .......... skipped: Authen::Simple required for this test t\55_driver_authensimple_die.t ...... ok t\55_driver_missing_authensimple.t .. ok t\60_parsimony.t .................... ok t\60_store.t ........................ ok t\60_store_cookie.t ................. ok t\60_store_session.t ................ ok t\70_action_dispatch.t .............. skipped: CGI::Application::Plugin::ActionDispatch required t\80_devpopup.t ..................... skipped: Not running these tests on windows yet t\98_pod.t .......................... skipped: Author test. Set $ENV{TEST_AUTHOR} to a true value to run. t\99_pod_coverage.t ................. skipped: Author test. Set $ENV{TEST_AUTHOR} to a true value to run. t\changes.t ......................... skipped: Author test. Set $ENV{TEST_AUTHOR} to a true value to run. t\manifest.t ........................ skipped: Author test. Set $ENV{TEST_AUTHOR} to a true value to run. t\podspell.t ........................ skipped: Author test. Set $ENV{TEST_AUTHOR} to a true value to run. t\prereq.t .......................... skipped: Author test. Set $ENV{TEST_PREREQ} to a true value to run. Test Summary Report ------------------- t\03_login_box_basic.t (Wstat: 0 Tests: 1 Failed: 1) Failed test: 1 Parse errors: Bad plan. You planned 0 tests but ran 1. t\03_missing_color.t (Wstat: 0 Tests: 1 Failed: 1) Failed test: 1 Parse errors: Bad plan. You planned 0 tests but ran 1. Files=42, Tests=415, 15 wallclock secs ( 0.27 usr + 0.17 sys = 0.44 CPU) Result: FAIL SILASMONK/CGI-Application-Plugin-Authentication-0.19.tar.gz C:\strawberry\perl\bin\perl.exe ./Build test -- NOT OK //hint// to see the cpan-testers results for installing this module, try: reports SILASMONK/CGI-Application-Plugin-Authentication-0.19.tar.gz Running Build install make test had returned bad status, won't install without force
I am aware that there are issues with getting these tests to work on windows. I have never been able to reproduce them myself. I wonder if that is because I use active state's perl rather than strawberry. One thing you might be able to try is upgrading Test::Regression to the latest version I would be interested to know if that helps. Since you should be able to force the installation I think this cannot be critical. On Wed Jan 19 06:27:03 2011, ASB wrote:
Show quoted text
> Hi! > > Please find attached to output from the cpan console, where the failed > tests are listed. > CAP::Authentication v. 0.17 installs fine. I tried 0.17_8 and 0.18, too, > they both failed. > > > More information: > * OS: Windows 7 x64 > * Perl: strawberry perl 5.12.2 built for MSWin32-x64-multi-thread > > hth, Alex
Hi! I found a clue. When removing Test::NoWarnings, the test does not fail anymore: [code] #!/usr/bin/perl -T use Test::More; use Test::Taint; use Test::Regression; #use Test::NoWarnings; use Test::Exception; use English qw(-no_match_vars); use lib qw(t); if ($OSNAME eq 'MSWin32') { my $msg = 'Not running these tests on windows yet'; plan skip_all => $msg; exit(0); } ... [/code] However, I'm not able to help any further, as I'm unfamiliar with most of the test modules (I know, I should change that...). Also, removing Test::NoWarnings; is possible for me, because the tests donÄt run anyway. I don't know if it's obligatory on other OS. hth, Alex
I suspect the solution is to lock down on this error: Use of uninitialized value in lc at C:\home\stro\cpan\build\5.13.11\CGI-Application-Plugin-Authentication-0.20-AzwPsj\blib\lib/CGI/Application/Plugin/Authentication/Driver/Filter/crypt.pm line 18. I'll try and look into that for the next release. On Wed Jan 19 06:27:03 2011, ASB wrote:
Show quoted text
> Hi! > > Please find attached to output from the cpan console, where the failed > tests are listed. > CAP::Authentication v. 0.17 installs fine. I tried 0.17_8 and 0.18, too, > they both failed. > > > More information: > * OS: Windows 7 x64 > * Perl: strawberry perl 5.12.2 built for MSWin32-x64-multi-thread > > hth, Alex


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.