Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Dist-Zilla CPAN distribution.

Report information
The Basics
Id: 64302
Status: resolved
Priority: 0/
Queue: Dist-Zilla

People
Owner: Nobody in particular
Requestors: mkanat [...] cpan.org
Cc: shuff [...] cpan.org
AdminCc:

Bug Information
Severity: Normal
Broken in: 4.200000
Fixed in: 4.200006



Subject: Requiring EU:MM 6.31 excludes RHEL5
Download (untitled) / with headers
text/plain 612b
Right now, the MakeMaker plugin sets a requirement on EU::MM 6.31. It looks like this is only required for proper share_dir behavior: https://github.com/rjbs/dist- zilla/commit/51cd68ade4f5b3cee4afcb81e1bd20a728286585 Unfortunately, RHEL5's Perl only ships with 6.30, meaning that it's difficult to install any Dist::Zilla-built module on RHEL5. (It's difficult to update MakeMaker on RHEL, and most admins won't want to for package-management reasons in any case.) Since we only require the updated version for the share_dir, could we make the requirement only happen if you're using that feature? -Max
On 2010-12-29 22:36:21, MKANAT wrote:
Show quoted text
> Right now, the MakeMaker plugin sets a requirement on EU::MM 6.31. It
> looks like this is only required for proper share_dir behavior:
>
> https://github.com/rjbs/dist-
> zilla/commit/51cd68ade4f5b3cee4afcb81e1bd20a728286585
>
> Unfortunately, RHEL5's Perl only ships with 6.30, meaning that it's
> difficult to install any Dist::Zilla-built module on RHEL5. (It's
> difficult to update MakeMaker on RHEL, and most admins won't want to for
> package-management reasons in any case.) Since we only require the
> updated version for the share_dir, could we make the requirement only
> happen if you're using that feature?
>
> -Max

ExtUtils::MakeMaker 6.31 came out in  2006, so rhel5 is approaching 5-years-out-of-date if that really is the case.

Are you sure there are no smarter alternatives? After all, if you can't install MakeMaker for "Package management reasons" then you probably can't install Dist-Zilla *anyway* for the same reasons.

If these reasons exist because you're using CPAN to install to vendors' system perl , then I'd hazard to say you're doing it wrong.

Its strongly recommended for peoples in your situation to use a local::lib installation, that is, a user/local perl5lib directory under which arbitrary upgrades and installations can be performed without interacting with or tainting the system perl5lib.

Other than this, your best bet in my opinion is petition rhel to update their perl toolchain, because 5 years out of date is somewhat rediculous in my opinion. ( Because since then, a copious amount of bug fixes have occurred, and there are reasons more than just 'share_dir' for which you'll probably want it upgraded for :  http://cpansearch.perl.org/src/MSCHWERN/ExtUtils-MakeMaker-6.57_01/Changes

Download (untitled) / with headers
text/plain 1.6k
Hey Kent. Thanks for your reply. I think you may have misunderstood my request. I would never attempt to develop a CPAN module on RHEL5, but I would like to able to install them on RHEL5. I'm not concerned that Dist::Zilla itself requires MakeMaker 6.31. That's fine. The problem is that Dist::Zilla::Plugins::MakeMaker creates a Makefile.PL that *always* explicitly requires EU:MM 6.31, even when we aren't using features that require EU:MM 6.31. So all modules *created with* Dist::Zilla cannot be easily packaged for RHEL5, since we can't package a new MakeMaker RPM. (In modern versions of Fedora and in RHEL6, this isn't a problem, because all dual-life modules have their own packages and can be upgraded separately. But in RHEL5 there was only one "perl" package, so there's no way to have a separate MakeMaker RPM.) As far as I know, RHEL5 and its derivatives (primarily CentOS 5) are still the most popular Linux server OS in the world. So, requiring EU::MM 6.31 for more and more CPAN modules is excluding a larger and large number of servers from being able to effectively install those CPAN modules. It's very easy to say "they should update their toolchain," but they're not going to make that sort of change on a stable enterprise OS. They in fact already *have* made it in Fedora and RHEL6, so this problem should be considerably less serious in about two years. But for now the practical aspect is that the world would have a much easier time packaging CPAN modules for many or most Linux servers if those CPAN modules did start with "use ExtUtils::MakeMaker 6.31" in Makefile.PL, and didn't depend on that version in order to be built, unless they really did require it.
I can't see what 6.31 got us over 6.30 Prereq lowered. -- rjbs


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.