Skip Menu |
 

This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id: 64037
Status: resolved
Priority: 0/
Queue: CPAN

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in:
  • 1.9304
  • 1.94_62
Fixed in: (no value)



Subject: Data-Encoder-0.03.tar.gz cannot be built (because of Archive::Tar)
Download (untitled) / with headers
text/plain 844b
It seems that Archive::Tar cannot handle Data-Encoder-0.03.tar.gz: Show quoted text
cpan> look Data::Encoder
... CPAN: Archive::Tar loaded ok (v1.68) PaxHeader/Data-Encoder-0.03 Data-Encoder-0.03/ Data-Encoder-0.03/PaxHeader/Changes ... Package seems to come without Makefile.PL. (The test -f "/usr/local/src/CPAN/build/XAICRON-OW_uBf/Makefile.PL" returned false.) Writing one on our own (setting NAME to DataEncoder) Problem is that an additional "PaxHeader" directory is seen here by Archive::Tar. The normal freebsd tar command does not extract such a directory. Unfortunately using "o conf tar /usr/bin/tar" does not help to fix this problem, Archive::Tar is nevertheless used. All in all: - probably Archive::Tar should not be the default for extracting distributions - it should be possible to specify another tar command Regards, Slaven
Download (untitled) / with headers
text/plain 179b
While I agree in principle that the current default policy isn't flexible enough, I observed the upgrading to Archive::Tar 1.74 works. Haven't tried versions between 1.68 and 1.74
Download (untitled) / with headers
text/plain 898b
On 2010-12-19 11:05:05, ANDK wrote: Show quoted text
> While I agree in principle that the current default policy isn't > flexible enough, I observed the upgrading to Archive::Tar 1.74 works. > Haven't tried versions between 1.68 and 1.74
Yes, it was fixed in Archive::Tar 1.74 yesterday. It was broken in 1.72. See the related ticket in the Archive::Tar queue. BTW, would it be possible to force CPAN.pm to upgrade Archive::Tar via distroprefs? I tried this: match: distribution: "/Data-Encoder-0\.03\." depends: configure_requires: Archive::Tar: 1.74 But unfortunately first Data-Encoder-0.03.tar.gz is extracted, and after that Archive::Tar built. Maybe there should be also an "extract_requires" keyword? But this would be somewhat special, because an "extract_requires" keyword would be meaningless in a META.yml, and "depends" tries to mimic the META.yml counterparts. Regards, Slaven
Download (untitled) / with headers
text/plain 122b
Rudimentary fix in e8c5279 in the repository. If nobody objects to this sort of fix I'll make it complete later this week.
Fixed in 1.94_63


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.