Skip Menu |
 

This queue is for tickets about the Catalyst-TraitFor-Request-ProxyBase CPAN distribution.

Report information
The Basics
Id: 63886
Status: rejected
Priority: 0/
Queue: Catalyst-TraitFor-Request-ProxyBase

People
Owner: Nobody in particular
Requestors: rjk [...] tamias.net
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: (no value)
Fixed in: (no value)



Subject: META.yml should require CatalystX::RoleApplicator
Download (untitled) / with headers
text/plain 114b
CatalystX::RoleApplicator is listed under build_requires in META.yml, but should be listed under requires instead.
Download (untitled) / with headers
text/plain 749b
Show quoted text
> CatalystX::RoleApplicator is listed under build_requires in META.yml, > but should be listed under requires instead.
No, it shouldn't. The most usual use case is to use CatalystX::RoleApplicator to apply the role to your request class, _HOWEVER_, you _can_ make a MyApp::Request class, which inherits from Catalyst::Request and applies the role in the traditional way (i.e. with 'Catalyst::TraitFor::Request::ProxyBase' in the class), and you can then override the default request class in your application. As such - ::RoleApplicator is not a runtime dependency of this distribution - it is a dependency of your application if you use it. Therefore I'm going to reject this, but I'd love a doc patch to clarify this if you fancy making one :)


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.