Skip Menu |
 

This queue is for tickets about the Apache-DBI CPAN distribution.

Report information
The Basics
Id: 63711
Status: new
Priority: 0/
Queue: Apache-DBI

People
Owner: Nobody in particular
Requestors: MRDVT [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in:
  • 1.08
  • 1.09
Fixed in: (no value)



Subject: Apache::AuthDBI will not run without Apache::DBI
Download (untitled) / with headers
text/plain 877b
Please note I'm running 1.08 as that is what is in FC12 repo. But, the delta from 1.08 and 1.09 show no changes with respect to this bug. Error from /var/log/httpd/error_log [Tue Dec 07 18:58:52 2010] [error] Can't locate object method "is_initial_req" via package "Apache2::RequestRec" at /usr/lib/perl5/vendor_perl/5.10.0/Apache/AuthDBI.pm line 216.\n Found this from Google dated back to 2008 http://www.1-script.com/forums/Can-t-locate-object-method-is-initial- req-article97401--6.htm Posted by joe on June 11, 2008, 10:59 am Found the problem. Not sure how it got to be like this. but I had to add require Apache2::RequestUtil; to the list or required libs in AuthDBI.pm. require Apache2::Const; + require Apache2::RequestRec; require Apache2::RequestUtil; But, another work around is to 'use Apache::DBI;' in a PerlRequire script. Mike (mrdvt92)


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.