Skip Menu |
 

This queue is for tickets about the Apache-DBI CPAN distribution.

Report information
The Basics
Id: 63691
Status: open
Priority: 0/
Queue: Apache-DBI

People
Owner: Nobody in particular
Requestors: MRDVT [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in:
  • 1.08
  • 1.09
Fixed in: (no value)



Subject: Auth_DBI_pwdcasesensitive=off does not work while Auth_DBI_encrypted=off
Download (untitled) / with headers
text/plain 375b
Fixed bug where Auth_DBI_pwdcasesensitive=off does not work while Auth_DBI_encrypted=off The attached patch simply changes this one line - my $select = "SELECT $Attr->{pwd_field}"; + my $select = "SELECT ". ($Attr->{encrypted} ne 'on' && $Attr->{pwdcasesensitive} ne 'on' ? "lower($Attr-> {pwd_field})" : "$Attr->{pwd_field}"); Thanks, Mike mrdvt92
Subject: Apache-DBI-1.09.patch
diff -Naur /tmp/tmp.wQw9bUJ04G/Apache-DBI-1.09/Changes /tmp/tmp.LOb8eaVxc9/Apache-DBI-1.10/Changes --- /tmp/tmp.wQw9bUJ04G/Apache-DBI-1.09/Changes 2010-11-18 19:55:47.000000000 +0000 +++ /tmp/tmp.LOb8eaVxc9/Apache-DBI-1.10/Changes 2010-12-07 05:45:13.000000000 +0000 @@ -1,5 +1,9 @@ Revision history for ApacheDBI. +1.10 December 07, 2010 + - Fixed bug where Auth_DBI_pwdcasesensitive=off does not work while Auth_DBI_encrypted=off + Submitted by: Michael R. Davis <mrdvt92 at pretty much everywhere> + 1.09 November 11, 2010 - Fix pod errors Submitted by: Damyan Ivanov <dmn@debian.org> diff -Naur /tmp/tmp.wQw9bUJ04G/Apache-DBI-1.09/lib/Apache/AuthDBI.pm /tmp/tmp.LOb8eaVxc9/Apache-DBI-1.10/lib/Apache/AuthDBI.pm --- /tmp/tmp.wQw9bUJ04G/Apache-DBI-1.09/lib/Apache/AuthDBI.pm 2010-11-18 19:55:47.000000000 +0000 +++ /tmp/tmp.LOb8eaVxc9/Apache-DBI-1.10/lib/Apache/AuthDBI.pm 2010-12-07 05:40:07.000000000 +0000 @@ -1,7 +1,7 @@ # $Id$ package Apache::AuthDBI; -$Apache::AuthDBI::VERSION = '1.09'; +$Apache::AuthDBI::VERSION = '1.10'; # 1: report about cache miss # 2: full debug output @@ -335,7 +335,7 @@ # generate statement my $user_sent_quoted = $dbh->quote($user_sent); - my $select = "SELECT $Attr->{pwd_field}"; + my $select = "SELECT ". ($Attr->{encrypted} ne 'on' && $Attr->{pwdcasesensitive} ne 'on' ? "lower($Attr->{pwd_field})" : "$Attr->{pwd_field}"); my $from = "FROM $Attr->{pwd_table}"; my $where = ($Attr->{uidcasesensitive} eq "off") ? "WHERE lower($Attr->{uid_field}) =" : diff -Naur /tmp/tmp.wQw9bUJ04G/Apache-DBI-1.09/lib/Apache/DBI.pm /tmp/tmp.LOb8eaVxc9/Apache-DBI-1.10/lib/Apache/DBI.pm --- /tmp/tmp.wQw9bUJ04G/Apache-DBI-1.09/lib/Apache/DBI.pm 2010-11-18 19:55:47.000000000 +0000 +++ /tmp/tmp.LOb8eaVxc9/Apache-DBI-1.10/lib/Apache/DBI.pm 2010-12-07 05:39:51.000000000 +0000 @@ -22,7 +22,7 @@ require_version DBI 1.00; -$Apache::DBI::VERSION = '1.09'; +$Apache::DBI::VERSION = '1.10'; # 1: report about new connect # 2: full debug output diff -Naur /tmp/tmp.wQw9bUJ04G/Apache-DBI-1.09/META.yml /tmp/tmp.LOb8eaVxc9/Apache-DBI-1.10/META.yml --- /tmp/tmp.wQw9bUJ04G/Apache-DBI-1.09/META.yml 2010-11-18 19:56:05.000000000 +0000 +++ /tmp/tmp.LOb8eaVxc9/Apache-DBI-1.10/META.yml 2010-12-07 05:46:47.000000000 +0000 @@ -1,24 +1,16 @@ --- #YAML:1.0 -name: Apache-DBI -version: 1.09 -abstract: ~ -author: [] -license: unknown -distribution_type: module -configure_requires: - ExtUtils::MakeMaker: 0 -build_requires: - ExtUtils::MakeMaker: 0 -requires: - DBI: 1 - Digest::MD5: 2.2 - Digest::SHA1: 2.01 - Test::More: 0 -no_index: - directory: - - t - - inc -generated_by: ExtUtils::MakeMaker version 6.56 +name: Apache-DBI +version: 1.10 +abstract: ~ +license: ~ +author: ~ +generated_by: ExtUtils::MakeMaker version 6.42 +distribution_type: module +requires: + DBI: 1 + Digest::MD5: 2.2 + Digest::SHA1: 2.01 + Test::More: 0 meta-spec: - url: http://module-build.sourceforge.net/META-spec-v1.4.html - version: 1.4 + url: http://module-build.sourceforge.net/META-spec-v1.3.html + version: 1.3
RT-Send-CC: fred [...] redhotpenguin.com
Download (untitled) / with headers
text/plain 307b
--- On Tue, 12/7/10, Fred Moyer <fred@redhotpenguin.com> wrote: Show quoted text
> Reviewed 63691 and the patch looks sane. Can you > provide an svn diff against the source? > > svn co https://svn.apache.org/repos/asf/perl/Apache-DBI/trunk/ > Apache-DBI
This is the exact package that I have been running for weeks now.
Subject: Apache-DBI.svn.20101230.diff
Property changes on: . ___________________________________________________________________ Added: svn:ignore + pm_to_blib blib Makefile Index: lib/Apache/AuthDBI.pm =================================================================== --- lib/Apache/AuthDBI.pm (revision 1054038) +++ lib/Apache/AuthDBI.pm (working copy) @@ -335,7 +335,7 @@ # generate statement my $user_sent_quoted = $dbh->quote($user_sent); - my $select = "SELECT $Attr->{pwd_field}"; + my $select = "SELECT ". ($Attr->{encrypted} ne 'on' && $Attr->{pwdcasesensitive} ne 'on' ? "lower($Attr->{pwd_field})" : "$Attr->{pwd_field}"); my $from = "FROM $Attr->{pwd_table}"; my $where = ($Attr->{uidcasesensitive} eq "off") ? "WHERE lower($Attr->{uid_field}) =" : Index: Changes =================================================================== --- Changes (revision 1054038) +++ Changes (working copy) @@ -1,8 +1,9 @@ Revision history for ApacheDBI. 1.10 + - Fixed bug where Auth_DBI_pwdcasesensitive=off does not work while Auth_DBI_encrypted=off + Submitted by: Michael R. Davis <mrdvt92 at pretty much everywhere> - 1.09 November 11, 2010 - Fix pod errors Submitted by: Damyan Ivanov <dmn@debian.org>


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.