This queue is for tickets about the WWW-Facebook-API CPAN distribution.

Report information
The Basics
Id:
63099
Status:
open
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
0.4.15
Fixed in:
(no value)



Subject: CGI.pm is undeclared dependency
CGI should be declared as a dependency.
Subject: WFA-04.18.patch
Only in WWW-Facebook-API: Makefile diff -ru WWW-Facebook-API-0.4.18/Makefile.PL WWW-Facebook-API/Makefile.PL --- WWW-Facebook-API-0.4.18/Makefile.PL 2009-08-21 22:45:23.000000000 -0700 +++ WWW-Facebook-API/Makefile.PL 2010-11-17 13:34:50.000000000 -0800 @@ -17,6 +17,7 @@ 'Time::HiRes' => 0, 'LWP::UserAgent' => 0, 'Readonly' => 0, + 'CGI' => 0, }, META_MERGE => { resources => { Only in WWW-Facebook-API: blib Only in WWW-Facebook-API: pm_to_blib
On 2010-11-17 16:48:52, MichaelRWolf@att.net wrote:
Show quoted text
> CGI should be declared as a dependency.
CGI.pm is not anymore part of the core modules in newer perls. See http://www.cpantesters.org/cpan/report/8b1bcdac-6740-11e5-b836-a6595406e694 for a sample fail report because of the missing dependency declaration.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.