Skip Menu |
 

This queue is for tickets about the Math-GSL CPAN distribution.

Report information
The Basics
Id: 62893
Status: resolved
Priority: 0/
Queue: Math-GSL

People
Owner: Nobody in particular
Requestors:
Cc:
AdminCc:

Bug Information
Severity: Wishlist
Broken in: (no value)
Fixed in: (no value)



Subject: Update GSL requirement in README
Download (untitled) / with headers
text/plain 472b
The README states that "Currently Math::GSL requires at least […] GSL 1.8". However I have GSL 1.10 and I get the following message: perl Makefile.PL # running Build.PL Checking for GSL.. *** *** You need to have GSL 1.11 or greater installed. (You have 1.10). *** Get GSL at http://www.gnu.org/software/gsl Couldn't run Build.PL: at /opt/perl-5.12.2/lib/5.12.2/Module/Build/Compat.pm line 335. The README file should make it clear which GSL version will be required.
Download (untitled) / with headers
text/plain 701b
Howdy, This seems to be a bug in how Math::GSL detects version numbers. Using GSL 1.12 or higher is highly recommended, though. Duke On Wed Nov 10 07:24:39 2010, http://calimo.myopenid.com/ wrote: Show quoted text
> The README states that "Currently Math::GSL requires at least […] GSL > 1.8". However I have GSL 1.10 and I get the following message: > > perl Makefile.PL > # running Build.PL > Checking for GSL.. > *** > *** You need to have GSL 1.11 or greater installed. (You have 1.10). > *** Get GSL at http://www.gnu.org/software/gsl > Couldn't run Build.PL: at > /opt/perl-5.12.2/lib/5.12.2/Module/Build/Compat.pm line 335. > > The README file should make it clear which GSL version will be required.
Download (untitled) / with headers
text/plain 148b
Newest Math::GSL requires at least GSL 1.11, and is documented as such in the git repo. A dev release (0.25_03) will be hitting CPAN in a few. Duke


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.