Skip Menu |

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the CPAN-FindDependencies CPAN distribution.

Report information
The Basics
Id: 62544
Status: new
Priority: 0/
Queue: CPAN-FindDependencies

Owner: Nobody in particular
Requestors: oyseoyse [...]

Bug Information
Severity: (no value)
Broken in: 2.34
Fixed in: (no value)

Subject: Wrong version number used for module dependencies which differs from distribution version
Download (untitled) / with headers
text/plain 845b
When fetching the version number for a dependency it uses the version number found in the META.yml file and not the one found in 02packages.details.txt.gz. This leads the wrong version number being reported for modules where the version number is different from the one used by the distribution. For instance Net::FTP has a different version number than the libnet distribution. To fix this the version number can be read from the 02packages.details.txt.gz file instead of META.yml. The following patch fixes the issue, but the code should probably be improved before being applied. 293,297d292 < # A module can have a different version number than its containing distribution < if( $p->package($target) && defined $p->package($target)->version () ){ < $version = $p->package($target)->version(); < } <

This service is sponsored and maintained by Best Practical Solutions and runs on infrastructure.

Please report any issues with to