Skip Menu |
 

This queue is for tickets about the rpm-build-perl CPAN distribution.

Report information
The Basics
Id: 62475
Status: open
Priority: 0/
Queue: rpm-build-perl

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.72
Fixed in: (no value)



Subject: Bleadperl 22bc907 breaks testsuite
Download (untitled) / with headers
text/plain 935b
git bisect on bleadperl finds the commit that broke the test suite: commit 22bc907ae9b9703f36931e4de30ca013ddb732f6 Author: Nicholas Clark <nick@ccl4.org> Date: Mon Oct 18 10:22:44 2010 +0200 Convert File::Glob::import to use given/when. The test suite then breaks like so: t/02-perlreq.t .... 1/? # Failed test 'File/Glob.pm dependencies' # at t/02-perlreq.t line 32. # got: 'perl(feature.pm) perl(Text/ParseWords.pm) perl(warnings.pm) perl(XSLoader.pm)' # expected: 'perl(Text/ParseWords.pm) perl(XSLoader.pm)' # Looks like you failed 1 test of 10. t/02-perlreq.t .... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/10 subtests It seems that the test makes assumptions about how some other module works and breaks when this other code is changed. Right? Let me know if you need further information. Ahh, this may be interesting: git describe says v5.13.5-497-g22bc907 about this perl Cheers,
From: mmaslano [...] redhat.com
I've fixed my rpm for 5.14.1, but it will need options for different releases of perl.
Subject: tests5.14.patch
Download tests5.14.patch
text/x-diff 978b
diff -up rpm-build-perl-0.74/t/02-perlreq.t.old rpm-build-perl-0.74/t/02-perlreq.t --- rpm-build-perl-0.74/t/02-perlreq.t.old 2010-04-20 08:43:06.000000000 +0200 +++ rpm-build-perl-0.74/t/02-perlreq.t 2011-06-22 10:21:45.353919965 +0200 @@ -33,10 +33,10 @@ sub Requires ($$) { ok $? == 0, "$f zero exit status"; } -# Valid for perl-5.8.0 - perl-5.8.9. +# Valid for perl-5.14.1 Requires "AutoLoader.pm" => "perl-base >= 1:5.6.1"; Requires "Exporter.pm" => "perl(Exporter/Heavy.pm) perl-base >= 1:5.6.0"; Requires "IO/File.pm" => "perl(File/Spec.pm) perl(IO/Seekable.pm) perl(SelectSaver.pm) perl(Symbol.pm) perl-base >= 1:5.6.1"; -Requires "File/Glob.pm" => "perl(Text/ParseWords.pm) perl(XSLoader.pm)"; -Requires "Socket.pm" => "perl(warnings/register.pm) perl(XSLoader.pm)"; +Requires "File/Glob.pm" => "perl(feature.pm) perl(Text/ParseWords.pm) perl(XSLoader.pm)"; +Requires "Socket.pm" => "perl(Scalar/Util.pm) perl(warnings/register.pm) perl(XSLoader.pm)";
From: ntyni [...] iki.fi
Download (untitled) / with headers
text/plain 233b
On Wed Jun 22 04:28:59 2011, mmaslano@redhat.com wrote: Show quoted text
> I've fixed my rpm for 5.14.1, but it will need options for different > releases of perl.
Here's a patch that looks at $] and acts accordingly. -- Niko Tyni ntyni@debian.org
Subject: 0001-Adapt-to-5.13.x-dependency-changes.patch
From 298df4863d9c598d3eccd14412f043b33887da04 Mon Sep 17 00:00:00 2001 From: Niko Tyni <ntyni@debian.org> Date: Sun, 10 Jul 2011 21:05:13 +0300 Subject: [PATCH] Adapt to 5.13.x dependency changes File::Glob added "use feature 'switch'" for 5.13.6, and Socket added 'require Scalar::Util' for 5.13.9. --- t/02-perlreq.t | 8 +++++--- 1 files changed, 5 insertions(+), 3 deletions(-) diff --git a/t/02-perlreq.t b/t/02-perlreq.t index d4d1be3..98ab0c5 100644 --- a/t/02-perlreq.t +++ b/t/02-perlreq.t @@ -33,10 +33,12 @@ sub Requires ($$) { ok $? == 0, "$f zero exit status"; } -# Valid for perl-5.8.0 - perl-5.8.9. +# Valid for perl-5.8.0 - perl-5.14.1 Requires "AutoLoader.pm" => "perl-base >= 1:5.6.1"; Requires "Exporter.pm" => "perl(Exporter/Heavy.pm) perl-base >= 1:5.6.0"; Requires "IO/File.pm" => "perl(File/Spec.pm) perl(IO/Seekable.pm) perl(SelectSaver.pm) perl(Symbol.pm) perl-base >= 1:5.6.1"; -Requires "File/Glob.pm" => "perl(Text/ParseWords.pm) perl(XSLoader.pm)"; -Requires "Socket.pm" => "perl(warnings/register.pm) perl(XSLoader.pm)"; +Requires "File/Glob.pm" => ($] > 5.013005 ? "perl(feature.pm) " : "") . + "perl(Text/ParseWords.pm) perl(XSLoader.pm)"; +Requires "Socket.pm" => ($] > 5.013008 ? "perl(Scalar/Util.pm) " : "") . + "perl(warnings/register.pm) perl(XSLoader.pm)"; -- 1.7.5.4


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.