Skip Menu |
 

This queue is for tickets about the Wx CPAN distribution.

Report information
The Basics
Id: 62416
Status: open
Priority: 0/
Queue: Wx

People
Owner: Nobody in particular
Requestors: ke.b [...] wanadoo.fr
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Bug-Report Wx-0.98
Date: Sun, 24 Oct 2010 13:43:45 +0200
To: bug-Wx [...] rt.cpan.org
From: Karl Ernst Brunk <ke.b [...] wanadoo.fr>
Hi, today i tried to get rid of wxWidgets-2.8 in favor of 2.9 . So i made some tries to compile programs still asking for that version to change to 2.9. Some worked like : Alien-wxWidgets Wx-Perl-ProcessStream but Wx produces this before stopping: GDI.c: In function »void XS_Wx__DC_BeginDrawing(PerlInterpreter*, CV*)«: GDI.c:4730: Fehler: »class wxDC« hat kein Element namens »BeginDrawing« GDI.c: In function »void XS_Wx__DC_EndDrawing(PerlInterpreter*, CV*)«: GDI.c:5500: Fehler: »class wxDC« hat kein Element namens »EndDrawing« GDI.c: In function »void XS_Wx__DC_SetClippingRegionRegion(PerlInterpreter*, CV*)«: GDI.c:6673: Warnung: »void wxDC::SetClippingRegion(const wxRegion&)« ist veraltet (deklariert bei /usr/include/wx-2.9/wx/dc.h:900) make: *** [GDI.o] Fehler 1 There are some messages like this (ist veraltet (deklariert bei /usr/include/wx-2.9/wx/dc.h:900)) but the did not make it stop. Perl : Summary of my perl5 (revision 5 version 12 subversion 1) configuration: Platform: osname=linux, osvers=2.6.35-gentoo-r5, archname=x86_64-linux-thread-multi uname='linux debcli4 2.6.35-gentoo-r5 #1 smp preempt sat aug 28 17:04:39 cest 2010 x86_64 amd phenom(tm) ii x4 940 processor authenticamd gnulinux ' config_args='-des -Duseshrplib -Darchname=x86_64-linux-thread -Dcc=x86_64-pc-linux-gnu-gcc -Doptimize=-O2 -march=amdfam10 -pipe -mfpmath=sse -fprefetch-loop-arrays -Dprefix=/usr -Dsiteprefix=/usr -Dvendorprefix=/usr -Dscriptdir=/usr/bin -Dprivlib=/usr/lib64/perl5/5.12.1 -Darchlib=/usr/lib64/perl5/5.12.1/x86_64-linux-thread-multi -Dsitelib=/usr/lib64/perl5/site_perl/5.12.1 -Dsitearch=/usr/lib64/perl5/site_perl/5.12.1/x86_64-linux-thread-multi -Dvendorlib=/usr/lib64/perl5/vendor_perl/5.12.1 -Dvendorarch=/usr/lib64/perl5/vendor_perl/5.12.1/x86_64-linux-thread-multi -Dman1dir=/usr/share/man/man1 -Dman3dir=/usr/share/man/man3 -Dsiteman1dir=/usr/share/man/man1 -Dsiteman3dir=/usr/share/man/man3 -Dvendorman1dir=/usr/share/man/man1 -Dvendorman3dir=/usr/share/man/man3 -Dman1ext=1 -Dman3ext=3pm -Dlibperl=libperl.so.5.12.1 -Dlocincpth= -Duselargefiles -Dd_semctl_semun -Dcf_by=Gentoo -Dmyhostname=localhost -Dperladmin=root@localhost -Dinstallusrbinperl=n -Ud_csh -Uusenm -Ui_ndbm -Ui_gdbm -Di_db -Dusethreads -Dinc_version_list=5.12.0 5.12.0/x86_64-linux-thread-multi -Dusrinc=/usr/include -Dlibpth=/usr/local/lib64 /lib64 /usr/lib64' hint=recommended, useposix=true, d_sigaction=define useithreads=define, usemultiplicity=define useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef use64bitint=define, use64bitall=define, uselongdouble=undef usemymalloc=n, bincompat5005=undef Compiler: cc='x86_64-pc-linux-gnu-gcc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64', optimize='-O2 -march=amdfam10 -pipe -mfpmath=sse -fprefetch-loop-arrays', cppflags='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector' ccversion='', gccversion='4.4.3', gccosandvers='' intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678 d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16 ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8 alignbytes=8, prototype=define Linker and Libraries: ld='x86_64-pc-linux-gnu-gcc', ldflags =' -fstack-protector' libpth=/usr/local/lib64 /lib64 /usr/lib64 libs=-lnsl -ldb -ldl -lm -lcrypt -lutil -lpthread -lc perllibs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc libc=/lib/libc-2.11.so, so=so, useshrplib=true, libperl=libperl.so.5.12.1 gnulibc_version='2.11' Dynamic Linking: dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E' cccdlflags='-fPIC', lddlflags='-shared -O2 -march=amdfam10 -pipe -mfpmath=sse -fprefetch-loop-arrays -fstack-protector' System : Linux 2.6.35-gentoo-r11 #2 SMP PREEMPT Wed Oct 20 21:22:47 CEST 2010 x86_64 AMD Phenom(tm) II X4 940 Processor AuthenticAMD GNU/Linux hope those infos help. If more needed please ask. cheers Karl
Subject: Re: [rt.cpan.org #62416] Bug-Report Wx-0.98
Date: Tue, 26 Oct 2010 23:46:19 +0200
To: bug-Wx [...] rt.cpan.org
From: Mattia Barbon <mattia.barbon [...] libero.it>
Download (untitled) / with headers
text/plain 1.1k
ke.b via RT wrote: Hi, Show quoted text
> today i tried to get rid of wxWidgets-2.8 in favor of 2.9 . So i made some tries to compile programs still asking for that version to change to 2.9. Some worked like : > Alien-wxWidgets > Wx-Perl-ProcessStream > > but Wx produces this before stopping: > > GDI.c: In function »void XS_Wx__DC_BeginDrawing(PerlInterpreter*, CV*)«: > GDI.c:4730: Fehler: »class wxDC« hat kein Element namens »BeginDrawing« > GDI.c: In function »void XS_Wx__DC_EndDrawing(PerlInterpreter*, CV*)«: > GDI.c:5500: Fehler: »class wxDC« hat kein Element namens »EndDrawing« > GDI.c: In function »void XS_Wx__DC_SetClippingRegionRegion(PerlInterpreter*, CV*)«: > GDI.c:6673: Warnung: »void wxDC::SetClippingRegion(const wxRegion&)« ist veraltet (deklariert bei /usr/include/wx-2.9/wx/dc.h:900) > make: *** [GDI.o] Fehler 1 > > There are some messages like this (ist veraltet (deklariert bei /usr/include/wx-2.9/wx/dc.h:900)) but the did not make it stop.
Should be fixed in current Subversion (revision 2988). You can either use that revision or recompile wxWidgets without 2.6 compatibility. HTH, Mattia


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.