Skip Menu |
 

This queue is for tickets about the WWW-Google-SiteMap CPAN distribution.

Report information
The Basics
Id: 62243
Status: open
Priority: 0/
Queue: WWW-Google-SiteMap

People
Owner: Nobody in particular
Requestors: info [...] madduck.co.uk
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 1.09
Fixed in: (no value)



Subject: Make fails: Module::Install no longer supports Build.PL
Download (untitled) / with headers
text/plain 469b
I've attached the full `make test` output to this bug. I'm using 5.10.1 (*) built for i386-linux-thread-multi, a custom build into /opt/ on Centos 5.5. $ perl -MModule::Install\ 10000 Module::Install version 10000 required--this is only version 1.00. BEGIN failed--compilation aborted. Deleting Build.PL seemed to do the trick here, after that I was able to run perl Makefile.PL && make with no more errors. If you want any more info on my platform, let me know!
Subject: output.txt
Download output.txt
text/plain 2.6k
CPAN: Storable loaded ok (v2.21) Going to read '/home/edward/.local/share/.cpan/Metadata' Database was generated on Mon, 18 Oct 2010 00:32:39 GMT Running install for module 'WWW::Google::SiteMap' CPAN: YAML loaded ok (v0.72) Running make for J/JA/JASONK/WWW-Google-SiteMap-1.10.tar.gz CPAN: Digest::SHA loaded ok (v5.48) CPAN: Compress::Zlib loaded ok (v2.03) Checksum for /home/edward/.local/share/.cpan/sources/authors/id/J/JA/JASONK/WWW-Google-SiteMap-1.10.tar.gz ok CPAN: Archive::Tar loaded ok (v1.68) WWW-Google-SiteMap-1.10/ WWW-Google-SiteMap-1.10/Build.PL WWW-Google-SiteMap-1.10/Changes WWW-Google-SiteMap-1.10/inc/ WWW-Google-SiteMap-1.10/inc/Module/ WWW-Google-SiteMap-1.10/inc/Module/AutoInstall.pm WWW-Google-SiteMap-1.10/inc/Module/Install/ WWW-Google-SiteMap-1.10/inc/Module/Install/AutoInstall.pm WWW-Google-SiteMap-1.10/inc/Module/Install/Base.pm WWW-Google-SiteMap-1.10/inc/Module/Install/Can.pm WWW-Google-SiteMap-1.10/inc/Module/Install/Fetch.pm WWW-Google-SiteMap-1.10/inc/Module/Install/Include.pm WWW-Google-SiteMap-1.10/inc/Module/Install/Makefile.pm WWW-Google-SiteMap-1.10/inc/Module/Install/Metadata.pm WWW-Google-SiteMap-1.10/inc/Module/Install/Win32.pm WWW-Google-SiteMap-1.10/inc/Module/Install/WriteAll.pm WWW-Google-SiteMap-1.10/inc/Module/Install.pm WWW-Google-SiteMap-1.10/lib/ WWW-Google-SiteMap-1.10/lib/WWW/ WWW-Google-SiteMap-1.10/lib/WWW/Google/ WWW-Google-SiteMap-1.10/lib/WWW/Google/SiteMap/ WWW-Google-SiteMap-1.10/lib/WWW/Google/SiteMap/Index.pm WWW-Google-SiteMap-1.10/lib/WWW/Google/SiteMap/Ping.pm WWW-Google-SiteMap-1.10/lib/WWW/Google/SiteMap/Robot.pm WWW-Google-SiteMap-1.10/lib/WWW/Google/SiteMap/URL.pm WWW-Google-SiteMap-1.10/lib/WWW/Google/SiteMap.pm WWW-Google-SiteMap-1.10/Makefile.PL WWW-Google-SiteMap-1.10/MANIFEST WWW-Google-SiteMap-1.10/META.yml WWW-Google-SiteMap-1.10/README CPAN: File::Temp loaded ok (v0.22) CPAN: Module::Build loaded ok (v0.3607) CPAN.pm: Going to build J/JA/JASONK/WWW-Google-SiteMap-1.10.tar.gz Module::Install no longer supports Build.PL. It was impossible to maintain duel backends, and has been deprecated. Please remove all Build.PL files and only use the Makefile.PL installer. Compilation failed in require at /home/edward/perl5/lib/perl5/inc/Module/Install.pm line 42. Compilation failed in require at Makefile.PL line 1. BEGIN failed--compilation aborted at Makefile.PL line 1. Compilation failed in require at Build.PL line 1. Warning: No success on command[/usr/bin/perl Build.PL ] JASONK/WWW-Google-SiteMap-1.10.tar.gz /usr/bin/perl Build.PL -- NOT OK Running Build test Make had some problems, won't test Running Build install Make had some problems, won't install
Subject: Re: [rt.cpan.org #62243] Make fails: Module::Install no longer supports Build.PL
Date: Tue, 19 Oct 2010 11:46:11 -0400
To: bug-WWW-Google-SiteMap [...] rt.cpan.org
From: Jason Kohles <email [...] jasonkohles.com>
Download (untitled) / with headers
text/plain 3.7k
WWW::Google::SiteMap is obsolete, it has been replaced by Search::Sitemap. On Oct 18, 2010, at 5:20 PM, http://www.google.com/profiles/eprenders via RT wrote: Show quoted text
> Mon Oct 18 17:20:34 2010: Request 62243 was acted upon. > Transaction: Ticket created by http://www.google.com/profiles/eprenders > Queue: WWW-Google-SiteMap > Subject: Make fails: Module::Install no longer supports Build.PL > Broken in: 1.09 > Severity: Critical > Owner: Nobody > Requestors: info@madduck.co.uk > Status: new > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=62243 > > > > I've attached the full `make test` output to this bug. > > I'm using 5.10.1 (*) built for i386-linux-thread-multi, a custom build > into /opt/ on Centos 5.5. > > $ perl -MModule::Install\ 10000 > Module::Install version 10000 required--this is only version 1.00. > BEGIN failed--compilation aborted. > > Deleting Build.PL seemed to do the trick here, after that I was able to > run perl Makefile.PL && make with no more errors. > > If you want any more info on my platform, let me know! > CPAN: Storable loaded ok (v2.21) > Going to read '/home/edward/.local/share/.cpan/Metadata' > Database was generated on Mon, 18 Oct 2010 00:32:39 GMT > Running install for module 'WWW::Google::SiteMap' > CPAN: YAML loaded ok (v0.72) > Running make for J/JA/JASONK/WWW-Google-SiteMap-1.10.tar.gz > CPAN: Digest::SHA loaded ok (v5.48) > CPAN: Compress::Zlib loaded ok (v2.03) > Checksum for /home/edward/.local/share/.cpan/sources/authors/id/J/JA/JASONK/WWW-Google-SiteMap-1.10.tar.gz ok > CPAN: Archive::Tar loaded ok (v1.68) > WWW-Google-SiteMap-1.10/ > WWW-Google-SiteMap-1.10/Build.PL > WWW-Google-SiteMap-1.10/Changes > WWW-Google-SiteMap-1.10/inc/ > WWW-Google-SiteMap-1.10/inc/Module/ > WWW-Google-SiteMap-1.10/inc/Module/AutoInstall.pm > WWW-Google-SiteMap-1.10/inc/Module/Install/ > WWW-Google-SiteMap-1.10/inc/Module/Install/AutoInstall.pm > WWW-Google-SiteMap-1.10/inc/Module/Install/Base.pm > WWW-Google-SiteMap-1.10/inc/Module/Install/Can.pm > WWW-Google-SiteMap-1.10/inc/Module/Install/Fetch.pm > WWW-Google-SiteMap-1.10/inc/Module/Install/Include.pm > WWW-Google-SiteMap-1.10/inc/Module/Install/Makefile.pm > WWW-Google-SiteMap-1.10/inc/Module/Install/Metadata.pm > WWW-Google-SiteMap-1.10/inc/Module/Install/Win32.pm > WWW-Google-SiteMap-1.10/inc/Module/Install/WriteAll.pm > WWW-Google-SiteMap-1.10/inc/Module/Install.pm > WWW-Google-SiteMap-1.10/lib/ > WWW-Google-SiteMap-1.10/lib/WWW/ > WWW-Google-SiteMap-1.10/lib/WWW/Google/ > WWW-Google-SiteMap-1.10/lib/WWW/Google/SiteMap/ > WWW-Google-SiteMap-1.10/lib/WWW/Google/SiteMap/Index.pm > WWW-Google-SiteMap-1.10/lib/WWW/Google/SiteMap/Ping.pm > WWW-Google-SiteMap-1.10/lib/WWW/Google/SiteMap/Robot.pm > WWW-Google-SiteMap-1.10/lib/WWW/Google/SiteMap/URL.pm > WWW-Google-SiteMap-1.10/lib/WWW/Google/SiteMap.pm > WWW-Google-SiteMap-1.10/Makefile.PL > WWW-Google-SiteMap-1.10/MANIFEST > WWW-Google-SiteMap-1.10/META.yml > WWW-Google-SiteMap-1.10/README > CPAN: File::Temp loaded ok (v0.22) > CPAN: Module::Build loaded ok (v0.3607) > > CPAN.pm: Going to build J/JA/JASONK/WWW-Google-SiteMap-1.10.tar.gz > > > Module::Install no longer supports Build.PL. > > It was impossible to maintain duel backends, and has been deprecated. > > Please remove all Build.PL files and only use the Makefile.PL installer. > > Compilation failed in require at /home/edward/perl5/lib/perl5/inc/Module/Install.pm line 42. > Compilation failed in require at Makefile.PL line 1. > BEGIN failed--compilation aborted at Makefile.PL line 1. > Compilation failed in require at Build.PL line 1. > Warning: No success on command[/usr/bin/perl Build.PL ] > JASONK/WWW-Google-SiteMap-1.10.tar.gz > /usr/bin/perl Build.PL -- NOT OK > Running Build test > Make had some problems, won't test > Running Build install > Make had some problems, won't install
I also have this problem. If it's obsolete AND doesn't install, why is it on CPAN?


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.