Skip Menu |
 

This queue is for tickets about the podlators CPAN distribution.

Report information
The Basics
Id: 62209
Status: rejected
Priority: 0/
Queue: podlators

People
Owner: Nobody in particular
Requestors: sprout [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: 2.4.0 test failures on perl 5.8.9
Date: Sun, 17 Oct 2010 14:17:45 -0700
To: bug-podlators [...] rt.cpan.org, rra [...] stanford.edu
From: Father Chrysostomos <sprout [...] cpan.org>
I’ve just tried installing version 2.4.0 on perl 5.8.9. I get the following failures: Running make test PERL_DL_NONLAZY=1 /usr/bin/perl5.8.9 "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/basic............ok t/color............ok t/devise-date......ok t/filehandle.......ok t/man-heading......ok t/man-options......ok t/man-perlio.......ok t/man-utf8.........ok t/man..............NOK 29/31 # Failed test 'Output correct for test 27' # at t/man.t line 62. # got: '.SH "LINK TO URL" # .IX Header "LINK TO URL" # This is a link to a \s-1URL\s0. # ' # expected: '.SH "LINK TO URL" # .IX Header "LINK TO URL" # This is a link <http://www.example.com/> to a \s-1URL\s0. # ' t/man..............NOK 31/31 # Failed test 'Output correct for test 29' # at t/man.t line 62. # got: '.SH "TRAILING SPACE" # .IX Header "TRAILING SPACE" # Hello\ # .PP # world # .PP # \&. # .SH "POD ERRORS" # .IX Header "POD ERRORS" # Hey! \fBThe above document had some coding errors, which are explained below:\fR # .IP "Around line 5:" 4 # .IX Item "Around line 5:" # Unterminated S<...> sequence # ' # expected: '.SH "TRAILING SPACE" # .IX Header "TRAILING SPACE" # Hello\ # .PP # world\ \ \ # .PP # \&. # ' # Looks like you failed 2 tests of 31. t/man..............dubious Test returned status 2 (wstat 512, 0x200) DIED. FAILED tests 29, 31 Failed 2/31 tests, 93.55% okay t/overstrike.......ok t/parselink........ok t/pod-parser.......ok t/pod-spelling.....skipped all skipped: Spelling tests only run for maintainer t/pod..............ok t/termcap..........ok t/text-encoding....ok t/text-options.....ok t/text-perlio......ok t/text-utf8........ok t/text.............ok 1/8 # Failed test 'Output correct for test 3' # at t/text.t line 52. # got: 'Test of S<> # This is some # # POD ERRORS # Hey! The above document had some coding errors, which are explained # below: # # Around line 3: # Unterminated S<...> sequence # # ' # expected: 'Test of S<> # This is some whitespace. # # ' t/text.............NOK 5/8 # Failed test 'Output correct for test 6' # at t/text.t line 52. # got: 'LINK TO URL # This is a link to a URL. # # ' # expected: 'LINK TO URL # This is a link <http://www.example.com/> to a URL. # # ' # Looks like you failed 2 tests of 8. t/text.............dubious Test returned status 2 (wstat 512, 0x200) DIED. FAILED tests 5, 8 Failed 2/8 tests, 75.00% okay Failed Test Stat Wstat Total Fail List of Failed ------------------------------------------------------------------------------- t/man.t 2 512 31 2 29 31 t/text.t 2 512 8 2 5 8 1 test skipped. Failed 2/20 test scripts. 4/182 subtests failed. Files=20, Tests=182, 6 wallclock secs ( 4.70 cusr + 0.59 csys = 5.29 CPU) Failed 2/20 test programs. 4/182 subtests failed.
Subject: Re: [rt.cpan.org #62209] 2.4.0 test failures on perl 5.8.9
Date: Sat, 26 May 2012 14:18:31 -0700
To: bug-podlators [...] rt.cpan.org
From: Russ Allbery <rra [...] stanford.edu>
Download (untitled) / with headers
text/plain 2.8k
"Father Chrysostomos via RT" <bug-podlators@rt.cpan.org> writes: Show quoted text
> I’ve just tried installing version 2.4.0 on perl 5.8.9. I get the > following failures:
Show quoted text
> Running make test > PERL_DL_NONLAZY=1 /usr/bin/perl5.8.9 "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t > t/basic............ok > t/color............ok > t/devise-date......ok > t/filehandle.......ok > t/man-heading......ok > t/man-options......ok > t/man-perlio.......ok > t/man-utf8.........ok > t/man..............NOK 29/31 > # Failed test 'Output correct for test 27' > # at t/man.t line 62. > # got: '.SH "LINK TO URL" > # .IX Header "LINK TO URL" > # This is a link to a \s-1URL\s0. > # ' > # expected: '.SH "LINK TO URL" > # .IX Header "LINK TO URL" > # This is a link <http://www.example.com/> to a \s-1URL\s0. > # ' > t/man..............NOK 31/31 > # Failed test 'Output correct for test 29' > # at t/man.t line 62. > # got: '.SH "TRAILING SPACE" > # .IX Header "TRAILING SPACE" > # Hello\ > # .PP > # world > # .PP > # \&. > # .SH "POD ERRORS" > # .IX Header "POD ERRORS" > # Hey! \fBThe above document had some coding errors, which are explained below:\fR > # .IP "Around line 5:" 4 > # .IX Item "Around line 5:" > # Unterminated S<...> sequence > # ' > # expected: '.SH "TRAILING SPACE" > # .IX Header "TRAILING SPACE" > # Hello\ > # .PP > # world\ \ \ > # .PP > # \&. > # ' > # Looks like you failed 2 tests of 31. > t/man..............dubious > Test returned status 2 (wstat 512, 0x200) > DIED. FAILED tests 29, 31 > Failed 2/31 tests, 93.55% okay
(Sorry about the long delay in responding to this.) I suspect you need a new Pod::Simple. It looks like Pod::Simple 3.06 has the fix for the S<> issue. Pod::Simple was first included in Perl with 5.9.3; could you have a fairly old version installed? I do already have a dependency in the Makefile.PL on at least Pod::Simple 3.06 precisely because of that S<> bug. Could you have bypassed that while installing the module? These tests work fine for me with Pod::Simple 3.20, but I don't see other bugs in the ChangeLog that seem directly relevant between 3.20 or 3.06 (or I would tighten the dependency). -- Russ Allbery (rra@stanford.edu) <http://www.eyrie.org/~eagle/>
Subject: Re: [rt.cpan.org #62209] 2.4.0 test failures on perl 5.8.9
Date: Sun, 3 Jun 2012 14:06:51 -0700
To: bug-podlators [...] rt.cpan.org
From: Father Chrysostomos <sprout [...] cpan.org>
On May 26, 2012, at 2:18 PM, rra@stanford.edu via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=62209 > > > "Father Chrysostomos via RT" <bug-podlators@rt.cpan.org> writes: >
>> I’ve just tried installing version 2.4.0 on perl 5.8.9. I get the >> following failures:
>
>> Running make test >> PERL_DL_NONLAZY=1 /usr/bin/perl5.8.9 "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t >> t/basic............ok >> t/color............ok >> t/devise-date......ok >> t/filehandle.......ok >> t/man-heading......ok >> t/man-options......ok >> t/man-perlio.......ok >> t/man-utf8.........ok >> t/man..............NOK 29/31 >> # Failed test 'Output correct for test 27' >> # at t/man.t line 62. >> # got: '.SH "LINK TO URL" >> # .IX Header "LINK TO URL" >> # This is a link to a \s-1URL\s0. >> # ' >> # expected: '.SH "LINK TO URL" >> # .IX Header "LINK TO URL" >> # This is a link <http://www.example.com/> to a \s-1URL\s0. >> # ' >> t/man..............NOK 31/31 >> # Failed test 'Output correct for test 29' >> # at t/man.t line 62. >> # got: '.SH "TRAILING SPACE" >> # .IX Header "TRAILING SPACE" >> # Hello\ >> # .PP >> # world >> # .PP >> # \&. >> # .SH "POD ERRORS" >> # .IX Header "POD ERRORS" >> # Hey! \fBThe above document had some coding errors, which are explained below:\fR >> # .IP "Around line 5:" 4 >> # .IX Item "Around line 5:" >> # Unterminated S<...> sequence >> # ' >> # expected: '.SH "TRAILING SPACE" >> # .IX Header "TRAILING SPACE" >> # Hello\ >> # .PP >> # world\ \ \ >> # .PP >> # \&. >> # ' >> # Looks like you failed 2 tests of 31. >> t/man..............dubious >> Test returned status 2 (wstat 512, 0x200) >> DIED. FAILED tests 29, 31 >> Failed 2/31 tests, 93.55% okay
> > (Sorry about the long delay in responding to this.) > > I suspect you need a new Pod::Simple. It looks like Pod::Simple 3.06 has > the fix for the S<> issue. Pod::Simple was first included in Perl with > 5.9.3; could you have a fairly old version installed? > > I do already have a dependency in the Makefile.PL on at least Pod::Simple > 3.06 precisely because of that S<> bug. Could you have bypassed that > while installing the module? > > These tests work fine for me with Pod::Simple 3.20, but I don't see other > bugs in the ChangeLog that seem directly relevant between 3.20 or 3.06 (or > I would tighten the dependency).
I can’t reproduce this any more, but I don’t know what upgrade in the mean time caused the change.
Download (untitled) / with headers
text/plain 215b
It's not clear what fixed this, sadly, but I don't think there's more action I can take without more details. Hopefully someone else will report the issue if there's a missing tighter dependency that I need to add.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.