Skip Menu |
 

This queue is for tickets about the Devel-Declare CPAN distribution.

Report information
The Basics
Id: 62042
Status: resolved
Priority: 0/
Queue: Devel-Declare

People
Owner: Nobody in particular
Requestors: sprout [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Installation problems caused by configure_requires
Date: Sun, 10 Oct 2010 22:08:44 -0700
To: Florian Ragwitz <rafl [...] debian.org>, bug-B-Hooks-Parser [...] rt.cpan.org, bug-Devel-Declare [...] rt.cpan.org
From: Father Chrysostomos <sprout [...] cpan.org>
Download (untitled) / with headers
text/plain 365b
Both B::Hooks::Parser and Devel::Declare have installation problems on a brand new perl 5.10.1 installation (or any earlier version), because the CPAN.pm included does not properly support configure_requires. It requires YAML to be installed first. I wrote Module::ConfigureRequires to work around this problem. Could you consider using it for those two modules?
CC: sprout [...] cpan.org
Subject: Re: [rt.cpan.org #62042] Installation problems caused by configure_requires
Date: Mon, 11 Oct 2010 07:28:53 +0200
To: bug-Devel-Declare [...] rt.cpan.org
From: Florian Ragwitz <rafl [...] debian.org>
Download (untitled) / with headers
text/plain 1.2k
"Father Chrysostomos via RT" <bug-Devel-Declare@rt.cpan.org> writes: Show quoted text
> Both B::Hooks::Parser and Devel::Declare have installation problems on > a brand new perl 5.10.1 installation (or any earlier version), because > the CPAN.pm included does not properly support configure_requires. It > requires YAML to be installed first. > > I wrote Module::ConfigureRequires to work around this problem. Could > you consider using it for those two modules?
I'm not particularly keen on having to load all configure requires conditionally, and handle their absence specially, especially if a working tool-chain is just a 'cpan -i CPAN' away. However I'm willing to accept patches if you think it'll actually help anyone. Also note that configure_requires is used in at least one of Devel-Declare's dependencies, B-Hooks-OP-Check, as well, so changes to that distribution will be needed as well for this to actually work. I also have a couple of dozen other distributions using configure_requires. Some of them, I believe, are using their configure_requires to determine what their actual dependencies are. Module::ConfigureRequires can't handle that, can it? (not to mention the tedious work that'd be involved in making them all use it, and convincing the authors of the of their dependants to use it as well)
Download (untitled)
application/pgp-signature 197b

Message body not shown because it is not plain text.

CC: bug-Devel-Declare [...] rt.cpan.org
Subject: Re: [rt.cpan.org #62042] Installation problems caused by configure_requires
Date: Sun, 17 Oct 2010 12:59:39 -0700
To: Florian Ragwitz <rafl [...] debian.org>
From: Father Chrysostomos <sprout [...] cpan.org>
Download (untitled) / with headers
text/plain 1.9k
On Oct 10, 2010, at 10:28 PM, Florian Ragwitz wrote: Show quoted text
> "Father Chrysostomos via RT" <bug-Devel-Declare@rt.cpan.org> writes: >
>> Both B::Hooks::Parser and Devel::Declare have installation problems on >> a brand new perl 5.10.1 installation (or any earlier version), because >> the CPAN.pm included does not properly support configure_requires. It >> requires YAML to be installed first. >> >> I wrote Module::ConfigureRequires to work around this problem. Could >> you consider using it for those two modules?
> > I'm not particularly keen on having to load all configure requires > conditionally, and handle their absence specially, especially if a > working tool-chain is just a 'cpan -i CPAN' away.
It’s actually more like ‘cpan -i ANDK/CPAN-1.94_56.tar.gz’. Show quoted text
> However I'm willing to > accept patches if you think it'll actually help anyone.
I do. I’ll try to prepare a few, if I have time. Show quoted text
> Also note that configure_requires is used in at least one of > Devel-Declare's dependencies, B-Hooks-OP-Check, as well, so changes to > that distribution will be needed as well for this to actually work.
I was actually thinking of using B::Hooks::OP::Check for Classic::Perl, but I decided against it, as I want it to be easy for people to put ‘use Classic::Perl;’ at the top of their scripts *before* upgrading perl, to make the transition easier (Classic::Perl’s raison d’être). Show quoted text
> I also have a couple of dozen other distributions using > configure_requires. Some of them, I believe, are using their > configure_requires to determine what their actual dependencies > are. Module::ConfigureRequires can't handle that, can it?
No. That’s a hard one to solve. In cases like that, I simply bundle up the dependencies. Show quoted text
> (not to > mention the tedious work that'd be involved in making them all use it, > and convincing the authors of the of their dependants to use it as well)
I should have noticed this sooner before the trend started. :-( I was hoping eventually to get all these modules switched over.
CC: bug-Devel-Declare [...] rt.cpan.org
Subject: Re: [rt.cpan.org #62042] Installation problems caused by configure_requires
Date: Sun, 17 Oct 2010 17:21:56 -0700
To: Florian Ragwitz <rafl [...] debian.org>
From: Father Chrysostomos <sprout [...] cpan.org>
Download (untitled) / with headers
text/plain 813b
On Oct 10, 2010, at 10:28 PM, Florian Ragwitz wrote: Show quoted text
> "Father Chrysostomos via RT" <bug-Devel-Declare@rt.cpan.org> writes: >
>> Both B::Hooks::Parser and Devel::Declare have installation problems on >> a brand new perl 5.10.1 installation (or any earlier version), because >> the CPAN.pm included does not properly support configure_requires. It >> requires YAML to be installed first. >> >> I wrote Module::ConfigureRequires to work around this problem. Could >> you consider using it for those two modules?
> > I'm not particularly keen on having to load all configure requires > conditionally, and handle their absence specially, especially if a > working tool-chain is just a 'cpan -i CPAN' away. However I'm willing to > accept patches if you think it'll actually help anyone.
Here are some patches.

Message body is not shown because sender requested not to inline it.

Message body is not shown because sender requested not to inline it.

Message body is not shown because sender requested not to inline it.

Download (untitled) / with headers
text/plain 102b
The toolchain has got better at configure_requires. I don't think there's any need to work around it.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.