Skip Menu |
 

This queue is for tickets about the MailTools CPAN distribution.

Report information
The Basics
Id: 61753
Status: resolved
Priority: 0/
Queue: MailTools

People
Owner: Nobody in particular
Requestors: alexandre.bouillot [...] atelier.tm
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Invalid minimal Perl version
Date: Wed, 29 Sep 2010 15:43:07 +0200
To: <bug-MailTools [...] rt.cpan.org>
From: "Alexandre Bouillot" <alexandre.bouillot [...] atelier.tm>
Download (untitled) / with headers
text/plain 233b
According to the readme, MailTool require Perl 5.005 while in Makefile.PL it is stated 5.008.001 I'm wondering if perl 5.08 is enough or 5.8.1 is mandatory. Shouldn't the two locations synchronized? Thanks Alexandre
Subject: Re: [rt.cpan.org #61753] Invalid minimal Perl version
Date: Wed, 29 Sep 2010 16:24:12 +0200
To: Alexandre Bouillot via RT <bug-MailTools [...] rt.cpan.org>
From: Mark Overmeer <solutions [...] overmeer.net>
Download (untitled) / with headers
text/plain 1.1k
* Alexandre Bouillot via RT (bug-MailTools@rt.cpan.org) [100929 13:43]: Show quoted text
> Wed Sep 29 09:43:20 2010: Request 61753 was acted upon. > Transaction: Ticket created by alexandre.bouillot@atelier.tm > Queue: MailTools > Subject: Invalid minimal Perl version > Requestors: alexandre.bouillot@atelier.tm > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=61753 > > > According to the readme, MailTool require Perl 5.005 while in Makefile.PL it > is stated 5.008.001 > > I'm wondering if perl 5.08 is enough or 5.8.1 is mandatory. > Shouldn't the two locations synchronized?
Anything before 5.8.5 should not be used anymore. The 5.8.[0-4] have many unicode problems. 5.8.5 is six years old. You probably can run older perls with the code, but some tests may fail and you may encounter problems with real-ife mail... maybe not. I will not support those versions for 2.* releases. -- Regards, MarkOv ------------------------------------------------------------------------ Mark Overmeer MSc MARKOV Solutions Mark@Overmeer.net solutions@overmeer.net http://Mark.Overmeer.net http://solutions.overmeer.net
no response for requestor anymore


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.