Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 6155
Status: resolved
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors: barbie [...] missbarbell
Cc:
AdminCc:

Bug Information
Severity: Wishlist
Broken in: (no value)
Fixed in: (no value)



Subject: Configuration Independant installations
Download (untitled) / with headers
text/plain 3.4k
Below is the report from a recent cpan-smoke run Testing: /K/KW/KWILLIAMS/Module-Build-0.25.tar.gz Checking whether your kit is complete... Looks good Creating new 'Build' script for 'Module-Build' version '0.25' * ERROR: Configuration was initially created with Module::Build version '0.25', but we are now using version '0.23'. Please re-run the Build.PL or Makefile.PL script. Is there any way to stop this from happening as I don't want to have keep updating Module::Build, everytime another module is built with a more recent version. Especially if there is no reason for me to do so. As an example another cpan-smoke run: Testing: /A/AS/ASAVIGE/Acme-EyeDrops-1.44.tar.gz ###### ##### ######### ########## ########### ########## ############# ####### ################ ######## ################### ####### ##################### ############################# ############################# ############################## ############################# ######################### ## ## ############### #### ## #### ######## ### # ### #### ### ### ### ##### ## ## ### #### ## ## ## # ## ## ## # # # ## # # # # ### # # ## ## # ## #### # ## #### #### Creating custom builder _build\lib\My\Builder.pm in _build\lib\My Checking whether your kit is complete... Looks good Creating new 'Build' script for 'Acme-EyeDrops' version '1.44' * ERROR: Version 0.23 of Module::Build is installed, but we need version >= 0.24 ERRORS/WARNINGS FOUND IN PREREQUISITES. You may wish to install the versions of the modules indicated above before proceeding with this installation. No such module: Module::Build, cannot satisfy dependency in CPANPLUS::Internals::Make::_make at Tue Apr 27 10:11:50 2004 at C:\Perl\site\lib/CPANPLUS/Internals/Make.pm line 346 t\00_Coffee.........ok t\01_mug............ok t\02_shatters.......ok t\03_Larry..........ok t\04_Apocalyptic....ok t\05_Parrot.........ok t\06_not............ok t\07_a..............ok t\08_hoax...........ok t\09_Gallop.........ok t\10_Ponie..........ok t\11_bold...........ok t\12_Beer...........skipped all skipped: Linux /usr/games/banner not available t\13_to.............ok t\14_gulp...........ok t\15_Buffy..........ok t\16_astride........ok t\17_Orange.........ok t\18_sky............ok t\19_surrounds......skipped all skipped: Skipping long running generator tests unless $ENV{PERL_SMOKE} is true t\gen...............ok t\zgen..............ok All tests successful, 2 tests skipped. Files=22, Tests=854, 14 wallclock secs ( 0.00 cusr + 0.00 csys = 0.00 CPU) 1 shapes completed. Successfully sent report for Acme-EyeDrops-1.44. As CPANPLUS is have problems installing prerequisites at the moment, you can see that even with the installed version of Module::Build (0.23) the module gets to the test sequence without a hitch. If users are going to have to keep installing the latest version of Module::Build by hand, everytime they want a module that the author has created with a more recent version, I can see Module::Build quickly falling out of favour. If there is already a setting to do this, perhaps it should be the default rather than forcing the latest and greatest. Distribution: Module-Build all versions Perl: v5.6.1 built for MSWin32-x86-multi-thread build 635 OS: MINGW32_NT-5.0
Download (untitled) / with headers
text/plain 953b
Hi Barbie, Those look like two separate issues. The first issue is that it looks like something weird happened when trying to install Module::Build 0.25, it somehow loaded two different versions of Module::Build (the one it was testing, and the one you already had installed) at different times. This is a real error, so the error message is correct. I'm not sure what caused it. Maybe something funky CPANPLUS is doing. What does the 'Build' script that it generates look like? The second issue is different, and benign: the author of Acme::EyeDrops has decided that Module::Build version 0.24 is necessary to install his module, presumably either because he uses some new feature not available in 0.23, or he uses some feature that was broken in 0.23. The only solutions for you in this case are to either upgrade Module::Build, not install Acme::EyeDrops, or take your chances with something bad happening if you force it. -Ken


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.