Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 61464
Status: resolved
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: CHORNY [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 1.00
Fixed in: 1.01



Subject: compatibility with EUMM 6.57_02
Download (untitled) / with headers
text/plain 557b
ExtUtils::MakeMaker from version 6.57_02 supports MYMETA.yml generation. Module::Install fails tests with this version. If M::I generates it own MYMETA.yml, NO_MYMETA => 1 key should be used, although I consider that EUMM's own algorithm is enough (it reuses META.yml if possible, generates correct build_requires). Also AUTHOR key can now accept both arrayref and scalar. Scalar is converted to arrayref internally, so generated Makefile contains arrayref. Empty string is converted into reference to empty array. -- Alexandr Ciornii, http://chorny.net
Download (untitled) / with headers
text/plain 684b
On Sun Sep 19 14:40:51 2010, CHORNY wrote: Show quoted text
> ExtUtils::MakeMaker from version 6.57_02 supports MYMETA.yml generation. > Module::Install fails tests with this version. If M::I generates it own > MYMETA.yml, NO_MYMETA => 1 key should be used, although I consider that > EUMM's own algorithm is enough (it reuses META.yml if possible, > generates correct build_requires). > > Also AUTHOR key can now accept both arrayref and scalar. Scalar is > converted to arrayref internally, so generated Makefile contains > arrayref. Empty string is converted into reference to empty array.
How does this affect existing distributions which bundle Module::Install? Are they still going to work?
Download (untitled) / with headers
text/plain 915b
On Fri Feb 11 02:59:57 2011, MSCHWERN wrote: Show quoted text
> On Sun Sep 19 14:40:51 2010, CHORNY wrote:
> > ExtUtils::MakeMaker from version 6.57_02 supports MYMETA.yml generation. > > Module::Install fails tests with this version. If M::I generates it own > > MYMETA.yml, NO_MYMETA => 1 key should be used, although I consider that > > EUMM's own algorithm is enough (it reuses META.yml if possible, > > generates correct build_requires). > > > > Also AUTHOR key can now accept both arrayref and scalar. Scalar is > > converted to arrayref internally, so generated Makefile contains > > arrayref. Empty string is converted into reference to empty array.
> > How does this affect existing distributions which bundle > Module::Install?
Only tests are affected as they read/parse Makefile for author field and check that MYMETA.yml does not exist. Show quoted text
> Are they still going to work?
yes -- Alexandr Ciornii, http://chorny.net
Subject: Re: [rt.cpan.org #61464] compatibility with EUMM 6.57_02
Date: Sat, 12 Feb 2011 18:15:34 +1100
To: bug-Module-Install [...] rt.cpan.org
From: Adam Kennedy <adamkennedybackup [...] gmail.com>
Module::Install's MYMETA.yml (very old now) proof-of-concept implementation is hidden away under an X_ environment variable, disabled by default. The existing userbase are totally fine. Adam K On 11 February 2011 18:59, Michael G Schwern via RT <bug-Module-Install@rt.cpan.org> wrote: Show quoted text
>       Queue: Module-Install >  Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=61464 > > > On Sun Sep 19 14:40:51 2010, CHORNY wrote:
>> ExtUtils::MakeMaker from version 6.57_02 supports MYMETA.yml generation. >> Module::Install fails tests with this version. If M::I generates it own >> MYMETA.yml, NO_MYMETA => 1 key should be used, although I consider that >> EUMM's own algorithm is enough (it reuses META.yml if possible, >> generates correct build_requires). >> >> Also AUTHOR key can now accept both arrayref and scalar. Scalar is >> converted to arrayref internally, so generated Makefile contains >> arrayref. Empty string is converted into reference to empty array.
> > How does this affect existing distributions which bundle > Module::Install?  Are they still going to work? > > >
Download (untitled) / with headers
text/plain 4.9k
On Sat Feb 12 02:15:43 2011, adam@ali.as wrote: Show quoted text
> Module::Install's MYMETA.yml (very old now) proof-of-concept > implementation is hidden away under an X_ environment variable, > disabled by default. > > The existing userbase are totally fine. > > Adam K > > On 11 February 2011 18:59, Michael G Schwern via RT > <bug-Module-Install@rt.cpan.org> wrote:
> >       Queue: Module-Install > >  Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=61464 > > > > > On Sun Sep 19 14:40:51 2010, CHORNY wrote:
> >> ExtUtils::MakeMaker from version 6.57_02 supports MYMETA.yml
generation. Show quoted text
> >> Module::Install fails tests with this version. If M::I generates it own > >> MYMETA.yml, NO_MYMETA => 1 key should be used, although I consider that > >> EUMM's own algorithm is enough (it reuses META.yml if possible, > >> generates correct build_requires). > >> > >> Also AUTHOR key can now accept both arrayref and scalar. Scalar is > >> converted to arrayref internally, so generated Makefile contains > >> arrayref. Empty string is converted into reference to empty array.
> > > > How does this affect existing distributions which bundle > > Module::Install?  Are they still going to work? > > > > > >
Problem still persists (5.13.10), see test report below. Also see RT#63849: t/01_compile.t .......................... ok # Failed test at t/02_mymeta.t line 19. # Failed test at t/02_mymeta.t line 43. # Looks like you failed 2 tests of 24. t/02_mymeta.t ........................... Dubious, test returned 2 (wstat 512, 0x200) Failed 2/24 subtests t/03_autoinstall.t ...................... skipped: Skipping dangerous test t/04_version.t .......................... ok t/05_share.t ............................ ok t/06_ppport.t ........................... ok t/07_perl_version.t ..................... ok t/08_dsl.t .............................. ok t/09_read.t ............................. ok t/10_test.t ............................. ok t/11_extraction.t ....................... ok t/12_eumm_params.t ...................... ok t/13_author_tests.t ..................... ok t/13_author_tests_ext.t ................. skipped: requires Module::Install::AuthorTests t/13_author_tests_ext2.t ................ skipped: requires Module::Install::ExtraTests 0.007 t/14_auto_include_deps_with_version.t ... skipped: your perl is new enough to have File::Spec 3.30 in core t/15_wrong_usage.t ...................... ok t/16_require.t .......................... ok t/17_sign.t ............................. ok # Failed test 'has author' # at t/18_all_from.t line 33. # Failed test 'has author' # at t/18_all_from.t line 61. # Looks like you failed 2 tests of 18. t/18_all_from.t ......................... Dubious, test returned 2 (wstat 512, 0x200) Failed 2/18 subtests (less 1 skipped subtest: 15 okay) # Failed test 'has one author' # at t/19_authors.t line 31. # Failed test 'has two authors' # at t/19_authors.t line 54. # Failed test 'has two authors' # at t/19_authors.t line 77. # Failed test 'has two authors' # at t/19_authors.t line 101. # Looks like you failed 4 tests of 32. t/19_authors.t .......................... Dubious, test returned 4 (wstat 1024, 0x400) Failed 4/32 subtests # Failed test 'has one author' # at t/20_authors_with_special_characters.t line 48. # Failed test 'has one author' # at t/20_authors_with_special_characters.t line 90. # Failed test 'has one author' # at t/20_authors_with_special_characters.t line 115. # Looks like you failed 3 tests of 26. t/20_authors_with_special_characters.t .. Dubious, test returned 3 (wstat 768, 0x300) Failed 3/26 subtests t/21_makemaker_args.t ................... ok old INSTALLDIRS (probably set by makemaker_args) is overriden by installdirs t/22_installdirs.t ...................... ok t/23_pl_files.t ......................... ok t/24_multiple_license_blocks.t .......... ok t/25_perl_version_from.t ................ ok t/26_unknown_func.t ..................... ok Warning: prerequisite Test::More 9999 not found. We have 0.9701. t/27_build_requires_and_include.t ....... ok t/28_makemaker_args.t ................... ok t/29_requires_from.t .................... ok t/30_build_subdirs.t .................... ok t/31_add_metadata.t ..................... ok t/recursive/test.t ...................... ok Test Summary Report ------------------- t/02_mymeta.t (Wstat: 512 Tests: 24 Failed: 2) Failed tests: 5, 21 Non-zero exit status: 2 t/18_all_from.t (Wstat: 512 Tests: 18 Failed: 2) Failed tests: 6, 15 Non-zero exit status: 2 t/19_authors.t (Wstat: 1024 Tests: 32 Failed: 4) Failed tests: 5, 13, 21, 29 Non-zero exit status: 4 t/20_authors_with_special_characters.t (Wstat: 768 Tests: 26 Failed: 3) Failed tests: 6, 15, 23 Non-zero exit status: 3 Files=34, Tests=565, 50 wallclock secs ( 0.29 usr 0.06 sys + 34.97 cusr 6.57 csys = 41.89 CPU) Result: FAIL Failed 4/34 test programs. 11/565 subtests failed.
*poke poke* MakeMaker and 5.14 are in release candidates, MI needs a release.
Subject: Re: [rt.cpan.org #61464] compatibility with EUMM 6.57_02
Date: Fri, 1 Apr 2011 15:12:22 +1100
To: bug-Module-Install [...] rt.cpan.org
From: Adam Kennedy <adamkennedybackup [...] gmail.com>
Download (untitled) / with headers
text/plain 346b
Can it wait until the QA hackathon? I'm overloaded a bit right now... On 1 April 2011 11:07, Michael G Schwern via RT <bug-Module-Install@rt.cpan.org> wrote: Show quoted text
>       Queue: Module-Install >  Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=61464 > > > *poke poke* MakeMaker and 5.14 are in release candidates, MI needs a > release. >
Download (untitled) / with headers
text/plain 135b
Now that Perl 5.14.0-RC1 is out, this problem is more urgent. Can you please release a new Module::Install that builds under this Perl?
Download (untitled) / with headers
text/plain 270b
On Wed Apr 20 12:13:16 2011, SARTAK wrote: Show quoted text
> Now that Perl 5.14.0-RC1 is out, this problem is more urgent. Can you > please release a new Module::Install that builds under this Perl?
+1 Confirmed it's fixed in trunk - fixed by r13110. It just needs a release on CPAN.
Download (untitled) / with headers
text/plain 112b
I just tested the latest MI release from CPAN with the latest EUMM dev release and installs fine. Thanks a lot!


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.