Skip Menu |
 

This queue is for tickets about the Text-Aligner CPAN distribution.

Report information
The Basics
Id: 61276
Status: resolved
Priority: 0/
Queue: Text-Aligner

People
Owner: Nobody in particular
Requestors: d.thomas [...] its.uq.edu.au
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.06
Fixed in: (no value)



Subject: 10_Aligner.t test 101 requires colorstrip ?
Download (untitled) / with headers
text/plain 3.2k
Text-Aligner-0.06 on RedHat EL5 Summary of my perl5 (revision 5 version 10 subversion 1) configuration: Platform: osname=linux, osvers=2.6.18-194.8.1.el5, archname=x86_64-linux uname='linux kolanut.cc.uq.edu.au 2.6.18-194.8.1.el5 #1 smp wed jun 23 10:52:51 edt 2010 x86_64 x86_64 x86_64 gnulinux ' config_args='-des -Dprefix=/opt/perl/distro-5.10.1-20100912 -Dusethreads=n - Uuseshrplib -Dinc_version_list=none -Dotherlibdirs=/opt/perl/site_perl:/opt/perl/other_perl -Dcc=gcc -Doptimize=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions - fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic - Dlibpth=/usr/local/lib64 /lib64 /usr/lib64' hint=recommended, useposix=true, d_sigaction=define useithreads=undef, usemultiplicity=undef useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef use64bitint=define, use64bitall=define, uselongdouble=undef usemymalloc=n, bincompat5005=undef Compiler: cc='gcc', ccflags ='-DDEBUGGING -fno-strict-aliasing -pipe -fstack-protector - I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64', optimize='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack- protector --param=ssp-buffer-size=4 -m64 -mtune=generic', cppflags='-DDEBUGGING -fno-strict-aliasing -pipe -fstack-protector - I/usr/local/include' ccversion='', gccversion='4.1.2 20080704 (Red Hat 4.1.2-48)', gccosandvers='' intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678 d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16 ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8 alignbytes=8, prototype=define Linker and Libraries: ld='gcc', ldflags =' -fstack-protector' libpth=/usr/local/lib64 /lib64 /usr/lib64 libs=-lnsl -ldb -ldl -lm -lcrypt -lutil -lc perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc libc=/lib/libc-2.5.so, so=so, useshrplib=false, libperl=libperl.a gnulibc_version='2.5' Dynamic Linking: dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E' cccdlflags='-fPIC', lddlflags='-shared -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 - fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic' Characteristics of this binary (from libperl): Compile-time options: DEBUGGING PERL_DONT_CREATE_GVSV PERL_MALLOC_WRAP USE_64_BIT_ALL USE_64_BIT_INT USE_LARGE_FILES USE_PERLIO Built under linux Compiled at Sep 11 2010 13:07:33 @INC: /opt/perl/distro-5.10.1-20100912/lib/5.10.1/x86_64-linux /opt/perl/distro-5.10.1-20100912/lib/5.10.1 /opt/perl/distro-5.10.1-20100912/lib/site_perl/5.10.1/x86_64-linux /opt/perl/distro-5.10.1-20100912/lib/site_perl/5.10.1 /opt/perl/site_perl /opt/perl/other_perl . I used CPANPLUS to build a local perl and this cycle upgraded from 0.03 to 0.06 which resulted in # Looks like you failed 1 test of 511. t/10_Aligner.t .. Dubious, test returned 1 (wstat 256, 0x100) soon narrowed down to test 101. make test PASSed after adding '!' ok(!Text::Aligner::_is_number(colored('123', 'red'))); given that last few test report ok 506 # skip Term::ANSIColor 2.00 doesn't support colorstrip I think 101 also needs to be made aware of that
From: anno5 [...] mac.com
Download (untitled) / with headers
text/plain 668b
On Sat Sep 11 18:49:28 2010, d.thomas@its.uq.edu.au wrote: Show quoted text
> Text-Aligner-0.06 > on RedHat EL5
[snip] Show quoted text
> I used CPANPLUS to build a local perl and this cycle > upgraded from 0.03 to 0.06 which resulted in > > # Looks like you failed 1 test of 511. > t/10_Aligner.t .. Dubious, test returned 1 (wstat 256, 0x100) > > soon narrowed down to test 101. > make test PASSed after adding '!' > ok(!Text::Aligner::_is_number(colored('123', 'red'))); > > given that last few test report > ok 506 # skip Term::ANSIColor 2.00 doesn't support colorstrip > I think 101 also needs to be made aware of that
Thanks for the report, fixed in Text::Aligner v0.07. Regards, Anno
Subject: Re: [rt.cpan.org #61276] 10_Aligner.t test 101 requires colorstrip ?
Date: Sun, 12 Sep 2010 11:00:57 +1000
To: "bug-Text-Aligner [...] rt.cpan.org" <bug-Text-Aligner [...] rt.cpan.org>
From: Danny Thomas <d.thomas [...] its.uq.edu.au>
Download (untitled) / with headers
text/plain 737b
On 12/09/2010, at 9:42 AM, Anno Siegel via RT wrote: Thanks for the report, fixed in Text::Aligner v0.07. I was hoping it would be fixed, but not this quickly! CPANPLUS probably does the best it can, but sometimes won't proceed to install the module because of some minor test failure,. So I have to produce a patch to disable a test or work-around the problem, which I currently do for perldap-1.4.tar.gz.diff SOAP-WSDL-2.00.10.tar.gz.diff XML-Twig-3.35.tar.gz.diff Since 0.07 is not currently on CPAN, so can you please either send me the diff or point me to a site I can fetch it ? Of course, until it appears in 02packages.details.txt,gz, I'll have to apply a patch to the Text::Align entry in that file. thanks, Danny
Subject: Re: [rt.cpan.org #61276] 10_Aligner.t test 101 requires colorstrip ?
Date: Sun, 12 Sep 2010 03:41:09 +0200
To: bug-Text-Aligner [...] rt.cpan.org
From: Anno Siegel <anno5 [...] mac.com>
Download (untitled) / with headers
text/plain 945b
On 12.09.2010, at 03:01, d.thomas@its.uq.edu.au via RT wrote: Show quoted text
> Queue: Text-Aligner > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=61276 > > > > On 12/09/2010, at 9:42 AM, Anno Siegel via RT wrote: > > Thanks for the report, fixed in Text::Aligner v0.07. > > I was hoping it would be fixed, but not this quickly! > > CPANPLUS probably does the best it can, but sometimes > won't proceed to install the module because of some > minor test failure,. So I have to produce a patch to > disable a test or work-around the problem, which I > currently do for > perldap-1.4.tar.gz.diff > SOAP-WSDL-2.00.10.tar.gz.diff > XML-Twig-3.35.tar.gz.diff
You can use "cpanp −i −−skiptest Text::Aligner" to install a module with failing tests. Show quoted text
> Since 0.07 is not currently on CPAN, so can you please > either send me the diff or point me to a site I can > fetch it ?
It will be available within 24 hours, usually. Regards, Anno
Subject: Re: [rt.cpan.org #61276] 10_Aligner.t test 101 requires colorstrip ?
Date: Sun, 12 Sep 2010 17:09:14 +1000
To: "bug-Text-Aligner [...] rt.cpan.org" <bug-Text-Aligner [...] rt.cpan.org>
From: Danny Thomas <d.thomas [...] its.uq.edu.au>
Download (untitled) / with headers
text/plain 1.2k
On 12/09/2010, at 11:41 AM, Anno Siegel via RT wrote: Show quoted text
> It will be available within 24 hours, usually.
It was a lot quicker than that (including appearing in the CPAN index, then again Net::Patricia disappeared from it for no apparent reason). Unfortunately for me it exposed another issue. I'm building against 5.10.1, which isn't that old, and comes with Term::ANSIColor 2.00. Yet Text::Aligner wants 2.01+. Was there a reason for that ? AAFAICT there won't be a 5.10.2, but I'm worried our legacy code. and/or modules suitable for some of the old RHEL5 libraries, will have some issues with 5.12+. Danny PS a similar issue previously noted Module::Build =============================== Seems to create a pre-requisite for a recent version of itself when building a distribution, e.g. Test::Exception 0.29 META.yml configure_requires: Module::Build: 0.35 generated_by: Module::Build version 0.35 Now I'm building against 5.10.1 which now includes Module::Build as a core module, but only version 0.340201. Is it really the case that Test::Exception 0.29 can't be installed by that version of Module::Build ? There were other distributions like that, so I ended up installing the latest Module::Build over the core one.
Subject: Re: [rt.cpan.org #61276] 10_Aligner.t test 101 requires colorstrip ?
Date: Sun, 12 Sep 2010 17:15:21 +0200
To: bug-Text-Aligner [...] rt.cpan.org
From: Anno Siegel <anno5 [...] mac.com>
Download (untitled) / with headers
text/plain 1.1k
On 12.09.2010, at 09:09, d.thomas@its.uq.edu.au via RT wrote: Show quoted text
> Queue: Text-Aligner > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=61276 > > > > On 12/09/2010, at 11:41 AM, Anno Siegel via RT wrote:
[...] Show quoted text
> Unfortunately for me it exposed another issue. > I'm building against 5.10.1, which isn't that old, > and comes with Term::ANSIColor 2.00. > Yet Text::Aligner wants 2.01+. > > Was there a reason for that ?
Yes, that's intentional. As of v0.06, Text::Aligner can align strings with embeded color control sequences. It uses Term::ANSIColor::colorstrip for that which isn't available before 2.01. Show quoted text
> AAFAICT there won't be a 5.10.2, but I'm worried our > legacy code. and/or modules suitable for some of the > old RHEL5 libraries, will have some issues with 5.12+.
You don't have to install 5.12 to use Term::ANSColor 2.01. In fact Txt::Aligner should have updated Term::ANSIColor to v2.01 during prereq processing. Didn't it do that? Show quoted text
> > Danny
Show quoted text
> > PS a similar issue previously noted > > Module::Build
[snip] I am not particularly acquainted with Module::Build and/or Text::Exception. Can't help you with that, sorry. Anno
Resolving as fixed per the discussion.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.