This queue is for tickets about the App-EUMM-Upgrade CPAN distribution.

Report information
The Basics
Id:
60743
Status:
open
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
dolmen [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
0.22
Fixed in:
(no value)



Subject: Version is outdated in eumm-upgrade.pl
In release 0.22 the version number has not been upgraded in the eumm-upgrade.pl code: the $compat_layer still says the upgrade has been done by 0.21. The $VERSION should instead be extracted from the App::EUMM::Upgrade module. Either dynamically or at distribution build time. -- Olivier Mengué - http://search.cpan.org/~dolmen/ http://github.com/dolmen/
On 2010-08-25 16:21:05, DOLMEN wrote:
Show quoted text
> In release 0.22 the version number has not been upgraded in the > eumm-upgrade.pl code: the $compat_layer still says the upgrade has been > done by 0.21. > > The $VERSION should instead be extracted from the App::EUMM::Upgrade > module. Either dynamically or at distribution build time.
This problem still exists -- the latest version is 0.24, but Makefile.PL is altered to say: #Compatibility code for old versions of EU::MM. Written by Alexandr Ciornii, version 0.23. Added by eumm-upgrade.
RT-Send-CC: ether@cpan.org
I'll just use different version scheme, currently it will be version 2. On Fri Dec 04 15:15:35 2015, ETHER wrote:
Show quoted text
> On 2010-08-25 16:21:05, DOLMEN wrote:
> > In release 0.22 the version number has not been upgraded in the > > eumm-upgrade.pl code: the $compat_layer still says the upgrade has > > been > > done by 0.21. > > > > The $VERSION should instead be extracted from the App::EUMM::Upgrade > > module. Either dynamically or at distribution build time.
> > This problem still exists -- the latest version is 0.24, but > Makefile.PL is altered to say: > #Compatibility code for old versions of EU::MM. Written by Alexandr > Ciornii, version 0.23. Added by eumm-upgrade.
-- Alexandr Ciornii, http://chorny.net


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.