Skip Menu |
 

This queue is for tickets about the Rose-DateTime CPAN distribution.

Report information
The Basics
Id: 60672
Status: resolved
Priority: 0/
Queue: Rose-DateTime

People
Owner: Nobody in particular
Requestors: justin [...] hawkins.id.au
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Missing dependency on DateTime::Locale
Date: Tue, 24 Aug 2010 16:04:09 +0930
To: bug-Rose-DateTime [...] rt.cpan.org
From: Justin Hawkins <justin [...] hawkins.id.au>
Download (untitled) / with headers
text/plain 249b
Hi John, It looks like there is a missing dependency in Rose::DateTime: http://pastebin.com/5h86K9WH (Found when helping a friend with a Rose::DB install on an virgin perl machine :-) Cheers, Justin -- Justin Hawkins justin@hawkins.id.au
Download smime.p7s
application/pkcs7-signature 3.8k

Message body not shown because it is not plain text.

Download (untitled) / with headers
text/plain 416b
Rose::DateTime requires DateTime, and DateTime requires DateTime::Locale, so everything should work. I think the problem might have something to do with line 35 of your pastbin information: "Could not read '/root/.cpan/build/Rose-DateTime-0.534-Ig34Xf/META.yml'. Falling back to other methods to determine prerequisites" Did you have DateTime::Locale installed at all when this test ran? If so, what version?
Subject: Re: [rt.cpan.org #60672] Missing dependency on DateTime::Locale
Date: Tue, 24 Aug 2010 22:36:34 +0930
To: bug-Rose-DateTime [...] rt.cpan.org
From: Justin Hawkins <justin [...] hawkins.id.au>
Download (untitled) / with headers
text/plain 957b
On 24/08/2010, at 10:26 PM, John Siracusa via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=60672 > > > Rose::DateTime requires DateTime, and DateTime requires DateTime::Locale, so everything > should work. I think the problem might have something to do with line 35 of your pastbin > information: > > "Could not read '/root/.cpan/build/Rose-DateTime-0.534-Ig34Xf/META.yml'. Falling back to > other methods to determine prerequisites" > > Did you have DateTime::Locale installed at all when this test ran? If so, what version? >
Hmm to be honest I'm not sure, I was helping a perl newbie get some modules installed and I don't have any access to the machine. It is even possible that he said 'No' to a previous pre-req, or had some other problem. I just tried duplicating the problem on a blank ubuntu install and couldn't... I apologise for leading you astray! Regards, Justin -- Justin Hawkins justin@hawkins.id.au


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.