This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id:
60435
Status:
open
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
djerius [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Critical
Broken in:
1.00
Fixed in:
(no value)



Subject: Bundled modules are not installed
In an unwrapped distribution, bundled modules are now (relative to 0.95) being built in their individual bundled directories (i.e. inc/BUNDLES/MODULE) rather than in the top level directory (as MODULE). The resultant files are now stored in inc/BUNDLES/blib rather than in blib. This causes a problem during "make install". inc/BUNDLES/blib is ignored and none of the bundled modules are installed. I'm using Perl 5.10.0 (as shipped with Debian Lenny). I see this problem with ExtUtils::MakeMaker versions 6.42 (as shipped with Lenny) and 6.56. Diab
I've come up with a work around by explicitly defining the INST_* variables in Makefile.PL; see the attached file. Rather kludgy! Diab
Subject: Makefile.PL
use inc::Module::Install; [ various standard stuff goes here ] use Cwd; use File::Spec::Functions qw[ catdir ]; my $cwd = getcwd; makemaker_args( INST_ARCHLIB => catdir( $cwd, qw[ blib arch] ), INST_LIB => catdir( $cwd, qw[ blib lib] ), INST_BIN => catdir( $cwd, qw[ blib bin] ), INST_SCRIPT => catdir( $cwd, qw[ blib script] ), INST_MAN1DIR => catdir( $cwd, qw[ blib man1] ), INST_MAN3DIR => catdir( $cwd, qw[ blib man3] ), ); WriteAll;


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.