Skip Menu |
 

This queue is for tickets about the SOAP-WSDL CPAN distribution.

Report information
The Basics
Id: 60381
Status: open
Priority: 0/
Queue: SOAP-WSDL

People
Owner: Nobody in particular
Requestors: mschwern [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in:
  • 2.00.10
  • 2.00.99_3
Fixed in: (no value)



Subject: Makefile.PL does not work
Download (untitled) / with headers
text/plain 943b
The Makefile.PL shipped with SOAP::WSDL does not work because Module::Build::Compat does not understand three argument versions. $ perl Makefile.PL # running Build.PL Checking prerequisites... requires: ! Class::Std::Fast is not installed build_requires: ! Class::Std::Fast is not installed ERRORS/WARNINGS FOUND IN PREREQUISITES. You may wish to install the versions of the modules indicated above before proceeding with this installation Creating new 'MYMETA.yml' with configuration results Creating new 'Build' script for 'SOAP-WSDL' version '2.00.10' Prereq '0.0.5' for 'Class::Std::Fast' is not supported by Module::Build::Compat Either the Makefile.PL should be removed, most everything understands Build.PL now, or the dependency specified in the equivalent decimal version (0.000005). See http://stackoverflow.com/questions/3489642/dependency-problem-of-perl-cpan-modules for an example of the confusion it causes.
From: Mark
Download (untitled) / with headers
text/plain 2.3k
Same problem here. Perl 5.12.2 on x86_64. Summary of my perl5 (revision 5 version 12 subversion 2) configuration: Platform: osname=linux, osvers=2.6.32-25-generic, archname=x86_64-linux-thread-multi uname='linux hp6730b 2.6.32-25-generic #44-ubuntu smp fri sep 17 20:05:27 utc 2010 x86_64 gnulinux ' config_args='-Dusethreads -Dinc_version_list=none -Dprefix=/home/perl/5.12.2 -d' hint=recommended, useposix=true, d_sigaction=define useithreads=define, usemultiplicity=define useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef use64bitint=define, use64bitall=define, uselongdouble=undef usemymalloc=n, bincompat5005=undef Compiler: cc='cc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64', optimize='-O2', cppflags='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include' ccversion='', gccversion='4.4.3', gccosandvers='' intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678 d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16 ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8 alignbytes=8, prototype=define Linker and Libraries: ld='cc', ldflags =' -fstack-protector -L/usr/local/lib' libpth=/usr/local/lib /lib /usr/lib /lib64 /usr/lib64 libs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc perllibs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc libc=/lib/libc-2.11.1.so, so=so, useshrplib=false, libperl=libperl.a gnulibc_version='2.11.1' Dynamic Linking: dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E' cccdlflags='-fPIC', lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector' Characteristics of this binary (from libperl): Compile-time options: MULTIPLICITY PERL_DONT_CREATE_GVSV PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP USE_64_BIT_ALL USE_64_BIT_INT USE_ITHREADS USE_LARGE_FILES USE_PERLIO USE_PERL_ATOF USE_REENTRANT_API Built under linux Compiled at Sep 28 2010 13:04:18 @INC: /home/perl/5.12.2/lib/site_perl/5.12.2/x86_64-linux-thread-multi /home/perl/5.12.2/lib/site_perl/5.12.2 /home/perl/5.12.2/lib/5.12.2/x86_64-linux-thread-multi /home/perl/5.12.2/lib/5.12.2 .
From: Mark
more information, better formatting.
Subject: soap-wsdl-inst-err.txt

Message body is not shown because it is too large.

From: Mark
workaround: in cpanp do: z SOAP::WSDL rm Makefile.PL exit i SOAP::WSDL
Download (untitled) / with headers
text/plain 1.4k
On Sun Aug 15 22:52:42 2010, MSCHWERN wrote: Show quoted text
> The Makefile.PL shipped with SOAP::WSDL does not work because > Module::Build::Compat does not understand three argument versions. > > $ perl Makefile.PL > # running Build.PL > Checking prerequisites... > requires: > ! Class::Std::Fast is not installed > build_requires: > ! Class::Std::Fast is not installed > > ERRORS/WARNINGS FOUND IN PREREQUISITES. You may wish to install the > versions > of the modules indicated above before proceeding with this > installation > > Creating new 'MYMETA.yml' with configuration results > Creating new 'Build' script for 'SOAP-WSDL' version '2.00.10' > Prereq '0.0.5' for 'Class::Std::Fast' is not supported by > Module::Build::Compat > > Either the Makefile.PL should be removed, most everything understands > Build.PL now, or the dependency specified in the equivalent decimal > version (0.000005). See > http://stackoverflow.com/questions/3489642/dependency-problem-of-perl- > cpan-modules > for an example of the confusion it causes.
I just uploaded SOAP-WSDL-3.00.0_1.tar.gz to PAUSE. The CPAN admins were kind enough to grant me co-maint on this module. That's a devel release, so you have to go to http://search.cpan.org/~swalters/ to find it. I switched from Module::Build to MakeMaker, so this particular problem shouldn't occur any more, though other problems might. Testing feedback would be appreciated. If I don't hear anything, I'll close this ticket. Thanks!
Download (untitled) / with headers
text/plain 121b
This ticket needs to be closed as the issue is no longer present. -- Cheers, ZZ [ https://metacpan.org/author/ZOFFIX ]


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.